summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBakasura2021-12-23 14:44:03 -0500
committerBakasura2021-12-23 14:44:03 -0500
commit169a464195530915e4abee850a1bf4b5d86590d5 (patch)
tree090d254dd79bc2f09b8b12548e44db9391030f3d
parent34eb0a65ce6fca449ba01335fc74a712cc75d309 (diff)
downloadaur-169a464195530915e4abee850a1bf4b5d86590d5.tar.gz
Update to version r1183
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
-rw-r--r--disable-debian.patch43
3 files changed, 16 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c671558df6d..4bd056b633c9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = cbftp-svn
pkgdesc = an advanced multi-purpose FTP/FXP client that focuses on efficient large-scale data spreading, while also supporting most regular FTP/FXP use cases in a modern way. It runs in a terminal and provides a semi-graphical user interface through ncurses.
- pkgver = r1015
+ pkgver = r1183
pkgrel = 1
url = https://cbftp.eu
arch = x86_64
@@ -16,7 +16,6 @@ pkgbase = cbftp-svn
source = svn+https://cbftp.eu/svn/cbftp/
source = disable-debian.patch
sha256sums = SKIP
- sha256sums = 50d12919d89186921cfe89d434a96c896ccd05a5eb466716a72e1ff47d5f0b0c
+ sha256sums = 77bbedb52617cc34edc49e6d93075c092b333fdb17c4b554f431e7057a90fcd8
pkgname = cbftp-svn
-
diff --git a/PKGBUILD b/PKGBUILD
index aea0019a5a96..69ba072914f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bakasura <bakasura@protonmail.ch>
pkgname=cbftp-svn
-pkgver=r1015
+pkgver=r1183
pkgrel=1
pkgdesc='an advanced multi-purpose FTP/FXP client that focuses on efficient large-scale data spreading, while also supporting most regular FTP/FXP use cases in a modern way. It runs in a terminal and provides a semi-graphical user interface through ncurses.'
arch=('x86_64')
@@ -16,7 +16,7 @@ license=('MIT')
_srcname=cbftp
source=("svn+https://cbftp.eu/svn/cbftp/" "disable-debian.patch")
sha256sums=('SKIP'
- '50d12919d89186921cfe89d434a96c896ccd05a5eb466716a72e1ff47d5f0b0c')
+ '77bbedb52617cc34edc49e6d93075c092b333fdb17c4b554f431e7057a90fcd8')
pkgver() {
cd "$_srcname"
@@ -31,7 +31,7 @@ build() {
prepare() {
cd "$_srcname"
- patch --forward --strip=1 --input="${srcdir}/disable-debian.patch"
+ patch -Np0 -i "${srcdir}/disable-debian.patch"
}
package() {
diff --git a/disable-debian.patch b/disable-debian.patch
index 0d9424a49d7a..518f2835a5b1 100644
--- a/disable-debian.patch
+++ b/disable-debian.patch
@@ -1,32 +1,11 @@
-diff -cr cbftp-r1011.o/Makefile.inc cbftp-r1011/Makefile.inc
-*** cbftp-r1011.o/Makefile.inc 2019-03-17 04:15:01.000000000 -0500
---- cbftp-r1011/Makefile.inc 2019-03-31 21:46:53.009762000 -0500
-***************
-*** 38,42 ****
- ifeq ($(UNAME_S),Darwin)
- LINKFLAGS+=-lncurses
- else
-! LINKFLAGS+=-lncursesw
- endif
---- 38,42 ----
- ifeq ($(UNAME_S),Darwin)
- LINKFLAGS+=-lncurses
- else
-! LINKFLAGS+=-lncurses
- endif
-diff -cr cbftp-r1011.o/src/ui/ncurseswrap.h cbftp-r1011/src/ui/ncurseswrap.h
-*** cbftp-r1011.o/src/ui/ncurseswrap.h 2019-03-17 04:15:01.000000000 -0500
---- cbftp-r1011/src/ui/ncurseswrap.h 2019-03-31 22:05:16.467017954 -0500
-***************
-*** 4,8 ****
- #ifdef __APPLE__
- #include <ncurses.h>
- #else
-! #include <ncursesw/curses.h>
- #endif
---- 4,8 ----
- #ifdef __APPLE__
- #include <ncurses.h>
- #else
-! #include <ncurses.h>
- #endif
+--- src/ui/ncurseswrap.h 2021-12-23 14:30:57.292928343 -0500
++++ src/ui/ncurseswrap.h 2021-12-23 14:35:43.500147277 -0500
+@@ -2,7 +2,7 @@
+ #define _XOPEN_SOURCE_EXTENDED
+ #endif
+ #ifndef NO_NCURSESW
+-#include <ncursesw/curses.h>
++#include <ncurses.h>
+ #else
+ #include <ncurses.h>
+ #endif