summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2021-11-26 18:37:40 -0500
committerCarlos Aznarán Laos2021-11-26 18:37:40 -0500
commit16a7b53e96f1b68aac4f48f7de56835268c66709 (patch)
tree23163e3fee86071c38a7e56334f7b2eb9969e655
parent597d652dc70b164294db3b6092d8df445053e167 (diff)
downloadaur-16a7b53e96f1b68aac4f48f7de56835268c66709.tar.gz
Add python-pyparsing dependency
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD37
3 files changed, 30 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index febc13e9a37b..be71a19cfc35 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-snuggs
pkgdesc = Snuggs are s-expressions for Numpy
pkgver = 1.4.7
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/mapbox/snuggs
arch = any
license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-hypothesis
makedepends = python-setuptools
- depends = python
- source = https://files.pythonhosted.org/packages/source/s/snuggs/snuggs-1.4.7.tar.gz
- sha256sums = 501cf113fe3892e14e2fee76da5cd0606b7e149c411c271898e6259ebde2617b
+ depends = python-numpy
+ depends = python-pyparsing
+ source = snuggs-1.4.7::https://github.com/mapbox/snuggs/archive/1.4.7.tar.gz
+ sha512sums = c1f40e521d1b0cf15075b22b04000c74ecbd0522cdd820b8c159aac812924d877349b3f3bca93b09eed5b025a34c26665a41c7a52a8145419558b115cf8ef361
pkgname = python-snuggs
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 270ca54c7ab7..70b310010517 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,31 @@
-# Maintainer: Simon Legner <Simon.Legner@gmail.com>
-pkgname=python-snuggs
-_module='snuggs'
+# Maintainer: Carlos Aznarán <caznaranl@uni.pe>
+# Contributor: Simon Legner <Simon.Legner@gmail.com>
+_base=snuggs
+pkgname=python-${_base}
pkgver=1.4.7
-pkgrel=1
+pkgrel=2
pkgdesc="Snuggs are s-expressions for Numpy"
-url="https://github.com/mapbox/snuggs"
-depends=('python')
-makedepends=('python-setuptools')
-license=('MIT')
+url="https://github.com/mapbox/${_base}"
+license=(MIT)
arch=('any')
-source=("https://files.pythonhosted.org/packages/source/s/$_module/$_module-$pkgver.tar.gz")
+depends=(python-numpy python-pyparsing)
+makedepends=(python-setuptools)
+checkdepends=(python-pytest python-hypothesis)
+source=(${_base}-${pkgver}::${url}/archive/${pkgver}.tar.gz)
+sha512sums=('c1f40e521d1b0cf15075b22b04000c74ecbd0522cdd820b8c159aac812924d877349b3f3bca93b09eed5b025a34c26665a41c7a52a8145419558b115cf8ef361')
build() {
- cd "$srcdir/$_module-$pkgver"
- python setup.py build
+ cd "${_base}-${pkgver}"
+ python setup.py build
}
-package() {
- cd "$srcdir/$_module-$pkgver"
- python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+check() {
+ cd "${_base}-${pkgver}"
+ python -m pytest
}
-sha256sums=('501cf113fe3892e14e2fee76da5cd0606b7e149c411c271898e6259ebde2617b')
+package() {
+ cd "${_base}-${pkgver}"
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}