summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorchristian2015-07-01 15:28:48 +0200
committerchristian2015-07-01 15:28:48 +0200
commit16b72bb2a52c4f3b20dd36c9cab7f38950a2a3d4 (patch)
treef2ffe0fe7812cf4e20c7c0080ddf0fd48f65807c
parentd290d2c4035ff78596ef52f5123e3b3cd6cdff51 (diff)
downloadaur-16b72bb2a52c4f3b20dd36c9cab7f38950a2a3d4.tar.gz
added path from hashbang
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD3
-rw-r--r--proposal.patch22
3 files changed, 25 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef0899324b33..83c91c442518 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = brightd
pkgdesc = Automatically dims screen when there is no user input (like a macbook :-).
pkgver = 0.4.1
- pkgrel = 3
+ pkgrel = 4
url = http://www.pberndt.com/Programme/Linux/brightd/
install = brightd.install
arch = i686
diff --git a/PKGBUILD b/PKGBUILD
index 267210587511..d0776955dd09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,10 +1,11 @@
+# Contributor: csllbr
# Contributor: Cheer Xiao <xiaqqaix AT gmail DOT com>
# Contributor: Leo Scherer <aur AT leo-scherer DOT de>
# original Contributor: Niklas Schmuecker (IRC: nisc) <nschmuecker (gmail)>
pkgname=brightd
pkgver=0.4.1
-pkgrel=3
+pkgrel=4
pkgdesc='Automatically dims screen when there is no user input (like a macbook :-).'
arch=('i686' 'x86_64')
license=('GPL2')
diff --git a/proposal.patch b/proposal.patch
index 31797a99ae3a..a5ba49ed9d64 100644
--- a/proposal.patch
+++ b/proposal.patch
@@ -53,3 +53,25 @@
info("Would fade, but on AC");
alarm(waitSeconds);
return;
+
+
+--- a/brightd.c 2015-06-30 23:20:50.636205206 +0000
++++ b/brightd.c 2015-06-30 23:34:15.452916469 +0000
+@@ -121,7 +121,7 @@
+ /*
+ * Write an debug message to the console
+ */
+-inline void info(char *str) { /*{{{*/
++void info(char *str) { /*{{{*/
+ if(verbose == 1 && daemonize == 0) {
+ printf("%s\n", str);
+ }
+@@ -307,7 +307,7 @@
+ /*
+ * Event source filter
+ */
+-inline char isEventFileValid(char *file) { /* {{{ */
++char isEventFileValid(char *file) { /* {{{ */
+ if(*((char*)&eventSourceFilter) == 0) {
+ return 1;
+ }