summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBioArchLinuxBot2023-12-03 18:01:33 +0000
committerBioArchLinuxBot2023-12-03 18:01:33 +0000
commit16be77530817d8b2dccb30e94df4cb8bc4483e9f (patch)
treeae24fcb2d4b480c7fab62048638b7104aeb2ceea
parente25627e1a24d9edd87faea1f2e019af64f42dcfc (diff)
downloadaur-16be77530817d8b2dccb30e94df4cb8bc4483e9f.tar.gz
[lilac] updated to 3.99.0.16-2
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD58
-rw-r--r--fix-build.patch24
3 files changed, 74 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4995e620befd..d5e680fcb291 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,19 @@
pkgbase = r-xml
- pkgdesc = An ODBC database interface
+ pkgdesc = Tools for Parsing and Generating XML Within R and S-Plus
pkgver = 3.99.0.16
- pkgrel = 1
+ pkgrel = 2
url = https://cran.r-project.org/package=XML
- arch = any
- license = GPL2
- license = GPL3
+ arch = x86_64
+ license = BSD
depends = libxml2
depends = r
+ optdepends = r-bitops
+ optdepends = r-rcurl
source = https://cran.r-project.org/src/contrib/XML_3.99-0.16.tar.gz
+ source = fix-build.patch
md5sums = afa1fd1496595b5aa4f6cb758bad0122
+ md5sums = fe644b51ff4b55a2b594a6c7dda5bc25
+ sha256sums = 350d37bab99ba3dac03313fa3901cc053ab2d962a94a9c3404fb3ad0a91cc95b
+ sha256sums = 5fd93db9dbd4100d4db55714c62340b025d0a871eaf61bffe145fb743e5d26da
pkgname = r-xml
diff --git a/PKGBUILD b/PKGBUILD
index a1c867e82fd4..833dd3c3137a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,47 @@
-_cranname=XML
-_cranver=3.99-0.16
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
-pkgdesc="An ODBC database interface"
-arch=(any)
-depends=("libxml2" "r")
-url="https://cran.r-project.org/package=${_cranname}"
-license=(GPL2 GPL3)
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
-md5sums=('afa1fd1496595b5aa4f6cb758bad0122')
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
+# Contributor: Alex Branham <branham@utexas.edu>
+# Contributor: fordprefect <fordprefect@dukun.de>
+# Contributor: Nick B <Shirakawasuna at gmail _dot_com>
-build() {
- cd "${srcdir}"
+_pkgname=XML
+_pkgver=3.99-0.16
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//-/.}
+pkgrel=2
+pkgdesc="Tools for Parsing and Generating XML Within R and S-Plus"
+arch=(x86_64)
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(BSD)
+depends=(
+ libxml2
+ r
+)
+optdepends=(
+ r-bitops
+ r-rcurl
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz"
+ "fix-build.patch")
+md5sums=('afa1fd1496595b5aa4f6cb758bad0122'
+ 'fe644b51ff4b55a2b594a6c7dda5bc25')
+sha256sums=('350d37bab99ba3dac03313fa3901cc053ab2d962a94a9c3404fb3ad0a91cc95b'
+ '5fd93db9dbd4100d4db55714c62340b025d0a871eaf61bffe145fb743e5d26da')
+
+prepare() {
+ # fix build
+ patch -Np1 -i fix-build.patch
+}
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l ${srcdir}
+build() {
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- cd "${srcdir}"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
- install -dm0755 "${pkgdir}/usr/lib/R/library"
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/share/licenses/$pkgname"
+ ln -s "/usr/lib/R/library/$_pkgname/LICENSE" "$pkgdir/usr/share/licenses/$pkgname"
}
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..24e2b94038b0
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,24 @@
+diff --git a/XML/src/HTMLParse.c b/XML/src/HTMLParse.c
+index 8d71f9f..7dea289 100644
+--- a/XML/src/HTMLParse.c
++++ b/XML/src/HTMLParse.c
+@@ -11,6 +11,7 @@
+
+ #include "libxml/HTMLparser.h"
+ #include "libxml/HTMLtree.h"
++#include "libxml/xmlsave.h"
+
+ #include <sys/stat.h>
+ #include <unistd.h>
+diff --git a/XML/src/XMLTree.c b/XML/src/XMLTree.c
+index 6047de0..c28d5d0 100644
+--- a/XML/src/XMLTree.c
++++ b/XML/src/XMLTree.c
+@@ -35,6 +35,7 @@
+ #include <libxml/HTMLtree.h>
+ #endif
+
++#include <libxml/xmlsave.h>
+
+ #define R_USE_XML_ENCODING 1
+ #include "Utils.h" /* R_createXMLNodeRef, Encoding macros. */