summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebRmv2015-06-07 08:42:11 +0200
committerSebRmv2015-06-07 08:42:11 +0200
commit16c1483759d1cf780ff3a206544e9e92ec6241cc (patch)
tree2584b74409e1ae48a10ed48203c7195b384158ed
downloadaur-16c1483759d1cf780ff3a206544e9e92ec6241cc.tar.gz
Initial import.
-rw-r--r--.SRCINFO21
-rw-r--r--Makefile9
-rw-r--r--PKGBUILD27
-rw-r--r--binfmt_aout.install12
4 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b122cad7983c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by makepkg 4.2.1
+# Sat Mar 21 16:07:20 UTC 2015
+pkgbase = binfmt_aout
+ pkgdesc = binfmt_aout kernel module, for running an a.out binary format
+ pkgver = 3.19
+ pkgrel = 1
+ url = https://www.kernel.org
+ install = binfmt_aout.install
+ arch = i686
+ license = GPLv3
+ makedepends = linux-headers
+ makedepends = linux-api-headers
+ makedepends = gzip
+ options = !strip
+ source = https://raw.githubusercontent.com/torvalds/linux/v{3.19}/fs/binfmt_aout.c
+ source = Makefile
+ sha1sums = 461efd1c09b0b2420c1544ba5ec94952ecef4255
+ sha1sums = 24969cd0bfe0eba16b15a714839891615001842f
+
+pkgname = binfmt_aout
+
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..8e17a99c514e
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,9 @@
+obj-m := binfmt_aout.o
+KDIR := /lib/modules/$(shell uname -r)/build
+PWD := $(shell pwd)
+
+default:
+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules
+
+install:
+ $(MAKE) -C $(KDIR) SUBDIRS=$(PWD) modules_install
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9dc8d974d27f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Elbarto
+pkgname=binfmt_aout
+pkgver=3.19
+pkgrel=1
+pkgdesc='binfmt_aout kernel module, for running an a.out binary format'
+arch=('i686')
+makedepends=('linux-headers' 'linux-api-headers' 'gzip')
+url="https://www.kernel.org"
+license=("GPLv3")
+options=('!strip')
+source=("https://raw.githubusercontent.com/torvalds/linux/v{$pkgver}/fs/binfmt_aout.c"
+ "Makefile")
+sha1sums=('461efd1c09b0b2420c1544ba5ec94952ecef4255'
+ '24969cd0bfe0eba16b15a714839891615001842f')
+install=binfmt_aout.install
+
+build(){
+cd "$srcdir"
+ make
+}
+
+package() {
+ cd "$srcdir"
+ mkdir -p "${pkgdir}"/lib/modules
+ make install INSTALL_MOD_PATH="${pkgdir}"
+# gzip "${pkgdir}/lib/modules/`uname -r`/extra/binfmt_aout.ko"
+}
diff --git a/binfmt_aout.install b/binfmt_aout.install
new file mode 100644
index 000000000000..95266cb60b62
--- /dev/null
+++ b/binfmt_aout.install
@@ -0,0 +1,12 @@
+post_install() {
+ depmod -a
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}
+