summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNichlas Severinsen2022-11-21 22:36:37 +0100
committerNichlas Severinsen2022-11-21 22:36:37 +0100
commit16c389a11a040560fe70a8d280375cc5bdf7385e (patch)
tree6f457ff0a15f595c45c4c2ef6838292adb1ce374
parent50ba60b13ef77c03a2eead334985c1c77aeb63b8 (diff)
downloadaur-16c389a11a040560fe70a8d280375cc5bdf7385e.tar.gz
Update to v2.2.0
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD58
-rw-r--r--patch_addLLVM.patch19
-rw-r--r--patch_fix_build_dir.patch11
4 files changed, 48 insertions, 73 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e538ef6eb184..0a66942fb02f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,26 @@
pkgbase = tor-shadow
- pkgdesc = an open-source network simulator/emulator hybrid (e.g. for Tor and Bitcoin)
- pkgver = 1.11.2
+ pkgdesc = An open-source network simulator/emulator hybrid (e.g. for Tor and Bitcoin)
+ pkgver = 2.2.0
pkgrel = 1
url = https://shadow.github.io/
- arch = i686
- arch = x86_64
+ arch = any
license = custom
- makedepends = llvm>=3.2
- makedepends = cmake>=2.8.8
- depends = igraph>=0.5.4
+ makedepends = gcc
+ makedepends = cmake>=3.2
+ makedepends = make
+ makedepends = cargo
+ makedepends = pkgconf
+ makedepends = xz
+ makedepends = util-linux
depends = glib2>=2.32.0
- source = https://github.com/shadow/shadow/archive/v1.11.2.tar.gz
- source = patch_addLLVM.patch
- source = patch_fix_build_dir.patch
- md5sums = 72a65ce92c311117fa80f9309824dfe3
- md5sums = ad343433a279cc78a54f6eecffb92b36
- md5sums = bc3c5e1e79c0fcf8600a30e2cb8e0fe0
+ depends = python>=3.6
+ optdepends = python-numpy
+ optdepends = python-lxml
+ optdepends = python-matplotlib
+ optdepends = python-networkx
+ optdepends = python-scipy
+ optdepends = python-yaml
+ source = https://github.com/shadow/shadow/archive/v2.2.0.tar.gz
+ sha256sums = 707e27c4b1181849ebaa0ab052de0932713d0af26a1f3c682e47d5abfeffaf25
pkgname = tor-shadow
-
diff --git a/PKGBUILD b/PKGBUILD
index 9fc6b9b9fbea..8e74813a6811 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,42 @@
-# Maintainer: Max Beikirch <max.beikirch (at) unitybox (dot) de>
+# Maintainer: necklace <ns@nsz.no>
+# Contributor: Max Beikirch <max.beikirch (at) unitybox (dot) de>
+
pkgname=tor-shadow
-pkgver=1.11.2
+pkgver=2.2.0
pkgrel=1
-pkgdesc="an open-source network simulator/emulator hybrid (e.g. for Tor and Bitcoin)"
-arch=('i686' 'x86_64')
+pkgdesc="An open-source network simulator/emulator hybrid (e.g. for Tor and Bitcoin)"
+arch=('any')
url="https://shadow.github.io/"
license=('custom')
-depends=('igraph>=0.5.4' 'glib2>=2.32.0')
-makedepends=('llvm>=3.2' 'cmake>=2.8.8')
-source=("https://github.com/shadow/shadow/archive/v$pkgver.tar.gz"
- "patch_addLLVM.patch"
- "patch_fix_build_dir.patch")
-md5sums=('72a65ce92c311117fa80f9309824dfe3'
- 'ad343433a279cc78a54f6eecffb92b36'
- 'bc3c5e1e79c0fcf8600a30e2cb8e0fe0')
+depends=('glib2>=2.32.0' 'python>=3.6')
+makedepends=('gcc' 'cmake>=3.2' 'make' 'cargo' 'pkgconf' 'xz' 'util-linux' )
+optdepends=('python-numpy' 'python-lxml' 'python-matplotlib' 'python-networkx' 'python-scipy' 'python-yaml')
+source=("https://github.com/shadow/shadow/archive/v$pkgver.tar.gz")
+sha256sums=("707e27c4b1181849ebaa0ab052de0932713d0af26a1f3c682e47d5abfeffaf25")
-prepare() {
- cd "shadow-$pkgver"
- patch -p1 -i "$srcdir/patch_addLLVM.patch"
- patch -p1 -i "$srcdir/patch_fix_build_dir.patch"
- mkdir -p build
-}
+# TODO
+# Maybe there should be a prepare() that checks various system variables to make sure they are in accordance with:
+# https://github.com/shadow/shadow/blob/0171ea8282e19bc439add4ad952bf75a98444627/docs/system_configuration.md
build() {
- cd "shadow-$pkgver"
- python2 setup build --include /usr/lib/cmake/llvm --prefix "/usr"
- cd build
- cmake -DCMAKE_SKIP_INSTALL_RPATH=ON ..
+ mkdir -p "shadow-$pkgver/build"
+ cd "shadow-$pkgver/build"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DSHADOW_TEST=ON \
+ ..
make
}
-package() {
- cd "shadow-$pkgver/build"
- make DESTDIR="${pkgdir}" install
+check() {
+ cd "shadow-$pkgver/build"
+ ctest
+}
- mv "$pkgdir/usr/plugins/libshadow-plugin-tgen.so" "$pkgdir/usr/lib"
- rm -rf "$pkgdir/usr/plugins"
+package() {
+ install -Dm644 "${srcdir}/shadow-${pkgver}/LICENSE" ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
- mkdir -p $pkgdir/usr/share/licenses/$pkgname
- install -Dm644 ../LICENSE $pkgdir/usr/share/licenses/$pkgname/
+ cd "shadow-$pkgver/build"
+ make DESTDIR="${pkgdir}" install
}
diff --git a/patch_addLLVM.patch b/patch_addLLVM.patch
deleted file mode 100644
index 9969533d6ef1..000000000000
--- a/patch_addLLVM.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff -ura shadow-1.11.2.orig/src/plugin/llvm-hoist-pass/CMakeLists.txt shadow-1.11.2.new/src/plugin/llvm-hoist-pass/CMakeLists.txt
---- shadow-1.11.2.orig/src/plugin/llvm-hoist-pass/CMakeLists.txt 2016-09-19 16:29:30.000000000 +0200
-+++ shadow-1.11.2.new/src/plugin/llvm-hoist-pass/CMakeLists.txt 2017-05-06 01:05:46.468807662 +0200
-@@ -23,6 +23,10 @@
- set(LLVM_RUNTIME_OUTPUT_INTDIR ${CMAKE_BINARY_DIR}/${CMAKE_CFG_INTDIR}/bin)
- set(LLVM_LIBRARY_OUTPUT_INTDIR ${CMAKE_BINARY_DIR}/${CMAKE_CFG_INTDIR}/lib)
- set(LLVM_PLUGIN_EXT ".so")
-+
-+cmake_policy(PUSH)
-+# needed by AddLLVM
-+cmake_policy(SET CMP0057 NEW)
- include(AddLLVM)
-
- #message(STATUS "Found components for LLVM")
-@@ -42,3 +46,4 @@
- ## The LLVM plugin to hoist out static and global variables
- ## adds a 'LLVMHoistGlobals' target
- add_llvm_loadable_module(LLVMHoistGlobals HoistGlobals.cpp)
-+cmake_policy(POP)
diff --git a/patch_fix_build_dir.patch b/patch_fix_build_dir.patch
deleted file mode 100644
index 6431a151fd66..000000000000
--- a/patch_fix_build_dir.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -ura shadow-1.11.2.orig/setup shadow-1.11.2.new/setup
---- shadow-1.11.2.orig/setup 2016-09-19 16:29:30.000000000 +0200
-+++ shadow-1.11.2.new/setup 2017-05-06 13:24:41.106253464 +0200
-@@ -126,7 +126,6 @@
-
- # create directories
- if not os.path.exists(builddir): os.makedirs(builddir)
-- if not os.path.exists(installdir): os.makedirs(installdir)
-
- # build up args string for the cmake command
- cmake_cmd = "cmake " + rootdir + " -DCMAKE_INSTALL_PREFIX=" + installdir