summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCedric Girard2017-12-11 17:05:35 +0100
committerCedric Girard2017-12-11 17:05:35 +0100
commit16c6075e4f53d36764c85fbc48ca85695d099359 (patch)
tree8a77531a12c3e12e8fcad7ea0afbe9294f332a11
parentea45b4483b317eeb3b1cc3cedeb4d6d3cc59050d (diff)
downloadaur-16c6075e4f53d36764c85fbc48ca85695d099359.tar.gz
split package python{2,3}
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 35 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24266e64e853..2f59242e812b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,19 +5,20 @@ pkgbase = python2-flask-restplus
url = http://pypi.python.org/pypi/Flask-Restplus/
arch = any
license = BSD
- checkdepends = python2-blinker
- checkdepends = python2-rednose
- checkdepends = python2-nose
- checkdepends = python2-mock
- checkdepends = python2-tzlocal
- makedepends = python2-setuptools
+ source = https://pypi.io/packages/source/f/flask-restplus/flask-restplus-0.10.1.tar.gz
+ sha1sums = d6162efccd7e7c794f435252adcf78a262cfa969
+
+pkgname = python2-flask-restplus
depends = python2-flask>=0.8
depends = python2-six>=1.3.0
depends = python2-jsonschema
depends = python2-pytz
depends = python2-aniso8601>=0.82
- source = https://pypi.io/packages/source/f/flask-restplus/flask-restplus-0.10.1.tar.gz
- sha1sums = d6162efccd7e7c794f435252adcf78a262cfa969
-pkgname = python2-flask-restplus
+pkgname = python-flask-restplus
+ depends = python-flask>=0.8
+ depends = python-six>=1.3.0
+ depends = python-jsonschema
+ depends = python-pytz
+ depends = python-aniso8601>=0.82
diff --git a/PKGBUILD b/PKGBUILD
index 3670e6db1e68..f9dcf216af7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,43 @@
# Maintainer: Cedric Girard <girard.cedric@gmail.com>
-pkgname='python2-flask-restplus'
-pkgver='0.10.1'
-pkgrel='1'
+_pythonmod=flask-restplus
+pkgname=('python2-flask-restplus' 'python-flask-restplus')
+pkgbase='python2-flask-restplus'
+pkgver=0.10.1
+pkgrel=1
pkgdesc='custom actions for flask to help manage your application'
arch=('any')
url='http://pypi.python.org/pypi/Flask-Restplus/'
license=('BSD')
-depends=('python2-flask>=0.8' 'python2-six>=1.3.0' 'python2-jsonschema' 'python2-pytz' 'python2-aniso8601>=0.82')
-checkdepends=('python2-blinker' 'python2-rednose' 'python2-nose' 'python2-mock' 'python2-tzlocal')
-makedepends=('python2-setuptools')
source=("https://pypi.io/packages/source/f/flask-restplus/flask-restplus-${pkgver}.tar.gz")
sha1sums=('d6162efccd7e7c794f435252adcf78a262cfa969')
-build() {
- cd "flask-restplus-${pkgver}"
- python2 ./setup.py build
-}
-
-check() {
- cd "flask-restplus-${pkgver}"
+check_python2-flask-restplus() {
+ checkdepends=('python2-blinker' 'python2-rednose' 'python2-nose' 'python2-mock' 'python2-tzlocal')
+ cd ${srcdir}/${_pythonmod}-$pkgver
python2 ./setup.py test
}
-package() {
- cd "flask-restplus-${pkgver}"
+package_python2-flask-restplus() {
+ depends=('python2-flask>=0.8' 'python2-six>=1.3.0' 'python2-jsonschema' 'python2-pytz' 'python2-aniso8601>=0.82')
+ cd ${srcdir}/${_pythonmod}-$pkgver
python2 ./setup.py install --root="${pkgdir}" --prefix="/usr"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
}
+check_python-flask-restplus() {
+ checkdepends=('python-blinker' 'python-rednose' 'python-nose' 'python-mock' 'python-tzlocal')
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python ./setup.py test
+}
+
+package_python-flask-restplus() {
+ depends=('python-flask>=0.8' 'python-six>=1.3.0' 'python-jsonschema' 'python-pytz' 'python-aniso8601>=0.82')
+ cd ${srcdir}/${_pythonmod}-$pkgver
+ python ./setup.py install --root="${pkgdir}" --prefix="/usr"
+
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}"
+}
+
# vim:set ts=2 sw=2 et: