summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2024-01-12 18:35:23 +0100
committerFabioLolix2024-01-12 18:35:23 +0100
commit16dedc7f447f5002df9480bd14034066f51524de (patch)
treebe3836212a60cfd3c716896b4e214ce24a4f71b7
parentfd9f1f1a514978b3420094c7b0212d3fc286459c (diff)
downloadaur-16dedc7f447f5002df9480bd14034066f51524de.tar.gz
reveal.js dependency + patch
-rw-r--r--.SRCINFO7
-rw-r--r--.gitignore1
-rw-r--r--2-rm-reveal-check.patch13
-rw-r--r--PKGBUILD15
4 files changed, 29 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b7d6edd2b0eb..494fca8e42f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = apostrophe-git
pkgdesc = A distraction free Markdown editor for GNU/Linux made with GTK+
- pkgver = 2.6.3.r142.gb1aee4e
- pkgrel = 1
+ pkgver = 2.6.3.r202.gcc6bef4
+ pkgrel = 2
url = https://world.pages.gitlab.gnome.org/apostrophe
arch = any
license = GPL3
@@ -22,11 +22,14 @@ pkgbase = apostrophe-git
depends = python-regex
depends = python-setuptools
depends = webkitgtk-6.0
+ depends = nodejs-reveal.js
optdepends = texlive-bin: for the pdftex module
optdepends = mathjax: for formula preview
provides = apostrophe
conflicts = apostrophe
source = git+https://gitlab.gnome.org/World/apostrophe.git
+ source = 2-rm-reveal-check.patch
sha256sums = SKIP
+ sha256sums = a3e2eea5fca084f53fd6d0f9e61ace8e14b4c83d9c2f1d5ea74c8589c8c10b8f
pkgname = apostrophe-git
diff --git a/.gitignore b/.gitignore
index 4dab8d6386e3..8e90664e2508 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,3 +5,4 @@
!.gitignore
!PKGBUILD
!.SRCINFO
+!*.patch
diff --git a/2-rm-reveal-check.patch b/2-rm-reveal-check.patch
new file mode 100644
index 000000000000..a040b52ebb1d
--- /dev/null
+++ b/2-rm-reveal-check.patch
@@ -0,0 +1,13 @@
+--- meson.build 2024-01-12 14:18:57.598799803 +0800
++++ meson.build 2024-01-12 14:38:59.351937376 +0800
+@@ -60,9 +60,7 @@
+ #bindir = join_paths(get_option('prefix'), get_option('bindir'))
+ podir = meson.source_root() / 'po'
+
+-if not fs.exists(join_paths(pkgdatadir, 'libs/reveal.js'))
+- error('No valid reveal.js installation found')
+-endif
++
+
+ subdir('data')
+ #subdir('help')
diff --git a/PKGBUILD b/PKGBUILD
index df1d5d5c637b..6cc57542e9c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,27 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Co-Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
+# Contributor: Kimiblock
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=apostrophe-git
-pkgver=2.6.3.r142.gb1aee4e
-pkgrel=1
+pkgver=2.6.3.r202.gcc6bef4
+pkgrel=2
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
url="https://world.pages.gitlab.gnome.org/apostrophe"
license=('GPL3')
depends=('libadwaita' 'otf-fira-mono' 'otf-fira-sans' 'python-cairo'
'python-chardet' 'python-gobject' 'python-levenshtein' 'python-pyenchant'
- 'python-pypandoc' 'python-regex' 'python-setuptools' 'webkitgtk-6.0')
+ 'python-pypandoc' 'python-regex' 'python-setuptools' 'webkitgtk-6.0' 'nodejs-reveal.js')
makedepends=('git' 'meson' 'gobject-introspection' 'sassc')
checkdepends=('appstream-glib')
optdepends=('texlive-bin: for the pdftex module'
'mathjax: for formula preview')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-source=('git+https://gitlab.gnome.org/World/apostrophe.git')
-sha256sums=('SKIP')
+source=('git+https://gitlab.gnome.org/World/apostrophe.git'
+ 2-rm-reveal-check.patch)
+sha256sums=('SKIP'
+ 'a3e2eea5fca084f53fd6d0f9e61ace8e14b4c83d9c2f1d5ea74c8589c8c10b8f')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -36,6 +39,8 @@ prepare() {
# W: hidden-file-or-dir
rm apostrophe/.pylintrc
+
+ patch "${srcdir}/apostrophe/meson.build" < "${srcdir}/2-rm-reveal-check.patch"
}
build() {