summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2015-09-13 22:55:22 +0200
committerSanskritFritz2015-09-13 22:55:22 +0200
commit1712dfbac33e00c801ac094e5052a876c02d5198 (patch)
tree34dcdd108679dbb570ada612722ecb59a1224839
downloadaur-1712dfbac33e00c801ac094e5052a876c02d5198.tar.gz
Initial AUR4 import.
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD44
-rw-r--r--kupfer-git.install13
3 files changed, 89 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..696c07e243a3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = kupfer-git
+ pkgdesc = An interface for quick and convenient access to applications and their documents.
+ pkgver = 2015.09.04
+ pkgrel = 1
+ url = http://engla.github.io/kupfer/
+ install = kupfer-git.install
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = gnome-doc-utils
+ makedepends = docutils
+ makedepends = intltool
+ depends = python2-xdg
+ depends = pygtk
+ depends = python2-dbus
+ depends = python2-gconf
+ depends = python2-keybinder2
+ depends = hicolor-icon-theme
+ depends = desktop-file-utils
+ optdepends = gnome-python-desktop: enables all plugins and gnome integration
+ optdepends = python2-gnomekeyring: gnome keyring integration
+ optdepends = python2-wnck: tracks running applications
+ optdepends = python2-setproctitle: set process name
+ optdepends = python2-gdata: google services
+ optdepends = xautomation: enables the Send Keys plugin
+ provides = kupfer
+ conflicts = kupfer
+ source = git://git.gnome.org/kupfer
+ md5sums = SKIP
+
+pkgname = kupfer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..36bc6db4d382
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Contributor: SpepS <dreamspepser at yahoo dot it>
+# Maintainer: SanskritFritz (gmail)
+
+_name=kupfer
+pkgname=$_name-git
+pkgver=2015.09.04
+pkgrel=1
+pkgdesc="An interface for quick and convenient access to applications and their documents."
+arch=(any)
+url="http://engla.github.io/kupfer/"
+license=('GPL')
+depends=('python2-xdg' 'pygtk' 'python2-dbus' 'python2-gconf' 'python2-keybinder2'
+ 'hicolor-icon-theme' 'desktop-file-utils')
+optdepends=('gnome-python-desktop: enables all plugins and gnome integration'
+ 'python2-gnomekeyring: gnome keyring integration'
+ 'python2-wnck: tracks running applications'
+ 'python2-setproctitle: set process name'
+ 'python2-gdata: google services'
+ 'xautomation: enables the Send Keys plugin')
+makedepends=('git' 'gnome-doc-utils' 'docutils' 'intltool')
+provides=("$_name")
+conflicts=("$_name")
+install="$pkgname.install"
+source=("git://git.gnome.org/$_name")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_name"
+ git log -1 --format="%cd" --date=short | sed 's|-|.|g'
+}
+
+build() {
+ cd "$srcdir/$_name"
+ # python2 fixes
+ export PYTHON=/usr/bin/python2
+
+ python2 waf configure --prefix=/usr --no-update-mime --no-update-icon-cache
+ python2 waf
+}
+
+package() {
+ cd "$srcdir/$_name"
+ python2 waf install -f --destdir="$pkgdir/"
+}
diff --git a/kupfer-git.install b/kupfer-git.install
new file mode 100644
index 000000000000..16a010a03585
--- /dev/null
+++ b/kupfer-git.install
@@ -0,0 +1,13 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ update-mime-database /usr/share/mime
+ update-desktop-database -q
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}