summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlpxl2020-05-16 17:28:48 -0300
committerlpxl2020-05-16 17:28:48 -0300
commit1719686bfafd39eae739e8e16c56551a17609d14 (patch)
tree8fb80b31335207341fdeeec6844f744dd576ac26
downloadaur-1719686bfafd39eae739e8e16c56551a17609d14.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD17
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0745b5129577
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mun-bin
+ pkgdesc = A programming language empowering creation through iteration - precompiled binary
+ pkgver = 0.2.0
+ pkgrel = 1
+ url = https://mun-lang.org/
+ arch = x86_64
+ license = MIT
+ depends = zlib
+ depends = ncurses5-compat-libs
+ depends = libffi6
+ provides = mun
+ conflicts = mun
+ conflicts = mun-git
+ source = https://github.com/mun-lang/mun/releases/download/v0.2.0/mun-linux64-v0.2.0.tar.gz
+ md5sums = 905cac450f1ec5772c54549551cbb6b4
+
+pkgname = mun-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2eb103632162
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,17 @@
+# Maintainer: Hilton Medeiros <medeiros.hilton@gmail.com>
+pkgname=mun-bin
+pkgver=0.2.0
+pkgrel=1
+pkgdesc="A programming language empowering creation through iteration - precompiled binary"
+arch=('x86_64')
+url="https://mun-lang.org/"
+license=('MIT')
+provides=('mun')
+conflicts=('mun' 'mun-git')
+depends=('zlib' 'ncurses5-compat-libs' 'libffi6')
+source=("https://github.com/mun-lang/mun/releases/download/v${pkgver}/mun-linux64-v${pkgver}.tar.gz")
+md5sums=('905cac450f1ec5772c54549551cbb6b4')
+
+package() {
+ install -Dm755 "$srcdir/mun" "$pkgdir/usr/bin/mun"
+}