summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPiotr Rogoża2015-09-18 23:43:44 +0200
committerPiotr Rogoża2015-09-18 23:43:44 +0200
commit1743f9312d711ce7a6ade388cfd7df7de545076e (patch)
treef619559c1f45bd6a1b54ec078471221266cd1094
downloadaur-1743f9312d711ce7a6ade388cfd7df7de545076e.tar.gz
Initial commit, version 1.1001
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD62
2 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d1b87fbe9633
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = perl-module-cpanfile
+ pkgdesc = Module-CPANfile - Parse cpanfile
+ pkgver = 1.1001
+ pkgrel = 1
+ url = http://search.cpan.org/dist/Module-CPANfile/
+ arch = any
+ license = GPL
+ license = PerlArtistic
+ depends = perl
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/M/MI/MIYAGAWA/Module-CPANfile-1.1001.tar.gz
+ sha256sums = ad435d7658c6fd86c02b89527e27a3881d04df528989365a700934a3c22b08d6
+
+pkgname = perl-module-cpanfile
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d756cd0452d1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+# Contributor: Piotr Rogoza <piotr dot r dot public at gmail dot com>
+
+pkgname=perl-module-cpanfile
+pkgver=1.1001
+pkgrel=1
+_author="M/MI/MIYAGAWA"
+_perlmod="Module-CPANfile"
+pkgdesc="Module-CPANfile - Parse cpanfile"
+arch=('any')
+url="http://search.cpan.org/dist/Module-CPANfile/"
+license=('GPL' 'PerlArtistic')
+depends=(perl)
+options=(!emptydirs)
+source=("http://search.cpan.org/CPAN/authors/id/$_author/$_perlmod-$pkgver.tar.gz")
+sha256sums=('ad435d7658c6fd86c02b89527e27a3881d04df528989365a700934a3c22b08d6')
+
+build(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # Setting these env variables overwrites any command-line-options we don't want...
+ export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ /usr/bin/perl Makefile.PL
+ make
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ /usr/bin/perl Build.PL
+ perl Build
+ fi
+}
+check(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make test
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build test
+ fi
+}
+package(){
+ cd "$srcdir"/$_perlmod-$pkgver
+
+ # If using Makefile.PL
+ if [ -r Makefile.PL ]; then
+ make install
+ # If using Build.PL
+ elif [ -r Build.PL ]; then
+ perl Build install
+ fi
+
+ # remove perllocal.pod and .packlist
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+