summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2020-04-06 17:28:49 +0200
committerLubosz Sarnecki2020-04-06 17:50:38 +0200
commit174ceb13f70a20a069eb0bec87f8cc38f5b4a2e2 (patch)
treefedb516f230f0b2916ab72bc65ca963a1c160588
downloadaur-174ceb13f70a20a069eb0bec87f8cc38f5b4a2e2.tar.gz
Make it work
Add srcinfo
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD38
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c19f8fbf64f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = minigbs-git
+ pkgdesc = Small .gbs chiptune player for Linux.
+ pkgver = 1.4.2+0+gd880bfc
+ pkgrel = 1
+ url = https://github.com/baines/MiniGBS
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = make
+ provides = minigbs=1.4.2+0+gd880bfc
+ conflicts = minigbs
+ replaces = minigbs
+ source = git+https://github.com/baines/MiniGBS.git
+ sha256sums = SKIP
+
+pkgname = minigbs-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..287d5393df91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Lubosz Sarnecki <lubosz ! gmail ! com>
+
+pkgname=minigbs-git
+pkgver=1.4.2+0+gd880bfc
+pkgrel=1
+pkgdesc="Small .gbs chiptune player for Linux."
+arch=('i686' 'x86_64')
+license=('MIT')
+url="https://github.com/baines/MiniGBS"
+depends=()
+makedepends=('git' 'make')
+provides=("minigbs="$pkgver)
+replaces=("minigbs")
+conflicts=("minigbs")
+source=('git+https://github.com/baines/MiniGBS.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd MiniGBS
+ git describe --tags --long | sed 's/-/+/g'
+}
+
+prepare() {
+ cd MiniGBS
+
+ # Install to /usr
+ sed -i 's|/usr/local|/usr|' Makefile
+}
+
+build() {
+ cd MiniGBS
+ make
+}
+
+package() {
+ cd MiniGBS
+ make DESTDIR="$pkgdir" install
+}