summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Kowaliczek2017-04-19 22:54:53 +0200
committerThomas Kowaliczek2017-04-19 22:54:53 +0200
commit175d77622ff0cbc4c8a509684349a2774d3e989b (patch)
treee7e35c3001805f83517c5aa16eeb4b81b7a32507
parent77ae0cfa256ad654d8903923dbb158efec015cc1 (diff)
downloadaur-175d77622ff0cbc4c8a509684349a2774d3e989b.tar.gz
update to new git deps
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e176786d0656..2919ce3f549e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Oct 3 16:54:34 UTC 2016
pkgbase = fife-git
pkgdesc = The mission of the FIFE project is to create a cross platform game creation framework
- pkgver = 0.3.4.r608.gba383ca
+ pkgver = 0.4.1.r372.g85626ccd
pkgrel = 1
url = http://www.fifengine.net/
arch = i686
@@ -18,11 +16,12 @@ pkgbase = fife-git
depends = libogg
depends = openal
depends = swig
- depends = python2
+ depends = python
depends = zlib
depends = libgl
depends = libpng
depends = tinyxml
+ depends = glew
depends = fifechan-git
provides = fife
provides = fife-svn
diff --git a/PKGBUILD b/PKGBUILD
index 059cebb5f122..2d97f6f4e3d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
# Maintainer: Chris Oelmueller <chris.oelmueller@gmail.com>
# Contributor: Yaohan Chen <yaohan.chen@gmail.com>
# Contributor: Thomas Kinnen <thomas.kinnen@gmail.com>
+# Contributor: Thomas Kowaliczek-Schmer <thomas.kowaliczek@posteo.de>
pkgname=fife-git
provides=("fife" "fife-svn")
conflicts=("fife" "fife-svn")
pkgdesc="The mission of the FIFE project is to create a cross platform game creation framework"
url="http://www.fifengine.net/"
-pkgver=0.3.4.r608.gba383ca
+pkgver=0.4.1.r372.g85626ccd
pkgrel=1
arch=('i686' 'x86_64')
license=('LGPL')
-depends=('sdl2' 'boost' 'sdl2_ttf' 'sdl2_image' 'libvorbis' 'libogg' 'openal' 'swig' 'python2' 'zlib' 'libgl' 'libpng' 'tinyxml' 'fifechan-git')
+depends=('sdl2' 'boost' 'sdl2_ttf' 'sdl2_image' 'libvorbis' 'libogg' 'openal' 'swig' 'python' 'zlib' 'libgl' 'libpng' 'tinyxml' 'glew' 'fifechan-git')
makedepends=('cmake' 'git')
source=(git+https://github.com/fifengine/fifengine.git)
md5sums=('SKIP')
@@ -25,9 +26,9 @@ build() {
# [TODO] Due to severe laziness, I have not tested in-source builds yet
[[ -d "build" ]] && rm -r "build"
mkdir -p "build" && cd "build"
- cmake \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- ..
+ cmake -DCMAKE_INSTALL_PREFIX:PATH=/usr ..
+ # to build C/C++ version comment this in and the line above out.
+ # cmake -Dbuild-library=ON -DCMAKE_INSTALL_PREFIX:PATH=/usr -DCMAKE_INSTALL_LIBDIR:PATH=/usr/lib ..
make
}