summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPeter2017-10-14 07:38:07 +0200
committerPeter2017-10-14 07:38:07 +0200
commit177983bc86a1fb3fe1f9f36cb832e90364b472b4 (patch)
treedf7092d9109fa2738f732fc5fb029afba3ad746c
parentc5541e5fd6871557a4a9f31568956cc2564f42a9 (diff)
downloadaur-177983bc86a1fb3fe1f9f36cb832e90364b472b4.tar.gz
use improved PKGBUILD, thanks to jonathon
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD70
2 files changed, 36 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d50c949da024..b7f36cb8afa7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = chez-scheme-git
pkgdesc = Chez Scheme is an implementation of the Revised6 Report on Scheme (R6RS) with numerous language and programming environment extensions. (threaded build)
- pkgver = 9.5.1
+ pkgver = 9.4.r206.ga629477
pkgrel = 1
url = https://github.com/cisco/ChezScheme
arch = i686
@@ -13,6 +13,14 @@ pkgbase = chez-scheme-git
provides = chez-scheme
conflicts = petite-chez-scheme
replaces = petite-chez-scheme
+ source = git+https://github.com/cisco/ChezScheme.git
+ source = git+https://github.com/nanopass/nanopass-framework-scheme.git
+ source = git+https://github.com/dybvig/stex.git
+ source = git+https://github.com/madler/zlib.git
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
pkgname = chez-scheme-git
diff --git a/PKGBUILD b/PKGBUILD
index 1e374704dee7..78e30e15b7fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,64 +1,48 @@
-# This is an example PKGBUILD file. Use this as a start to creating your own,
-# and remove these comments. For more information, see 'man PKGBUILD'.
-# NOTE: Please fill out the license field for your package! If it is unknown,
-# then please put 'unknown'.
-
-# See http://wiki.archlinux.org/index.php/VCS_PKGBUILD_Guidelines
-# for more information on packaging from GIT sources.
-
# Maintainer: Peter <craven@gmx.net>
+# Contributor: Jonathon Fernyhough <>
+
pkgname=chez-scheme-git
-pkgver=9.5.1
+_pkgname=ChezScheme
+pkgver=9.5.r11.g1febe9b
pkgrel=1
pkgdesc="Chez Scheme is an implementation of the Revised6 Report on Scheme (R6RS) with numerous language and programming environment extensions. (threaded build)"
arch=(i686 x86_64)
url="https://github.com/cisco/ChezScheme"
license=('APL')
-groups=()
-depends=()
makedepends=('git' 'ncurses' 'libx11' 'xproto')
provides=(chez-scheme)
conflicts=(petite-chez-scheme)
replaces=(petite-chez-scheme)
-backup=()
-options=()
-install=
-source=()
-
-noextract=()
-#generate with 'makepkg -g'
+source=('git+https://github.com/cisco/ChezScheme.git'
+ 'git+https://github.com/nanopass/nanopass-framework-scheme.git'
+ 'git+https://github.com/dybvig/stex.git'
+ 'git+https://github.com/madler/zlib.git')
+md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
-_gitroot=https://github.com/cisco/ChezScheme.git
-_gitname=chez
+prepare() {
+ cd "$_pkgname"
+ rmdir nanopass stex zlib
+ ln -s ../nanopass-framework-scheme nanopass
+ ln -s ../stex
+ ln -s ../zlib
+}
build() {
- cd "$srcdir"
- msg "Connecting to GIT server...."
-
- if [[ -d "$_gitname" ]]; then
- cd "$_gitname" && git pull origin
- msg "The local files are updated."
- else
- git clone "$_gitroot" "$_gitname"
- fi
-
- msg "GIT checkout done or server timeout"
- msg "Starting build..."
-
- rm -rf "$srcdir/$_gitname-build"
- git clone "$srcdir/$_gitname" "$srcdir/$_gitname-build"
- cd "$srcdir/$_gitname-build"
-
- #
- # BUILD HERE
- #
- ./configure --installprefix=/usr --temproot=$pkgdir --threads
+ cd "$_pkgname"
+ ./configure --installprefix=/usr --temproot="$pkgdir" --threads
make
}
package() {
- cd "$srcdir/$_gitname-build"
- make DESTDIR="$pkgdir/" install InstallSchemeName=chez-scheme
+ make -C "$_pkgname" DESTDIR="$pkgdir"/ install InstallSchemeName=chez-scheme
}
# vim:set ts=2 sw=2 et: