summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorayekat2019-05-12 17:34:21 +0200
committerayekat2019-05-12 17:34:21 +0200
commit179f2cf1a65743ee1f26b709930444817ab0c783 (patch)
tree6f8b1b158d7722056fe351f1528e3c264d1f7a55
downloadaur-179f2cf1a65743ee1f26b709930444817ab0c783.tar.gz
0.7.7-2 (Initial packaging)
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD45
-rw-r--r--changelog136
4 files changed, 208 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cd7c2df10342
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = makemetapkg
+ pkgdesc = Create meta-packages for pacman
+ pkgver = 0.7.7
+ pkgrel = 2
+ url = https://gitlab.com/ayekat/pacman-hacks
+ changelog = changelog
+ arch = any
+ license = GPL3
+ makedepends = asciidoc
+ makedepends = git
+ depends = coreutils
+ depends = sed
+ conflicts = remakepkg
+ source = git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v0.7.7
+ sha256sums = SKIP
+
+pkgname = makemetapkg
+ depends = coreutils
+ depends = sed
+ depends = bash
+ depends = fakeroot
+ depends = pacman
+ depends = sh
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..366e1ae483c6
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+/pacman-hacks/
+/src/
+/pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..799916b07d11
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Tinu Weber <http://ayekat.ch>
+
+pkgname=makemetapkg
+pkgver=0.7.7
+pkgrel=2
+arch=(any)
+
+pkgdesc='Create meta-packages for pacman'
+url='https://gitlab.com/ayekat/pacman-hacks'
+license=(GPL3)
+
+# Both are part of pacman-hacks. If you want both makemetapkg and remakepkg,
+# just install pacman-hacks:
+# https://gitlab.com/ayekat/PKGBUILDs/tree/pacman-hacks
+conflicts=(remakepkg)
+
+depends=(coreutils sed)
+makedepends=(asciidoc git)
+
+changelog='changelog'
+
+source=("git+https://gitlab.com/ayekat/pacman-hacks.git#tag=v$pkgver")
+sha256sums=(SKIP)
+
+_tools='makemetapkg metapkg'
+
+build() {
+ cd pacman-hacks
+ make PREFIX=/usr SCRIPTS="$_tools" MANPAGES="$_tools"
+}
+
+package() {
+ # Remark: Since makemetapkg ends up calling makepkg at some point, the
+ # upstream author assumes that everything necessary for running makepkg is
+ # installed (i.e. the base-devel group). Since we cannot depend on base-devel
+ # directly (since it's only a group), but to avoid having to list everything
+ # in that group explicitly here, we just take a wild guess about which
+ # packages in base-devel we REALLY need:
+ depends+=(bash fakeroot pacman sh)
+
+ cd pacman-hacks
+ make DESTDIR="$pkgdir" SCRIPTS="$_tools" MANPAGES="$_tools" install
+ install -Dm 0644 README "$pkgdir"/usr/share/doc/remakepkg/README
+ install -Dm 0644 CHANGELOG "$pkgdir"/usr/share/doc/remakepkg/CHANGELOG
+}
diff --git a/changelog b/changelog
new file mode 100644
index 000000000000..01541c05397f
--- /dev/null
+++ b/changelog
@@ -0,0 +1,136 @@
+v0.7.7-2 (2019-05-12)
+* Initial packaging of makemetapkg
+
+v0.7.7-1 (2019-05-06)
+* Makefile: Fix targets dependency order for generating scripts/manpage/libs
+
+v0.7.6-1 (2019-03-18)
+* repkg: Fix file path for existence check in rename-file
+
+v0.7.5-1 (2019-03-16)
+* Makefile: Properly state dependencies for generating the prefix file
+
+v0.7.4-1 (2019-03-05)
+* repkg: Fix path related issues for remove-backup and rename-file
+
+v0.7.3-1 (2018-09-24)
+* Makefile: Fix PREFIX_… variable declarations - more
+
+v0.7.2-1 (2018-09-23)
+* Makefile: Fix PREFIX_… variable declarations
+* Makefile: Force rebuilding files containing software version
+
+v0.7.1-1 (2018-09-19)
+* PKGBUILD: Add provides and conflicts for provided scripts
+
+v0.7.1-1 (2018-09-18)
+* repkg: Properly handle *non*-versioned depends/conflicts/provides/replaces
+
+v0.7-1 (2018-09-18)
+* Split from pacman-hacks PKGBUILD, only package remakepkg + required scripts
+* repkg: Automatically add provision for old package version/release
+* repkg: Properly handle versioned depends/conflicts/provides/replaces
+* Bug fixes as in v0.6.1, v0.6.2, v0.6.3, v0.6.4 and v0.6.5
+
+v0.6.5-3 (2018-08-27)
+* pacman-hacks-build: Add versioned dependency on pacman-hacks
+* Add provides and conflicts for all included scripts
+
+v0.6.5-2 (2018-08-25)
+* Clean rebuild (for man pages)
+
+v0.6.5-1 (2018-08-22)
+* metapkg: Properly escape special characters in description strings
+
+v0.6.4-1 (2018-08-17)
+* metapkg: Properly generate conflicts/provides/replaces lines in PKGBUILD
+* metapkg: Fix output file location when being passed a relative path
+
+v0.6.3-1 (2018-08-07)
+* metapkg: Print info message for optional dependencies as well
+
+v0.6.2-1 (2018-06-24)
+* remakepkg: Add forgotten command line option -R
+
+v0.6.1-1 (2018-06-24)
+* remakepkg: Don't check for (wrong) output file existence
+
+v0.6-1 (2018-06-24)
+* metapkg: Add conflicts/provides/replaces
+* repkg: -o now takes an output *directory* (instead of output *filename*)
+* repkg: Packages now get a dotted suffix for the pkgrel
+* zr: Repository profiles are now read from $XDG_CONFIG_HOME/zr/repos
+* Bug fixes as in v0.5.1 and v0.5.2
+
+v0.5.2-1 (2018-06-24)
+* repkg: Fix error handling + file check that could lead to incomplete packages
+
+v0.5.1-4 (2018-06-14)
+* Remove unnecessary conflicts and provides
+
+v0.5.1-3 (2018-06-12)
+* Fix typo in install script
+
+v0.5.1-2 (2018-06-12)
+* Split build scripts into separate -build package
+
+v0.5.1-1 (2018-06-10)
+* pacred: Don't treat base-devel specially
+
+v0.5-1 (2018-04-16)
+* Add metapkg, a tool to generate meta-packages from compact rule files
+* Add makemetapkg, a wrapper around to build meta-packages using a METAPKGBUILD
+* Change project description a bit ("simplify" → "complement")
+* repkg: Drop functionality that reads rules from stdin (-r is now mandatory)
+* repkg: Add `add-group`/`remove-group`
+* diffrepo: Add -n to ignore/negate specific packages in a repository
+* Bug fixes as in v0.4.1 and v0.4.1.1
+
+v0.4.1.1-1 (2018-03-18)
+* Fix version information in help output and man pages
+
+v0.4.1-1 (2018-03-18)
+* Fix syntax error in library file
+* repkg: Handle spaces in XDG_CONFIG_HOME correctly
+
+v0.4-1 (2018-03-13)
+* Add remakepkg, a wrapper around repkg to repackage packages using a REPKGBUILD
+* repkg has a slightly different invocation syntax syntax now (more "low-level")
+* repkg: Add `set-arch` and `set-url` commands
+* repkg: Correctly update packager information
+* getpkg: Add -o option to specify output file
+* zr: Bulk-addition speed improved
+* Bug fixes as in v0.3.1, v0.3.2, v0.3.3 and v0.3.4
+
+v0.3.4-1 (2018-03-08)
+* zr: Don't print raw file names that are deleted
+
+v0.3.3-1 (2018-03-05)
+* zr: Correctly overwrite package in database as well if invoked with -f
+
+v0.3.2-1 (2018-03-03)
+* man pages: Use commit date, not build date
+
+v0.3.1-1 (2018-03-03)
+* repkg: Don't accept "empty command" or comment after a package name
+
+v0.3-1 (2018-02-26)
+* Add `-h` command line option (and help output) to all scripts
+* zr: Change argument format (`zr add package repo` and `zr rm repo/package`)
+* zr: Add `ls` subcommand
+* New scripts: diffrepo, getpkg, pkgmirror, repkg
+* Removed scripts: pacbloat
+* Bug fixes as in v0.2.1 and v0.2.2
+
+v0.2.2-1 (2018-02-12)
+* Project renamed from pacman-contrib-zuepfe to pacman-hacks
+
+v0.2.1-1 (2018-02-09)
+* zr: Fix argument handling
+
+v0.2-1 (2018-02-09)
+* Project renamed from zr to pacman-contrib-zuepfe
+* Add abs, ala, aur, checkrestart, pacbloat, pacred and pacwhy
+
+v0.1-1 (2017-12-16)
+* Initial release as zr