summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Baum2018-10-17 20:29:59 +0200
committerDavid Baum2018-10-17 20:29:59 +0200
commit17c9279f60a7b108ca6544df55e599fb74358c18 (patch)
treeca72cb72b4281d8fef53287839600280e532932c
downloadaur-17c9279f60a7b108ca6544df55e599fb74358c18.tar.gz
v1.0
-rw-r--r--.SRCINFO15
-rw-r--r--LICENSE22
-rw-r--r--PKGBUILD21
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..caa71a824468
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-phue
+ pkgdesc = A Philips Hue Python library
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/studioimaginaire/phue
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-pip
+ depends = python
+ source = LICENSE
+ md5sums = 852ebbd5fd0880fc619e859b04cf2b6c
+
+pkgname = python-phue
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..aa91423b5ccf
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,22 @@
+The MIT License (MIT)
+
+Copyright (c) 2014 Nathanaël Lécaudé
+https://github.com/studioimaginaire/phue
+
+Permission is hereby granted, free of charge, to any person obtaining a copy
+of this software and associated documentation files (the "Software"), to deal
+in the Software without restriction, including without limitation the rights
+to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+copies of the Software, and to permit persons to whom the Software is
+furnished to do so, subject to the following conditions:
+
+The above copyright notice and this permission notice shall be included in
+all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN
+THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4a7db8b3e9c6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: David Baum <david.baum@naraesk.eu>
+pkgname=python-phue
+pkgver=1.0
+pkgrel=1
+pkgdesc="A Philips Hue Python library"
+arch=('any')
+url="https://github.com/studioimaginaire/phue"
+license=('MIT')
+depends=('python')
+makedepends=('python' 'python-pip')
+source=('LICENSE')
+md5sums=('852ebbd5fd0880fc619e859b04cf2b6c')
+
+build() {
+ pip install --no-deps --target="phue" phue
+}
+package() {
+ mkdir -p $pkgdir/usr/lib/python3.7/site-packages/
+ cp -r $srcdir/phue/* $pkgdir/usr/lib/python3.7/site-packages/
+ install -Dm644 $srcdir/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}