summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJonas Heinrich2017-11-21 20:24:07 +0100
committerJonas Heinrich2017-11-21 20:24:07 +0100
commit17cf3da33596afb7dce4289a5dc73c5aac17c0ca (patch)
tree8dc28a8ecbb2bc2ce8d5c49ab37fe7d2e5ab8284
downloadaur-17cf3da33596afb7dce4289a5dc73c5aac17c0ca.tar.gz
first commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD39
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2b0fa2f5c83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Tue Nov 21 19:24:01 UTC 2017
+pkgbase = nextcloud-app-tasks-git
+ pkgdesc = Enhanced task app for NextCloud
+ pkgver = v0.9.5.r152.gbf6cdba
+ pkgrel = 1
+ url = https://github.com/nextcloud/tasks
+ arch = any
+ license = AGPL
+ depends = nextcloud
+ provides = nextcloud-app-tasks
+ conflicts = nextcloud-app-tasks
+ options = !strip
+ source = git+https://github.com/nextcloud/tasks.git
+ sha512sums = SKIP
+
+pkgname = nextcloud-app-tasks-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..99e7c4c4d955
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# $Id$
+# Maintainer: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Jonas Heinrich <onny@project-insanity.org>
+# Contributor: Sergej Pupykin <arch+pub@sergej.pp.ru>
+
+pkgname=nextcloud-app-tasks-git
+pkgver=v0.9.5.r152.gbf6cdba
+pkgrel=1
+pkgdesc="Enhanced task app for NextCloud"
+arch=('any')
+url="https://github.com/nextcloud/tasks"
+license=('AGPL')
+depends=('nextcloud')
+makedepends=()
+provides=('nextcloud-app-tasks')
+conflicts=('nextcloud-app-tasks')
+options=('!strip')
+source=("git+https://github.com/nextcloud/tasks.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "tasks"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ sed -i 's/openssl/#openssl/g' ${srcdir}/tasks/Makefile
+}
+
+build() {
+ cd "${srcdir}/tasks"
+ make
+ make appstore
+}
+
+package() {
+ install -d "${pkgdir}/usr/share/webapps/nextcloud/apps"
+ tar -xvf "${srcdir}/tasks/build/artifacts/appstore/tasks.tar.gz" -C "${pkgdir}/usr/share/webapps/nextcloud/apps"
+}