summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoramoka2020-08-23 00:05:29 -0400
committeramoka2020-08-23 00:05:29 -0400
commit17f05a6d8b82b52d4025fce911d111787f5a97e0 (patch)
tree165e8c363e709ac2d343ac7a69e5fe02a2b5c797
parent541ad9d7fc8e3cbbbda8217d898db7e6c95cb252 (diff)
downloadaur-17f05a6d8b82b52d4025fce911d111787f5a97e0.tar.gz
adopt misc improvements from extra
-rw-r--r--.SRCINFO12
-rw-r--r--[-rwxr-xr-x]PKGBUILD34
-rw-r--r--[-rwxr-xr-x]fontconfig-git.hook2
-rw-r--r--[-rwxr-xr-x]fontconfig-git.install39
4 files changed, 28 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 543988d3de4c..5bef8041e07f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fontconfig-git
- pkgdesc = A library for configuring and customizing font access (from git)
- pkgver = 2.13.91+18+g01e4f08
+ pkgdesc = Library for configuring and customizing font access (from git)
+ pkgver = 2.13.91+63+g9133e79
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/fontconfig/
install = fontconfig-git.install
@@ -12,14 +12,18 @@ pkgbase = fontconfig-git
makedepends = python-lxml
makedepends = python-six
makedepends = json-c
+ makedepends = expat
+ makedepends = freetype2
depends = expat
- depends = freetype2
+ depends = libfreetype.so
provides = fontconfig
+ provides = libfontconfig.so
conflicts = fontconfig
+ backup = etc/fonts/fonts.conf
source = git+https://anongit.freedesktop.org/git/fontconfig
source = fontconfig-git.hook
sha256sums = SKIP
- sha256sums = 672f6a1c5e164671955ce807e670306194142a1794ce88df653aa717a972e274
+ sha256sums = 8883f7e6e9d574ed52b89256507a6224507925715ddc85b3dfab9683df2f1e25
pkgname = fontconfig-git
diff --git a/PKGBUILD b/PKGBUILD
index f795902d5d4b..212c312131d3 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,26 @@
+# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
# Maintainer: Vincent Grande <shoober420@gmail.com>
-# Maintainer: Amanoel Dawod <amoka at amanoel dot com>
# Contributor: Yichao Yu <yyc1992@gmail.com>
# Contributor: Jan Alexander Steffens (heftig) <jan.steffens@gmail.com>
# Contributor: Jan de Groot <jgc@archlinux.org>
-# Contributor: Vincent Grande <shoober420@gmail.com>
pkgname=fontconfig-git
-pkgver=2.13.91+18+g01e4f08
+pkgver=2.13.91+63+g9133e79
pkgrel=1
-pkgdesc="A library for configuring and customizing font access (from git)"
-arch=('x86_64')
+pkgdesc="Library for configuring and customizing font access (from git)"
url="https://www.freedesktop.org/wiki/Software/fontconfig/"
+arch=('x86_64')
license=('custom')
-depends=('expat' 'freetype2')
-makedepends=('git' 'autoconf-archive' 'gperf' 'python-lxml' 'python-six' 'json-c')
+depends=('expat' 'libfreetype.so')
+makedepends=('git' 'autoconf-archive' 'gperf' 'python-lxml' 'python-six' 'json-c' 'expat' 'freetype2')
+provides=('fontconfig' 'libfontconfig.so')
conflicts=('fontconfig')
-provides=('fontconfig')
install=fontconfig-git.install
+backup=(etc/fonts/fonts.conf)
source=("git+https://anongit.freedesktop.org/git/fontconfig"
fontconfig-git.hook)
sha256sums=('SKIP'
- '672f6a1c5e164671955ce807e670306194142a1794ce88df653aa717a972e274')
+ '8883f7e6e9d574ed52b89256507a6224507925715ddc85b3dfab9683df2f1e25')
pkgver() {
cd fontconfig
@@ -37,7 +37,6 @@ build() {
./configure --prefix=/usr \
--sysconfdir=/etc \
--with-templatedir=/etc/fonts/conf.avail \
- --with-xmldir=/etc/fonts \
--localstatedir=/var \
--disable-static \
--disable-docs \
@@ -46,19 +45,10 @@ build() {
make
}
-#check() {
-# cd fontconfig
-# make -k check
-#}
-
-_install_conf() {
- install -m644 "$1" "$pkgdir/etc/fonts/conf.avail"
- ln -s "../conf.avail/${1##*/}" "$pkgdir/etc/fonts/conf.d"
-}
-
package() {
cd fontconfig
make DESTDIR="$pkgdir" install
- install -Dm644 COPYING "$pkgdir/usr/share/licenses/fontconfig/COPYING"
- install -Dm644 ../fontconfig-git.hook "$pkgdir/usr/share/libalpm/hooks/fontconfig-git.hook"
+
+ install -Dt "$pkgdir/usr/share/libalpm/hooks" -m644 ../*.hook
+ install -Dt "$pkgdir/usr/share/licenses/fontconfig" -m644 COPYING
}
diff --git a/fontconfig-git.hook b/fontconfig-git.hook
index 0f24bc4e86f2..63be791decaf 100755..100644
--- a/fontconfig-git.hook
+++ b/fontconfig-git.hook
@@ -1,5 +1,5 @@
[Trigger]
-Type = File
+Type = Path
Operation = Install
Operation = Upgrade
Operation = Remove
diff --git a/fontconfig-git.install b/fontconfig-git.install
index cc7341f128f7..52bd289fa5ef 100755..100644
--- a/fontconfig-git.install
+++ b/fontconfig-git.install
@@ -1,37 +1,12 @@
-post_install() {
- cat << _EOF
-
- Fontconfig configuration is done via /etc/fonts/conf.avail and conf.d.
- Read /etc/fonts/conf.d/README for more information.
-
- Configuration via /etc/fonts/local.conf is still possible,
- but is no longer recommended for options available in conf.avail.
-
- Main systemwide configuration should be done by symlinks
- (especially for autohinting, sub-pixel and lcdfilter):
-
- cd /etc/fonts/conf.d
- ln -s ../conf.avail/XX-foo.conf
-
- Check also https://wiki.archlinux.org/index.php/Font_Configuration
- and https://wiki.archlinux.org/index.php/Fonts.
-
-_EOF
-
- post_upgrade $1
-}
-
post_upgrade() {
- echo -n "updating font cache... "
+ # a full forced directory scan is required here
+ echo -n "Rebuilding fontconfig cache..."
/usr/bin/fc-cache -rs
- echo "done."
+ echo " done."
}
-post_remove() {
- cat << _EOF
-
- Check for dead symlinks and leftover files
- in /etc/fonts/conf.d/
-
-_EOF
+post_install() {
+ post_upgrade $1 0
}
+
+# vim:set sw=2 et: