summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJames Groom2021-06-10 02:11:31 +1000
committerJames Groom2021-06-10 02:11:36 +1000
commit18041daa114b3728e597189a864da7061a9bfa05 (patch)
treeaba3915892d9527f274afc7261e5739db47a38f1
parentbb10635d90cc165365be3244234a76d96210afe5 (diff)
downloadaur-18041daa114b3728e597189a864da7061a9bfa05.tar.gz
Update to 2.6.2 release
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD19
-rw-r--r--bizhawk-monort.install2
3 files changed, 19 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9a8dc330053..e985c5b1782e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,20 @@
pkgbase = bizhawk-monort
pkgdesc = A multi-system emulator on .NET. Features rerecording and tools for TASing. (Mono runtime)
- pkgver = 2.5.2
+ pkgver = 2.6.2
pkgrel = 1
url = https://gitlab.com/TASVideos/BizHawk#readme
+ install = bizhawk-monort.install
arch = x86_64
license = MIT
license = custom
- makedepends = dotnet-sdk>=5.0.0
depends = glibc
depends = lsb-release
- depends = mono>=6.10
+ depends = mono>=6.12
depends = openal
- optdepends = antimicro: to use unsupported controllers as keyboards
- optdepends = ffmpeg: to use built-in A/V capture, unstable
- provides = bizhawk=2.5.2
- source = https://github.com/TASVideos/BizHawk/releases/download/2.5.2/BizHawk-2.5.2.zip
- sha512sums = 9e4cdf5e2e311ca5ad5750b91ea5163d8e727813f9a88200d80013657c45b33b0a51112fd5816debe264b99b1244b8555c0f8b9eccfc6f87c45e67bbd1c28b06
+ optdepends = antimicro: to use unsupported controllers (by mapping to the keyboard)
+ provides = bizhawk=2.6.2
+ source = https://github.com/TASVideos/BizHawk/releases/download/2.6.2/BizHawk-2.6.2-linux-x64.tar.zip
+ sha512sums = 8751a2229d9e500a3f3a283ce24ae62f8f911507f5fdbe25aa41f31ac5026cf89433c89dc766864439a17531543829e4b43bc4d3b311f5a80b4df0605bbd9627
pkgname = bizhawk-monort
diff --git a/PKGBUILD b/PKGBUILD
index fa9d4815ee06..fdfdef26258d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,28 @@
# Maintainer: James Groom <OSSYoshiRulz at gmail dot com>
pkgname=bizhawk-monort
_providesName=bizhawk
-pkgver=2.5.2
-_archiveName="BizHawk-2.5.2"
+pkgver=2.6.2
+_archiveName="BizHawk-$pkgver-linux-x64.tar.zip"
pkgrel=1
pkgdesc="A multi-system emulator on .NET. Features rerecording and tools for TASing. (Mono runtime)"
arch=("x86_64")
url="https://gitlab.com/TASVideos/BizHawk#readme"
license=("MIT" "custom")
-depends=("glibc" "lsb-release" "mono>=6.10" "openal")
+depends=("glibc" "lsb-release" "mono>=6.12" "openal")
optdepends=(
- "antimicro: to use unsupported controllers as keyboards"
- "ffmpeg: to use built-in A/V capture, unstable"
+ "antimicro: to use unsupported controllers (by mapping to the keyboard)"
)
-makedepends=("dotnet-sdk>=5.0.0")
+#makedepends=("dotnet-sdk>=5.0.0")
provides=("$_providesName=$pkgver")
-source=("https://github.com/TASVideos/BizHawk/releases/download/$pkgver/$_archiveName.zip")
-sha512sums=("9e4cdf5e2e311ca5ad5750b91ea5163d8e727813f9a88200d80013657c45b33b0a51112fd5816debe264b99b1244b8555c0f8b9eccfc6f87c45e67bbd1c28b06")
+install="bizhawk-monort.install"
+source=("https://github.com/TASVideos/BizHawk/releases/download/$pkgver/$_archiveName")
+sha512sums=("8751a2229d9e500a3f3a283ce24ae62f8f911507f5fdbe25aa41f31ac5026cf89433c89dc766864439a17531543829e4b43bc4d3b311f5a80b4df0605bbd9627")
package() {
cd "$srcdir"
+ mkdir opt
+ tar -xf BizHawk*.tar -C opt
+ cd opt
find . -type d -exec install -D -ggames -m775 -d "$pkgdir/opt/$_providesName/{}" \;
find . -type f -not -name *.sh -exec install -D -ggames -m664 "{}" "$pkgdir/opt/$_providesName/{}" \;
find . -type f -name *.sh -exec install -D -ggames -m774 "{}" "$pkgdir/opt/$_providesName/{}" \;
diff --git a/bizhawk-monort.install b/bizhawk-monort.install
index a6d439503cb2..fc0af2f35a86 100644
--- a/bizhawk-monort.install
+++ b/bizhawk-monort.install
@@ -1,3 +1,3 @@
post_install() {
- printf "%s\n" "Make sure you are in the games group (usermod -aG games \$(id -nu))."
+ printf "%s\n%s\n" "Make sure you are in the games group (usermod -aG games \$(id -nu))!" "The start script is /opt/bizhawk/EmuHawkMono.sh"
}