summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadek Podgorny2021-12-30 15:23:35 +0100
committerRadek Podgorny2021-12-30 15:23:35 +0100
commit1811771b5aa7981715e7dd12b40727b8a369348a (patch)
tree353fdb00e337593f511a7bf47b19dd5d17ed079f
parent5910d80b744265f640acbc4559c512d8396b946d (diff)
downloadaur-1811771b5aa7981715e7dd12b40727b8a369348a.tar.gz
add boost-1.77.0 patch to make it compile again
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD5
-rw-r--r--boost1770.patch56
3 files changed, 63 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4f69312aacb4..814665514fc5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = litecoin-qt
pkgdesc = Peer-to-peer network based digital currency (QT)
pkgver = 0.18.1
- pkgrel = 1
+ pkgrel = 2
url = http://www.litecoin.org/
install = litecoin-qt.install
arch = i686
@@ -19,11 +19,12 @@ pkgbase = litecoin-qt
source = https://download.litecoin.org/litecoin-0.18.1/src/litecoin-0.18.1.tar.gz
source = deque.patch
source = qpainterpath.patch
+ source = boost1770.patch
source = litecoin-qt.desktop
sha256sums = 6dfa71ccf059463f0a304f85ff1ca8b88039d63e93269d6f056ab24915be936d
sha256sums = 595b465639a0ac22c262da404b942d682b8bda5f010db9b13d07b671b3877af1
sha256sums = d7716150afe7cd49b708699c27f5e39835b6849c4839c005ff36b4e06ccd9593
+ sha256sums = 3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5
sha256sums = cfc53dc9028745358235698ddd562d3e6b4a3ea9f896f5efc1aa8cd81f595559
pkgname = litecoin-qt
-
diff --git a/PKGBUILD b/PKGBUILD
index 53c0080980eb..0f0de78b9f27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=litecoin-qt
pkgver=0.18.1
-pkgrel=1
+pkgrel=2
arch=('i686' 'x86_64')
url="http://www.litecoin.org/"
license=('MIT')
@@ -16,16 +16,19 @@ install=litecoin-qt.install
source=("https://download.litecoin.org/litecoin-${pkgver}/src/litecoin-${pkgver}.tar.gz"
"deque.patch"
"qpainterpath.patch"
+ "boost1770.patch"
"$pkgname.desktop")
sha256sums=('6dfa71ccf059463f0a304f85ff1ca8b88039d63e93269d6f056ab24915be936d'
'595b465639a0ac22c262da404b942d682b8bda5f010db9b13d07b671b3877af1'
'd7716150afe7cd49b708699c27f5e39835b6849c4839c005ff36b4e06ccd9593'
+ '3ccbff49fef5a7e820168f4c4b75ae9a1e74e81dc08587145aa85599254b85e5'
'cfc53dc9028745358235698ddd562d3e6b4a3ea9f896f5efc1aa8cd81f595559')
build() {
cd "$srcdir/litecoin-$pkgver"
patch -p2 <$srcdir/deque.patch
patch -p1 <$srcdir/qpainterpath.patch
+ patch -p1 <$srcdir/boost1770.patch
./autogen.sh
./configure --with-incompatible-bdb --with-gui=qt5
make
diff --git a/boost1770.patch b/boost1770.patch
new file mode 100644
index 000000000000..07f8432eddbb
--- /dev/null
+++ b/boost1770.patch
@@ -0,0 +1,56 @@
+commit acb7aad27ec8a184808aa7905887e3b2c5d54e9c
+Author: Rafael Sadowski <rafael@sizeofvoid.org>
+Date: Mon Aug 16 06:34:02 2021 +0200
+
+ Fix build with Boost 1.77.0
+
+ BOOST_FILESYSTEM_C_STR changed to accept the path as an argument
+
+diff --git a/src/fs.cpp b/src/fs.cpp
+index 4f20ca4d2..89c7ad27d 100644
+--- a/src/fs.cpp
++++ b/src/fs.cpp
+@@ -242,7 +242,11 @@ void ofstream::close()
+ }
+ #else // __GLIBCXX__
+
++#if BOOST_VERSION >= 107700
++static_assert(sizeof(*BOOST_FILESYSTEM_C_STR(fs::path())) == sizeof(wchar_t),
++#else
+ static_assert(sizeof(*fs::path().BOOST_FILESYSTEM_C_STR) == sizeof(wchar_t),
++#endif // BOOST_VERSION >= 107700
+ "Warning: This build is using boost::filesystem ofstream and ifstream "
+ "implementations which will fail to open paths containing multibyte "
+ "characters. You should delete this static_assert to ignore this warning, "
+diff --git a/src/wallet/test/db_tests.cpp b/src/wallet/test/db_tests.cpp
+index 17f5264b4..16cb7e0ba 100644
+--- a/src/wallet/test/db_tests.cpp
++++ b/src/wallet/test/db_tests.cpp
+@@ -25,7 +25,11 @@ BOOST_AUTO_TEST_CASE(getwalletenv_file)
+ std::string test_name = "test_name.dat";
+ const fs::path datadir = gArgs.GetDataDirNet();
+ fs::path file_path = datadir / test_name;
++#if BOOST_VERSION >= 107700
++ std::ofstream f(BOOST_FILESYSTEM_C_STR(file_path));
++#else
+ std::ofstream f(file_path.BOOST_FILESYSTEM_C_STR);
++#endif // BOOST_VERSION >= 107700
+ f.close();
+
+ std::string filename;
+diff --git a/src/wallet/test/init_test_fixture.cpp b/src/wallet/test/init_test_fixture.cpp
+index dd9354848..53c972c46 100644
+--- a/src/wallet/test/init_test_fixture.cpp
++++ b/src/wallet/test/init_test_fixture.cpp
+@@ -32,7 +32,11 @@ InitWalletDirTestingSetup::InitWalletDirTestingSetup(const std::string& chainNam
+ fs::create_directories(m_walletdir_path_cases["default"]);
+ fs::create_directories(m_walletdir_path_cases["custom"]);
+ fs::create_directories(m_walletdir_path_cases["relative"]);
++#if BOOST_VERSION >= 107700
++ std::ofstream f(BOOST_FILESYSTEM_C_STR(m_walletdir_path_cases["file"]));
++#else
+ std::ofstream f(m_walletdir_path_cases["file"].BOOST_FILESYSTEM_C_STR);
++#endif // BOOST_VERSION >= 107700
+ f.close();
+ }
+