summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrainDamage2020-01-04 05:45:33 +0100
committerBrainDamage2020-01-04 05:45:33 +0100
commit1824404c65492b7b219b9c6739d53950f0a01fa1 (patch)
tree42b367fb71b79013049afae3fc023d0741698ca5
parent2be57eb7a86e6be910f7adfaa2d093364e21c1bc (diff)
downloadaur-1824404c65492b7b219b9c6739d53950f0a01fa1.tar.gz
version bump
cleaned up the pkgbuild install the license as per guidelines added package checks
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD24
2 files changed, 19 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca829f62c421..4715362279b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = libsixel
pkgdesc = libsixel provides and encoder/decoder implementation for DEC SIXEL graphics, and some converter programs
- pkgver = v1.8.2
- pkgrel = 2
+ pkgver = v1.8.5
+ pkgrel = 1
url = https://saitoha.github.io/libsixel/
arch = i686
arch = x86_64
@@ -10,8 +10,8 @@ pkgbase = libsixel
depends = libpng
depends = python
depends = curl
- source = https://github.com/saitoha/libsixel/archive/v1.8.2.tar.gz
- sha256sums = c464d2a6fcf35e9e6bad1876729e853a8b9f6abfe97d9e3487c9bfac45cf2a5f
+ source = https://github.com/saitoha/libsixel/archive/v1.8.5.tar.gz
+ sha256sums = 682ef295eb93f262db7d77b3a5e8ffcb6e3f5a9fc864d1a21cc5cd3c347a4b0e
pkgname = libsixel
diff --git a/PKGBUILD b/PKGBUILD
index a83662509650..7f71d2588f9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,22 +1,28 @@
# Maintainer: BrainDamage
pkgname="libsixel"
-pkgrel=2
-stripped_ver="1.8.2"
-pkgver="v$stripped_ver"
+pkgrel=1
+pkgver="v1.8.5"
pkgdesc="libsixel provides and encoder/decoder implementation for DEC SIXEL graphics, and some converter programs"
arch=("i686" "x86_64")
url="https://saitoha.github.io/libsixel/"
license=("MIT")
depends=("libjpeg-turbo" "libpng" "python" "curl")
-sha256sums=('c464d2a6fcf35e9e6bad1876729e853a8b9f6abfe97d9e3487c9bfac45cf2a5f')
-source=("https://github.com/saitoha/libsixel/archive/$pkgver.tar.gz")
+sha256sums=('682ef295eb93f262db7d77b3a5e8ffcb6e3f5a9fc864d1a21cc5cd3c347a4b0e')
+source=("https://github.com/saitoha/libsixel/archive/${pkgver}.tar.gz")
build() {
- cd "libsixel-$stripped_ver"
- ./configure --prefix=/usr --enable-python
+ cd "${srcdir}/${pkgname}-${pkgver#v}"
+ ./configure --prefix=/usr --enable-python --enable-tests
+ make
}
package() {
- cd "libsixel-$stripped_ver"
- make DESTDIR="$pkgdir" install
+ cd "${srcdir}/${pkgname}-${pkgver#v}"
+ make DESTDIR="${pkgdir}" install
+ install -Dm 644 LICENSE "${pkgdir}/usr/share/licenses/libsixel/LICENSE"
+}
+
+check() {
+ cd "${srcdir}/${pkgname}-${pkgver#v}"
+ make test
}