summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Krause2015-07-09 13:53:13 +0200
committerChristian Krause2015-07-09 13:53:13 +0200
commit18537beb9d240fef030eccad8d8fc062cee4f812 (patch)
tree30034bc71b30671f363556300ff2a1fd0fc69608
downloadaur-18537beb9d240fef030eccad8d8fc062cee4f812.tar.gz
proovread-2.12-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD38
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2cb6a6669c5e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = proovread
+ pkgdesc = large-scale high accuracy PacBio correction through iterative short read consensus
+ pkgver = 2.12
+ pkgrel = 1
+ url = https://github.com/BioInf-Wuerzburg/proovread
+ arch = any
+ license = PerlArtistic
+ depends = blasr-git
+ depends = perl-log-log4perl
+ depends = blast+>=2.2.24
+ depends = samtools>=1.1
+ depends = shrimp
+ source = proovread::git+https://github.com/BioInf-Wuerzburg/proovread#tag=proovread-2.12
+ md5sums = SKIP
+
+pkgname = proovread
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..93f5f1047980
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Christian Krause ("wookietreiber") <kizkizzbangbang@googlemail.com>
+
+pkgname=proovread
+pkgver=2.12
+pkgrel=1
+pkgdesc="large-scale high accuracy PacBio correction through iterative short read consensus"
+arch=('any')
+url="https://github.com/BioInf-Wuerzburg/proovread"
+license=('PerlArtistic')
+depends=('blasr-git' 'perl-log-log4perl' 'blast+>=2.2.24' 'samtools>=1.1' 'shrimp')
+source=("$pkgname::git+https://github.com/BioInf-Wuerzburg/proovread#tag=proovread-2.12")
+md5sums=('SKIP')
+
+prepare() {
+ cd $srcdir/$pkgname
+
+ git submodule init
+ git submodule update
+}
+
+build() {
+ cd $srcdir/$pkgname/util/bwa
+
+ make
+}
+
+package() {
+ cd $srcdir/$pkgname
+
+ mkdir -p $pkgdir/usr/bin \
+ $pkgdir/usr/lib/perl5/vendor_perl
+
+ for file in bin/* util/SeqChunker/bin/* ; do
+ install -Dm755 $file $pkgdir/usr/bin/$(basename $file .pl)
+ done
+
+ cp -r lib/* $pkgdir/usr/lib/perl5/vendor_perl
+}