summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordamige2016-09-26 01:01:34 +0200
committerdamige2016-09-26 01:01:34 +0200
commit185becc5369e6abb4f241362300186a348927e65 (patch)
tree11e613349a727ec69693f8224cd3aa1702f5ef23
downloadaur-185becc5369e6abb4f241362300186a348927e65.tar.gz
V1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..017c781659a9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = numad-git
+ pkgdesc = numad is a deamon that monitors NUMA topology and usage and distributes loads for good locality for the purpose of providing the best performance, by avoiding unnecessary latency.
+ pkgver = 0.5
+ pkgrel = 1
+ url = https://git.fedorahosted.org/git/numad.git
+ arch = x86_64
+ arch = i686
+ license = LGPL
+ depends = libsystemd
+ depends = git
+ options =
+
+pkgname = numad-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..942ddc2f93aa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Paul Dunn <pwjdunn AT gmail DOT com>
+
+pkgname=numad-git
+pkgver=0.5
+pkgrel=1
+pkgdesc="numad is a deamon that monitors NUMA topology and usage and distributes loads for good locality for the purpose of providing the best performance, by avoiding unnecessary latency."
+arch=('x86_64' 'i686')
+license=('LGPL')
+url="https://git.fedorahosted.org/git/numad.git"
+options=()
+depends=('libsystemd' 'git')
+source=("git+https://git.fedorahosted.org/git/numad.git")
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/numad"
+ make
+}
+
+package() {
+ install -Dm755 $srcdir/numad/numad "$pkgdir/usr/bin/numad"
+ install -Dm644 $srcdir/numad/numad.8 $pkgdir/usr/share/man/man8
+ install -Dm644 $srcdir/numad/numad.service $pkgdir/usr/lib/systemd/system/numad.service
+}