summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornroi2017-01-29 22:15:29 +0100
committernroi2017-01-29 22:17:18 +0100
commit18711aa3a4e918dd0accb28f5c24b82f79643b82 (patch)
tree7fbe1433000839e617124e39c93678149bd59741
downloadaur-18711aa3a4e918dd0accb28f5c24b82f79643b82.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD20
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26537b707338
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = clyde-git
+ pkgdesc = Download pacman packages nightly for cpcache
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/nroi/clyde
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-yaml
+ source = git+https://github.com/nroi/clyde.git
+ sha256sums = SKIP
+
+pkgname = clyde-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa125eeea94c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: nroi <nroi@mailbox.org>
+pkgname=clyde-git
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Download pacman packages nightly for cpcache"
+arch=('any')
+url="https://github.com/nroi/clyde"
+source=('git+https://github.com/nroi/clyde.git')
+license=('MIT')
+depends=('python' 'python-yaml')
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 "${pkgname%-git}" "${pkgdir}/usr/bin/${pkgname%-git}"
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 "${pkgname%-git}.timer" "${pkgdir}/usr/lib/systemd//system/${pkgname%-git}.timer"
+ install -Dm644 "${pkgname%-git}.service" "${pkgdir}/usr/lib/systemd/system/${pkgname%-git}.service"
+ install -Dm644 config.yml "${pkgdir}/etc/${pkgname%-git}/config.yml"
+}