summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGabriel Rauter2020-03-12 11:10:24 +0100
committerGabriel Rauter2020-03-12 11:10:24 +0100
commit18762eb371bfb9691f29fffd4213c18cefc636b4 (patch)
tree5c57dd1d09746271910814c2a3720a639831df8e
downloadaur-18762eb371bfb9691f29fffd4213c18cefc636b4.tar.gz
init
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD34
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d23b5f940f52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = n-dhcp4-git
+ pkgdesc = Dynamic Host Configuration Protocol for IPv4
+ pkgver = 1.9.g9ba143a
+ pkgrel = 1
+ url = https://github.com/nettools/n-dhcp4
+ arch = x86_64
+ license = LGPL2.1
+ license = Apache
+ makedepends = meson
+ makedepends = pkgconf
+ depends = glibc
+ source = git+https://github.com/nettools/n-dhcp4.git
+ sha256sums = SKIP
+
+pkgname = n-dhcp4-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88ae7fed292a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Gabriel Rauter <rauter.gabriel@gmail.com>
+
+_pkgname=n-dhcp4
+pkgname=$_pkgname-git
+pkgver=1.9.g9ba143a
+pkgrel=1
+pkgdesc="Dynamic Host Configuration Protocol for IPv4"
+url="https://github.com/nettools/n-dhcp4"
+license=('LGPL2.1' 'Apache')
+arch=(x86_64)
+depends=(glibc)
+makedepends=(meson pkgconf)
+source=("git+https://github.com/nettools/n-dhcp4.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd $_pkgname
+ git describe --tags | sed 's/^v//;s/-/./g;s/_/./g;'
+}
+
+build() {
+ rm -rf build
+ arch-meson $_pkgname build
+ ninja -C build
+}
+
+check() {
+ meson test -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+}
+