summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Fink2023-03-26 19:01:00 +0300
committerChristoph Fink2023-03-26 19:01:00 +0300
commit18a227ea7598d72f4b7950cbf601eea110191013 (patch)
tree0306fa47ec86bdecb51e2c23771d1c87d6784733
parent2df61f4a3e42e23b9d76054a27a47a5ab1185fa9 (diff)
downloadaur-18a227ea7598d72f4b7950cbf601eea110191013.tar.gz
upgpkg: r-pkgload 1.3.2-3
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD34
2 files changed, 25 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03516b8aedbf..f1c360ac198e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,10 @@
pkgbase = r-pkgload
pkgdesc = Simulate Package Installation and Attach
pkgver = 1.3.2
- pkgrel = 2
+ pkgrel = 3
url = https://cran.r-project.org/package=pkgload
arch = any
license = GPL3
- checkdepends = r-bitops
- checkdepends = r-covr
- checkdepends = r-mathjaxr
- checkdepends = r-mockr
- checkdepends = r-pak
- checkdepends = r-pkgbuild
- checkdepends = r-rcpp
- checkdepends = r-remotes
- checkdepends = r-rstudioapi
- checkdepends = r-testthat>=3.1.0
depends = r>=3.4.0
depends = r-cli>=3.3.0
depends = r-crayon
diff --git a/PKGBUILD b/PKGBUILD
index b5f4591d588c..664026ae1c08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@ _cranname=pkgload
_cranver=1.3.2
pkgname=r-${_cranname,,}
pkgver=${_cranver//[:-]/.}
-pkgrel=2
+pkgrel=3
pkgdesc="Simulate Package Installation and Attach"
arch=(any)
url="https://cran.r-project.org/package=${_cranname}"
@@ -32,10 +32,25 @@ optdepends=(
"r-remotes"
"r-rstudioapi"
)
-checkdepends=(
- "${optdepends[@]}"
- "r-testthat>=3.1.0"
-)
+
+# The unittests for `r-pkgload` have multiple circular
+# dependency chains.
+
+# As such, the tests can not be run on first build.
+# While R packages from CRAN, generally, are well-tested
+# before they are released, in some situations, you want to
+# have thorough testing on your own end.
+
+# To run the tests, first build this package without `check()`
+# (i.e., as-is) to bootstrap `r-pkgload`. Then, on subsequent builds,
+# (assumining you have a local repository that is accessible from
+# the build chroot), uncomment the lines defining `checkdepends`, below,
+# as well as the `check()` function further down
+
+# checkdepends=(
+# "${optdepends[@]}"
+# "r-testthat>=3.1.0"
+# )
source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
b2sums=("a6113732d047812744902e6fed558b6f7301dd27a970509ec30990853f4bfa9e46e9fd55be3314f8d70e4ddd481f09f0186f8a0f0c85d90bbc8231750443bbf3")
@@ -45,15 +60,14 @@ build() {
R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}/build/"
}
-check() {
- cd "${srcdir}/${_cranname}/tests"
- R_LIBS="${srcdir}/build/" Rscript --vanilla testthat.R
-}
+# check() {
+# export R_LIBS="build/"
+# R CMD check --no-manual "${_cranname}"
+# }
package() {
install -dm0755 "${pkgdir}/usr/lib/R/library"
cp -a --no-preserve=ownership "${srcdir}/build/${_cranname}" "${pkgdir}/usr/lib/R/library"
-
if [[ -f "${_cranname}/LICENSE" ]]; then
install -Dm0644 "${_cranname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
fi