summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJohn D Jones III2015-06-16 14:40:29 -0600
committerJohn D Jones III2015-06-16 14:40:29 -0600
commit18ab1a0fc7030ebd19289a6e586eb87d3c3d674a (patch)
treeaa35f12d9db8eea6be819142df9c766c8bd3700c
downloadaur-18ab1a0fc7030ebd19289a6e586eb87d3c3d674a.tar.gz
Initial import
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD50
2 files changed, 75 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7331bd014774
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = perl-datetimex-duration-skipdays
+ pkgdesc = Given a starting date, a number of days and a list of days to be skipped, returns the date X number of days away.
+ pkgver = 0.002
+ pkgrel = 1
+ url = http://search.cpan.org/dist/DateTimeX-Duration-SkipDays
+ arch = any
+ license = PerlArtistic
+ license = GPL
+ makedepends = perl-test-checkdeps>=0.002
+ makedepends = perl-test-deep
+ makedepends = perl-test-nowarnings
+ makedepends = perl-test-useallmodules
+ depends = perl>=5.006
+ depends = perl-datetime
+ depends = perl-datetime-event-holiday-us
+ depends = perl-datetime-format-flexible
+ depends = perl-list-moreutils
+ depends = perl-try-tiny
+ options = !emptydirs
+ source = http://search.cpan.org/CPAN/authors/id/A/AY/AYOUNG/DateTimeX-Duration-SkipDays-0.002.tar.gz
+ md5sums = 2e2ed838ded0c4c4ad75853b651f7a9c
+ sha512sums = c1663d53fec6f5af69f21f312fa82d690984516726a221f8068c5ff49191ff7daf8bb93c97a9af4a4b775d2ee7b6be87af8f231ce0c39052dfafafc3ec9daa8c
+
+pkgname = perl-datetimex-duration-skipdays
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca98fca7a965
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,50 @@
+# Contributor: John D Jones III <j[nospace]n[nospace]b[nospace]e[nospace]k[nospace]1972 -_AT_- the domain name google offers a mail service at ending in dot com>
+# Generator : CPANPLUS::Dist::Arch 1.25
+
+pkgname='perl-datetimex-duration-skipdays'
+pkgver='0.002'
+pkgrel='1'
+pkgdesc="Given a starting date, a number of days and a list of days to be skipped, returns the date X number of days away."
+arch=('any')
+license=('PerlArtistic' 'GPL')
+options=('!emptydirs')
+depends=('perl>=5.006' 'perl-datetime' 'perl-datetime-event-holiday-us' 'perl-datetime-format-flexible' 'perl-list-moreutils' 'perl-try-tiny')
+makedepends=('perl-test-checkdeps>=0.002' 'perl-test-deep' 'perl-test-nowarnings' 'perl-test-useallmodules')
+url='http://search.cpan.org/dist/DateTimeX-Duration-SkipDays'
+source=('http://search.cpan.org/CPAN/authors/id/A/AY/AYOUNG/DateTimeX-Duration-SkipDays-0.002.tar.gz')
+md5sums=('2e2ed838ded0c4c4ad75853b651f7a9c')
+sha512sums=('c1663d53fec6f5af69f21f312fa82d690984516726a221f8068c5ff49191ff7daf8bb93c97a9af4a4b775d2ee7b6be87af8f231ce0c39052dfafafc3ec9daa8c')
+_distdir="DateTimeX-Duration-SkipDays-0.002"
+
+build() {
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB="" \
+ PERL_AUTOINSTALL=--skipdeps \
+ PERL_MM_OPT="INSTALLDIRS=vendor DESTDIR='$pkgdir'" \
+ PERL_MB_OPT="--installdirs vendor --destdir '$pkgdir'" \
+ MODULEBUILDRC=/dev/null
+
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Build.PL
+ /usr/bin/perl Build
+ )
+}
+
+check() {
+ cd "$srcdir/$_distdir"
+ ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
+ /usr/bin/perl Build test
+ )
+}
+
+package() {
+ cd "$srcdir/$_distdir"
+ /usr/bin/perl Build install
+
+ find "$pkgdir" -name .packlist -o -name perllocal.pod -delete
+}
+
+# Local Variables:
+# mode: shell-script
+# sh-basic-offset: 2
+# End:
+# vim:set ts=2 sw=2 et: