summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristoph Gysin2017-08-16 23:36:35 +0300
committerChristoph Gysin2017-08-16 23:36:35 +0300
commit18b7bb4a639e1350cff3ff3dfc87dd43ddb99fb1 (patch)
tree40ed88f8b3c375cc9236b707e43973103a56143f
parenta92921a4c26767d164c83f688b023ccb29e378ed (diff)
downloadaur-18b7bb4a639e1350cff3ff3dfc87dd43ddb99fb1.tar.gz
use provided librespot.service
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD16
-rw-r--r--librespot.service15
3 files changed, 7 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b12af7cb9c8..9f94d36b3e22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Mar 19 19:42:53 UTC 2017
+# Wed Aug 16 20:35:49 UTC 2017
pkgbase = librespot-git
pkgdesc = An open source client library for Spotify.
- pkgver = 320.eb49ff3
+ pkgver = 357.ddfc28f
pkgrel = 1
epoch = 1
url = https://github.com/plietar/librespot
@@ -15,13 +15,10 @@ pkgbase = librespot-git
depends = protobuf
provides = librespot
conflicts = librespot
- backup = etc/librespot.conf
source = git+https://github.com/plietar/librespot
source = librespot.conf
- source = librespot.service
sha256sums = SKIP
sha256sums = 3d48207e0be5cf2e68a9ecfd8f418aa1d71fa7f97d562780aa73d2db1a46cac5
- sha256sums = c41110008b16929c7e5f71512cea8dcf92fab36455a61bc2d56ced731918c602
pkgname = librespot-git
diff --git a/PKGBUILD b/PKGBUILD
index 43eb237227ab..faa6b72f596f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=librespot-git
_pkgname=librespot
-pkgver=320.eb49ff3
+pkgver=357.ddfc28f
pkgrel=1
epoch=1
pkgdesc="An open source client library for Spotify."
@@ -13,13 +13,10 @@ depends=('rust' 'protobuf')
makedepends=('cargo' 'portaudio')
provides=('librespot')
conflicts=('librespot')
-backup=('etc/librespot.conf')
source=('git+https://github.com/plietar/librespot'
- 'librespot.conf'
- 'librespot.service')
+ 'librespot.conf')
sha256sums=('SKIP'
- '3d48207e0be5cf2e68a9ecfd8f418aa1d71fa7f97d562780aa73d2db1a46cac5'
- 'c41110008b16929c7e5f71512cea8dcf92fab36455a61bc2d56ced731918c602')
+ '3d48207e0be5cf2e68a9ecfd8f418aa1d71fa7f97d562780aa73d2db1a46cac5')
pkgver()
{
@@ -31,7 +28,7 @@ build()
{
cd "$_pkgname"
cargo build \
- --features pulseaudio-backend \
+ --features alsa-backend \
--release
}
@@ -39,9 +36,6 @@ package()
{
install -D -m 755 "$_pkgname"/target/release/librespot \
"$pkgdir"/usr/bin/librespot
- install -d -m 755 "$pkgdir"/var/cache/librespot
- install -D -m 640 librespot.conf \
- "$pkgdir"/etc/librespot.conf
- install -D -m 644 librespot.service \
+ install -D -m 644 "$_pkgname"/contrib/librespot.service \
"$pkgdir"/usr/lib/systemd/system/librespot.service
}
diff --git a/librespot.service b/librespot.service
deleted file mode 100644
index 7c7c2b7ca307..000000000000
--- a/librespot.service
+++ /dev/null
@@ -1,15 +0,0 @@
-[Unit]
-Description=An open source client library for Spotify
-
-[Service]
-EnvironmentFile=/etc/librespot.conf
-ExecStart=/usr/bin/librespot \
- --cache ${LIBRESPOT_CACHE} \
- --name ${LIBRESPOT_NAME} \
- --bitrate ${LIBRESPOT_BITRATE} \
- --username ${LIBRESPOT_USERNAME} \
- --password ${LIBRESPOT_PASSWORD}
-Restart=always
-
-[Install]
-WantedBy=default.target