summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthekinrar2017-09-17 15:14:20 +0200
committerthekinrar2017-09-17 15:14:20 +0200
commit18b99d1a26964a42dda264a07f449fece4722391 (patch)
tree81ffd19aade5e271b589535fe1c74d6964be4909
parent286ce0f911e7e842d34b952d0c57193e63aef451 (diff)
downloadaur-18b99d1a26964a42dda264a07f449fece4722391.tar.gz
Update to version 23 and apply patch from upstream
-rw-r--r--.SRCINFO14
-rw-r--r--0001-make-ldd-parsing-compatible-with-upstream-glibc-chan.patch31
-rw-r--r--PKGBUILD16
3 files changed, 52 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa75dbd51b80..ef1896121de8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mkinitcpio-nosystemd
pkgdesc = Modular initramfs image creation utility
- pkgver = 22
+ pkgver = 23
pkgrel = 2
url = https://projects.archlinux.org/mkinitcpio.git/
install = mkinitcpio.install
@@ -23,15 +23,19 @@ pkgbase = mkinitcpio-nosystemd
optdepends = lzop: Use lzo compression for the initramfs image
optdepends = lz4: Use lz4 compression for the initramfs image
optdepends = mkinitcpio-nfs-utils: Support for root filesystem on NFS
- provides = mkinitcpio=22-2
+ provides = mkinitcpio=23-2
conflicts = mkinitcpio
backup = etc/mkinitcpio.conf
- source = https://sources.archlinux.org/other/mkinitcpio/mkinitcpio-22.tar.gz
- source = https://sources.archlinux.org/other/mkinitcpio/mkinitcpio-22.tar.gz.sig
+ source = https://sources.archlinux.org/other/mkinitcpio/mkinitcpio-23.tar.gz
+ source = https://sources.archlinux.org/other/mkinitcpio/mkinitcpio-23.tar.gz.sig
source = remove-systemd.patch
- sha256sums = 54c1fc0fc128ae486e72362f49f52e94acd5fcfea9f44b719dc33250e42664eb
+ source = 0001-make-ldd-parsing-compatible-with-upstream-glibc-chan.patch
+ validpgpkeys = 487EACC08557AD082088DABA1EB2638FF56C0C53
+ validpgpkeys = 86CFFCA918CF3AF47147588051E8B148A9999C34
+ sha256sums = 80f12a07f0dceef81dfe87200f099bd2149e0990391dda6defebaa5697f8a35a
sha256sums = SKIP
sha256sums = 4921518d130b73724645b3732ba471005b8755a89a219bb6396e3b082414bb78
+ sha256sums = f534892af930abf8164eead271dc012e42a552362fbb459e55e04d4a68b52a66
pkgname = mkinitcpio-nosystemd
diff --git a/0001-make-ldd-parsing-compatible-with-upstream-glibc-chan.patch b/0001-make-ldd-parsing-compatible-with-upstream-glibc-chan.patch
new file mode 100644
index 000000000000..3e700295d9bc
--- /dev/null
+++ b/0001-make-ldd-parsing-compatible-with-upstream-glibc-chan.patch
@@ -0,0 +1,31 @@
+From 32dbf895d07f07e32d2b3bb4afb132eea1919749 Mon Sep 17 00:00:00 2001
+From: Dave Reisner <dreisner@archlinux.org>
+Date: Mon, 21 Aug 2017 21:33:22 -0400
+Subject: [PATCH] make ldd parsing compatible with upstream glibc changes
+
+https://sourceware.org/git/?p=glibc.git;a=commit;h=eedca9772e99c72ab4c3c34e43cc764250aa3e3c
+---
+ functions | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/functions b/functions
+index 0e1fe0f..941312f 100644
+--- a/functions
++++ b/functions
+@@ -598,10 +598,10 @@ add_binary() {
+ ! lddout=$(ldd "$binary" 2>/dev/null) && return 0
+
+ # resolve sodeps
+- regex='(/.+) \(0x[a-fA-F0-9]+\)'
+- while read line; do
++ regex='^(|.+ )(/.+) \(0x[a-fA-F0-9]+\)'
++ while read -r line; do
+ if [[ $line =~ $regex ]]; then
+- sodep=${BASH_REMATCH[1]}
++ sodep=${BASH_REMATCH[2]}
+ elif [[ $line = *'not found' ]]; then
+ error "binary dependency \`%s' not found for \`%s'" "${line%% *}" "$1"
+ (( ++_builderrors ))
+--
+2.14.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 3a15c467e08e..45a5472877ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# that doesn't depend on systemd
pkgname=mkinitcpio-nosystemd
-pkgver=22
+pkgver=23
pkgrel=2
pkgdesc="Modular initramfs image creation utility"
arch=('any')
@@ -24,14 +24,22 @@ conflicts=('mkinitcpio')
backup=('etc/mkinitcpio.conf')
source=("https://sources.archlinux.org/other/${pkgname%-nosystemd}/${pkgname%-nosystemd}-$pkgver.tar.gz"{,.sig}
'remove-systemd.patch'
+ '0001-make-ldd-parsing-compatible-with-upstream-glibc-chan.patch'
)
install=mkinitcpio.install
-sha256sums=('54c1fc0fc128ae486e72362f49f52e94acd5fcfea9f44b719dc33250e42664eb'
+sha256sums=('80f12a07f0dceef81dfe87200f099bd2149e0990391dda6defebaa5697f8a35a'
'SKIP'
- '4921518d130b73724645b3732ba471005b8755a89a219bb6396e3b082414bb78'
- )
+ '4921518d130b73724645b3732ba471005b8755a89a219bb6396e3b082414bb78'
+ 'f534892af930abf8164eead271dc012e42a552362fbb459e55e04d4a68b52a66'
+ )
+validpgpkeys=('487EACC08557AD082088DABA1EB2638FF56C0C53'
+ '86CFFCA918CF3AF47147588051E8B148A9999C34')
prepare() {
+ cd "$pkgname-$pkgver"
+ patch -p1 -i ../0001-make-ldd-parsing-compatible-with-upstream-glibc-chan.patch
+ cd ".."
+
#start removing systemd related stuff
local d=${srcdir}/${pkgname}-${pkgver}
[ ! -h "$d" ] && ln -s ${pkgname%-nosystemd}-${pkgver} "$d"