summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Hesse2021-03-14 23:13:03 +0100
committerChristian Hesse2021-03-14 23:13:03 +0100
commit18cc025313433996c5c961daf1b3756484b8a183 (patch)
treebca3fbb2b0efd7de46a01fb620550c88cf0d8269
parent60f7b52d05efaab83cda76520198ab3368da14f5 (diff)
downloadaur-18cc025313433996c5c961daf1b3756484b8a183.tar.gz
commit cgit-git 1.2.3.r13.gbd6f568-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD62
-rw-r--r--cgit.install1
-rw-r--r--tmpfiles.conf1
4 files changed, 38 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efa2739c92a3..f080f5fef7fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = cgit-git
pkgdesc = A web interface for git written in plain C - git checkout
- pkgver = 1.2.3.r0.g55fa25a
+ pkgver = 1.2.3.r13.gbd6f568
pkgrel = 1
- url = http://git.zx2c4.com/cgit/
+ url = https://git.zx2c4.com/cgit/
install = cgit.install
arch = i686
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = cgit-git
optdepends = groff: about page using man page syntax
optdepends = python-pygments: syntax highlighting support
optdepends = python-docutils: about page formatted with reStructuredText
- optdepends = python-markdown: about page formated with markdown
+ optdepends = python-markdown: about page formatted with markdown
optdepends = lua51-luaossl: for lua filters
optdepends = gzip: gzip compressed snapshots
optdepends = bzip2: bzip2 compressed snapshots
@@ -28,9 +28,11 @@ pkgbase = cgit-git
conflicts = cgit
source = git://git.zx2c4.com/cgit.git
source = git://github.com/git/git.git
+ source = tmpfiles.conf
source = apache.example.conf
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = 4004b72d433e5810b046fc6019171a11a0dae3e9c6b29a44f16ed41705c46c3d
sha256sums = 89927d462c0504863c163eb8a210e5d65db30ee6e4300ff6a2f92460e4f20a62
pkgname = cgit-git
diff --git a/PKGBUILD b/PKGBUILD
index 1e061404ba46..422d220be2f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,33 +6,35 @@
# Contributor: Andreas Baumann <abaumann at yahoo dot com>
pkgname=cgit-git
-pkgver=1.2.3.r0.g55fa25a
+pkgver=1.2.3.r13.gbd6f568
pkgrel=1
pkgdesc='A web interface for git written in plain C - git checkout'
arch=('i686' 'x86_64')
-url='http://git.zx2c4.com/cgit/'
+url='https://git.zx2c4.com/cgit/'
license=('GPL2')
depends=('openssl' 'luajit')
makedepends=('git' 'zlib' 'curl' 'asciidoc')
optdepends=('groff: about page using man page syntax'
- 'python-pygments: syntax highlighting support'
- 'python-docutils: about page formatted with reStructuredText'
- 'python-markdown: about page formated with markdown'
- 'lua51-luaossl: for lua filters'
- 'gzip: gzip compressed snapshots'
- 'bzip2: bzip2 compressed snapshots'
- 'lzip: lzip compressed snapshots'
- 'xz: xz compressed snapshots'
- 'zstd: zstd compressed snapshots'
- 'mime-types: serve file with correct content-type header')
+ 'python-pygments: syntax highlighting support'
+ 'python-docutils: about page formatted with reStructuredText'
+ 'python-markdown: about page formatted with markdown'
+ 'lua51-luaossl: for lua filters'
+ 'gzip: gzip compressed snapshots'
+ 'bzip2: bzip2 compressed snapshots'
+ 'lzip: lzip compressed snapshots'
+ 'xz: xz compressed snapshots'
+ 'zstd: zstd compressed snapshots'
+ 'mime-types: serve file with correct content-type header')
conflicts=('cgit')
provides=('cgit')
install=cgit.install
source=('git://git.zx2c4.com/cgit.git'
- 'git://github.com/git/git.git'
- 'apache.example.conf')
+ 'git://github.com/git/git.git'
+ 'tmpfiles.conf'
+ 'apache.example.conf')
sha256sums=('SKIP'
'SKIP'
+ '4004b72d433e5810b046fc6019171a11a0dae3e9c6b29a44f16ed41705c46c3d'
'89927d462c0504863c163eb8a210e5d65db30ee6e4300ff6a2f92460e4f20a62')
pkgver() {
@@ -51,35 +53,35 @@ pkgver() {
}
prepare() {
- cd cgit/
+ cd cgit/
- git config --file=.gitmodules submodule.git.url ../git/
- git submodule init
- git submodule update
+ git config --file=.gitmodules submodule.git.url ../git/
+ git submodule init
+ git submodule update
}
build() {
- cd cgit/
+ cd cgit/
- make
- make doc-man
+ make
+ make doc-man
}
check() {
- cd cgit/
+ cd cgit/
- make test
+ make test
}
package() {
- cd cgit/
+ cd cgit/
- make CGIT_SCRIPT_PATH=/usr/share/webapps/cgit DESTDIR="${pkgdir}" prefix=/usr install install-man
+ make CGIT_SCRIPT_PATH=/usr/share/webapps/cgit DESTDIR="${pkgdir}" prefix=/usr install install-man
- install -vd "${pkgdir}/var/cache/cgit"
- install -vDm0644 "${srcdir}/apache.example.conf" "${pkgdir}/etc/webapps/cgit/apache.example.conf"
- install -d "${pkgdir}/usr/lib/cgit"
- mv "${pkgdir}/usr/share/webapps/cgit/cgit.cgi" "${pkgdir}/usr/lib/cgit"
- ln -sf ../../../lib/cgit/cgit.cgi "${pkgdir}/usr/share/webapps/cgit/cgit.cgi"
+ install -vDm0644 "${srcdir}/tmpfiles.conf" "${pkgdir}/usr/lib/tmpfiles.d/cgit.conf"
+ install -vDm0644 "${srcdir}/apache.example.conf" "${pkgdir}/etc/webapps/cgit/apache.example.conf"
+ install -d "${pkgdir}/usr/lib/cgit"
+ mv "${pkgdir}/usr/share/webapps/cgit/cgit.cgi" "${pkgdir}/usr/lib/cgit"
+ ln -sf ../../../lib/cgit/cgit.cgi "${pkgdir}/usr/share/webapps/cgit/cgit.cgi"
}
diff --git a/cgit.install b/cgit.install
index d45792886274..c1c97c9259b2 100644
--- a/cgit.install
+++ b/cgit.install
@@ -1,5 +1,4 @@
post_install() {
- chown -v http:http var/cache/cgit
echo "==> cgit looks at /etc/cgitrc for configuration. There is"
echo "==> an example configuration file in the cgitrc(5) man page."
}
diff --git a/tmpfiles.conf b/tmpfiles.conf
new file mode 100644
index 000000000000..ebb45b121170
--- /dev/null
+++ b/tmpfiles.conf
@@ -0,0 +1 @@
+d /var/cache/cgit 0750 http http -