summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWilliam McKIE2015-11-12 21:48:47 +0100
committerWilliam McKIE2015-11-12 21:48:47 +0100
commit18d97fc34c4941a0492c06fa06246d69ef1b053c (patch)
tree7710b962a0adcdd59881a8e0dfbe067e55982077
parent6a33620c4fa46045f70115664df2b27be3ad54ca (diff)
downloadaur-18d97fc34c4941a0492c06fa06246d69ef1b053c.tar.gz
Update to version 3.4
-rw-r--r--.SRCINFO31
-rw-r--r--.gitignore3
-rwxr-xr-xPKGBUILD98
-rw-r--r--mgcb.sh2
-rw-r--r--monogame-pipeline.sh2
-rw-r--r--monogame.pc.in2
6 files changed, 64 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f81c4ac2aa8..79c60b182521 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,36 +1,35 @@
pkgbase = monogame-git
- pkgdesc = XNA Implementation for Mono based platforms (git)
- pkgver = v3.2.3792
+ pkgdesc = Open Source implementation of the Microsoft XNA 4 Framework.
+ pkgver = 3.4
pkgrel = 1
- url = http://monogame.codeplex.com
- arch = i686
- arch = x86_64
- license = Microsoft Public License
- makedepends = nant
+ url = http://www.monogame.net/
+ arch = any
+ groups = any
+ license = Microsoft Public License (Ms-PL)
+ makedepends = git
makedepends = nvidia-texture-tools
makedepends = dos2unix
makedepends = monodevelop
makedepends = sharpfonts
makedepends = assimp-net
+ depends = gtk-sharp-3
depends = opentk
- depends = sdl_mixer
- depends = sdl_ttf
+ depends = sdl_gfx
depends = sdl_image
+ depends = sdl_mixer
depends = sdl_net
+ depends = sdl_ttf
depends = smpeg
- depends = sdl_gfx
provides = monogame
conflicts = monogame
conflicts = tao-framework
conflicts = tao-framework-svn
- source = monogame::git+https://github.com/mono/MonoGame.git
- source = Dependencies::git+https://github.com/Mono-Game/MonoGame.Dependencies.git
+ source = git+https://github.com/mono/MonoGame.git
source = monogame.pc.in
- source = mgcb.sh
- md5sums = SKIP
+ source = monogame-pipeline.sh
md5sums = SKIP
- md5sums = ca37d66293d3aac43cac32628ed5d6b6
- md5sums = 3cad3825e124ea7b7d060ba492adee47
+ md5sums = c41ca3ef34fc31b114b77bdff626c5a0
+ md5sums = 46a2caa68e21fd99aa4b30b78ab1a109
pkgname = monogame-git
diff --git a/.gitignore b/.gitignore
index 3b4fd7698708..923c879aadef 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,5 +2,4 @@
*.tar.xz
src/
pkg/
-Dependencies/
-monogame/
+[Mm]ono[Gg]ame/
diff --git a/PKGBUILD b/PKGBUILD
index 0120e1e53583..4000a4307347 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,65 +1,57 @@
+# Maintainer: William McKIE <mckie.william@hotmail.co.uk>
pkgname=monogame-git
-pkgver=v3.2.3792
+pkgver=3.4
pkgrel=1
-pkgdesc="XNA Implementation for Mono based platforms (git)"
-arch=(i686 x86_64)
-license=("Microsoft Public License")
-depends=(opentk sdl_mixer sdl_ttf sdl_image sdl_net smpeg sdl_gfx)
-makedepends=(nant nvidia-texture-tools dos2unix monodevelop sharpfonts assimp-net)
-conflicts=(monogame tao-framework tao-framework-svn)
-provides=(monogame)
-url="http://monogame.codeplex.com"
-source=("${pkgname%-*}::git+https://github.com/mono/MonoGame.git"
-"Dependencies::git+https://github.com/Mono-Game/MonoGame.Dependencies.git"
-"monogame.pc.in"
-"mgcb.sh")
-md5sums=(SKIP
-SKIP
-'ca37d66293d3aac43cac32628ed5d6b6'
-'3cad3825e124ea7b7d060ba492adee47')
-
-pkgver () {
- cd "$srcdir/${pkgname%-*}"
- git describe | sed 's|\(.*-.*\)-.*|\1|;s|-|.|'
-}
+pkgdesc="Open Source implementation of the Microsoft XNA 4 Framework."
+arch=('any')
+url="http://www.monogame.net/"
+license=('Microsoft Public License (Ms-PL)')
+groups=('any')
+depends=('gtk-sharp-3' 'opentk' 'sdl_gfx' 'sdl_image' 'sdl_mixer' 'sdl_net' 'sdl_ttf' 'smpeg')
+makedepends=('git' 'nvidia-texture-tools' 'dos2unix' 'monodevelop' 'sharpfonts' 'assimp-net')
+conflicts=('monogame' 'tao-framework' 'tao-framework-svn')
+provides=('monogame')
+source=('git+https://github.com/mono/MonoGame.git'
+ 'monogame.pc.in'
+ 'monogame-pipeline.sh')
+md5sums=(SKIP
+ 'c41ca3ef34fc31b114b77bdff626c5a0'
+ '46a2caa68e21fd99aa4b30b78ab1a109')
prepare() {
- cd "$srcdir/Dependencies"
+ cd "${srcdir}/MonoGame"
+ git checkout --detach v${pkgver}
+ git submodule update --init --recursive
+ cd "${srcdir}/MonoGame/ThirdParty/Dependencies"
find . -type f -exec dos2unix {} \;
- cd ../${pkgname%-*}/ThirdParty/Dependencies
- cp -r ../../../Dependencies/* .
- cd ../..
- find . -name '*.csproj' -exec sed -i 's,<DebugType>none,<DebugType>pdbonly,g' {} \;
- cd "$srcdir/${pkgname%-*}/IDE/MonoDevelop/MonoDevelop.MonoGame"
- sed -i -e "s,assemblies/WindowsGL,/usr/lib/monogame,g" -e "s,\"3\.0\",\"${_mdver}\",g" MonoDevelop.MonoGame.addin.xml
}
build() {
- cd "${srcdir}/${pkgname%-*}"
- mono Protobuild.exe
- nant build_linux
- cd "$srcdir/${pkgname%-*}/IDE/MonoDevelop/MonoDevelop.MonoGame"
- xbuild MonoDevelop.MonoGame.csproj /p:Configuration=Release
- cd ../../../
- xbuild MonoGame.Framework.Linux.sln /p:Configuration=Release
+ cd "${srcdir}/MonoGame"
+ mono Protobuild.exe
+ cd "${srcdir}/MonoGame/IDE/MonoDevelop/MonoDevelop.MonoGame"
+ xbuild MonoDevelop.MonoGame.csproj /p:Configuration=Release
+ cd "${srcdir}/MonoGame"
+ xbuild MonoGame.Framework.Linux.sln /p:Configuration=Release
}
package() {
- cd "${srcdir}/${pkgname%-*}/MonoGame.Framework/bin/Linux/AnyCPU/Release/"
- find . -name 'MonoGame.Framework.*' -exec install -Dm644 {} "$pkgdir/usr/lib/monogame/"{} \;
- find . -name 'Lidgren.Network.dll*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
- find . -name 'NVorbis.dll*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
- find . -name '*.mgfxo' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
- cd "${srcdir}/${pkgname%-*}/MonoGame.Framework.Content.Pipeline/bin/Linux/AnyCPU/Release"
- find . -name 'MonoGame.Framework.Content.Pipeline.dll*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
- find . -name 'Nvidia.TextureTools.dll*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
- cd "${srcdir}/${pkgname%-*}/IDE/MonoDevelop/bin/Release"
- find . -type f -exec install -Dm644 {} "$pkgdir/usr/lib/monodevelop/AddIns/MonoDevelop.MonoGame/"{} \;
- cd "${srcdir}/${pkgname%-*}/Tools/MGCB/bin/Linux/AnyCPU/Release"
- find . -name 'MGCB.Linux.exe*' -exec install -m644 {} "$pkgdir/usr/lib/monogame/"{} \;
- cd "$pkgdir/usr/lib/monogame"
- install -Dm644 "${srcdir}/${pkgname%-*}/LICENSE.txt" "$pkgdir/usr/share/licenses/monogame/LICENSE.txt"
- install -Dm755 "$srcdir/mgcb.sh" "$pkgdir/usr/bin/mgcb"
- install -Dm644 "$srcdir/monogame.pc.in" "$pkgdir/usr/lib/pkgconfig/monogame.pc"
- sed -i "s|@VERSION@|$pkgver|" "$pkgdir/usr/lib/pkgconfig/monogame.pc"
+ cd "${srcdir}/MonoGame/MonoGame.Framework/bin/Linux/AnyCPU/Release"
+ find . -name 'MonoGame.Framework.*' -exec install -Dm644 {} "${pkgdir}/usr/lib/monogame/"{} \;
+ find . -name 'Lidgren.Network.*' -exec install -Dm644 {} "${pkgdir}/usr/lib/monogame/"{} \;
+ cd "${srcdir}/MonoGame/MonoGame.Framework.Content.Pipeline/bin/Linux/AnyCPU/Release"
+ find . -name 'MonoGame.Framework.Content.Pipeline.*' -exec install -Dm644 {} "${pkgdir}/usr/lib/monogame/"{} \;
+ find . -name 'Nvidia.TextureTools.*' -exec install -Dm644 {} "${pkgdir}/usr/lib/monogame/"{} \;
+ find . -name 'ManagedPVRTC.*' -exec install -Dm644 {} "${pkgdir}/usr/lib/monogame/"{} \;
+ cd "${srcdir}/MonoGame/IDE/MonoDevelop/bin/Release"
+ find . -type f -exec install -Dm644 {} "${pkgdir}/usr/lib/monodevelop/AddIns/MonoDevelop.MonoGame/"{} \;
+ cd "${srcdir}/MonoGame/Tools/Pipeline/bin/Linux/AnyCPU/Release"
+ find . -name 'MGCB.*' -exec install -Dm644 {} "${pkgdir}/usr/lib/monogame/"{} \;
+ find . -name 'Pipeline.*' -exec install -Dm644 {} "${pkgdir}/usr/lib/monogame/"{} \;
+ find ./Templates -type f -exec install -Dm644 {} "${pkgdir}/usr/lib/monogame/"{} \;
+
+ install -Dm644 "${srcdir}/MonoGame/LICENSE.txt" "${pkgdir}/usr/share/licenses/monogame/LICENSE.txt"
+ install -Dm755 "${srcdir}/monogame-pipeline.sh" "${pkgdir}/usr/bin/monogame-pipeline"
+ install -Dm644 "${srcdir}/monogame.pc.in" "${pkgdir}/usr/lib/pkgconfig/monogame.pc"
+ sed -i "s,@VERSION@,v${pkgver}," "${pkgdir}/usr/lib/pkgconfig/monogame.pc"
}
diff --git a/mgcb.sh b/mgcb.sh
deleted file mode 100644
index 574a26fe5b30..000000000000
--- a/mgcb.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-#!/bin/sh
-exec /usr/bin/mono $MONO_OPTIONS /usr/lib/monogame/MGCB.Linux.exe "$@"
diff --git a/monogame-pipeline.sh b/monogame-pipeline.sh
new file mode 100644
index 000000000000..38dfd2013cd0
--- /dev/null
+++ b/monogame-pipeline.sh
@@ -0,0 +1,2 @@
+#!/bin/sh
+exec /usr/bin/mono $MONO_OPTIONS /usr/lib/monogame/Pipeline.exe "$@"
diff --git a/monogame.pc.in b/monogame.pc.in
index af501deab090..890bb5b2c950 100644
--- a/monogame.pc.in
+++ b/monogame.pc.in
@@ -3,7 +3,7 @@ exec_prefix=${prefix}
libdir=${prefix}/lib
Name: MonoGame.Framework
-Description: XNA Implementation for Mono based platforms
+Description: Open Source implementation of the Microsoft XNA 4 Framework
Version: @VERSION@
Requires: opentk
Libs: -r:${libdir}/monogame/MonoGame.Framework.dll -r:${libdir}/monogame/Lidgren.Network.dll -r:${libdir}/monogame/Tao.Sdl.dll