summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJaroslav Lichtblau2014-11-28 20:17:14 +0100
committerJaroslav Lichtblau2014-11-28 20:17:14 +0100
commit18eaaea41186bc53031c3c04f27231013462c4f3 (patch)
tree31804ecafb3d4843e9d342b1de4a27db651385f7
downloadaur-18eaaea41186bc53031c3c04f27231013462c4f3.tar.gz
Initial PKGBUILD status as of 28.11.2014
-rw-r--r--.AURINFO12
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
3 files changed, 49 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..c8aff96f7c51
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,12 @@
+pkgbase = sudsds
+ pkgdesc = Fork of the suds library, modified to meet the needs for interaction with the servers of Datové schránky
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://labs.nic.cz/page/969/datovka/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ source = http://www.nic.cz/public_media/datove_schranky/releases/src/sudsds-1.0.1.tar.gz
+
+pkgname = sudsds
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d142fa8a3d61
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = sudsds
+ pkgdesc = Fork of the suds library, modified to meet the needs for interaction with the servers of Datové schránky
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://labs.nic.cz/page/969/datovka/
+ arch = any
+ license = LGPL
+ makedepends = python2-setuptools
+ source = http://www.nic.cz/public_media/datove_schranky/releases/src/sudsds-1.0.1.tar.gz
+ sha256sums = eea36b873a98cce4b5597812f62e2c20eb534dd520a569d6aa250e29ea83ea9c
+
+pkgname = sudsds
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..04bd616f8eca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Jaroslav Lichtblau <dragonlord@aur.archlinux.org>
+
+pkgname=sudsds
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="Fork of the suds library, modified to meet the needs for interaction with the servers of Datové schránky"
+arch=('any')
+url="https://labs.nic.cz/page/969/datovka/"
+license=('LGPL')
+makedepends=('python2-setuptools')
+source=(http://www.nic.cz/public_media/datove_schranky/releases/src/$pkgname-$pkgver.tar.gz)
+sha256sums=('eea36b873a98cce4b5597812f62e2c20eb534dd520a569d6aa250e29ea83ea9c')
+
+package() {
+ cd "${srcdir}"/$pkgname-$pkgver
+
+#Python2 fix
+ for file in $(find . -name '*.py' -print); do
+ sed -i 's_^#!.*/usr/bin/python_#!/usr/bin/python2_' $file
+ sed -i 's_^#!.*/usr/bin/env.*python_#!/usr/bin/env python2_' $file
+ done
+
+ python2 setup.py install --root="${pkgdir}"
+}