summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Martin2018-01-14 22:42:03 -0600
committerStephen Martin2018-01-14 22:42:03 -0600
commit1910b568e166466b1664f51ff68956251faaa442 (patch)
treece5c3eb4c7c445c7048ac10d24f8a2e1d0290875
parent72545e9dea0fea9631b43cf0dc4c7aa47560e0a2 (diff)
downloadaur-1910b568e166466b1664f51ff68956251faaa442.tar.gz
v.8.5
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--include.patch6
-rw-r--r--rlibrary.patch4
4 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e68897c2590b..9904ae7509b0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Oct 28 01:54:52 UTC 2017
+# Mon Jan 15 04:41:50 UTC 2018
pkgbase = jasp-desktop-git
pkgdesc = JASP, a low fat alternative to SPSS, a delicious alternative to R.
- pkgver = v0.8.3.1.r0.g480272b1
+ pkgver = v0.8.5.r0.g3242143a
pkgrel = 1
url = http://jasp-stats.org
arch = any
@@ -29,10 +29,10 @@ pkgbase = jasp-desktop-git
conflicts = jasp
conflicts = jasp-desktop
options = !strip
- source = jasp-desktop::git+https://github.com/jasp-stats/jasp-desktop.git#tag=v0.8.3.1
+ source = jasp-desktop::git+https://github.com/jasp-stats/jasp-desktop.git#tag=v0.8.5
source = include.patch
md5sums = SKIP
- md5sums = a703cd01dddd301d89425b47cb2a0c61
+ md5sums = 846d0f24ef877c895ae027aed7588bdc
pkgname = jasp-desktop-git
diff --git a/PKGBUILD b/PKGBUILD
index 2c170b8ab113..917e8fbb8ca8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=jasp-desktop-git
_pkgname=jasp-desktop
_buildname=jasp-build
-pkgver=v0.8.3.1.r0.g480272b1
+pkgver=v0.8.5.r0.g3242143a
pkgrel=1
pkgdesc="JASP, a low fat alternative to SPSS, a delicious alternative to R."
arch=('any')
@@ -13,7 +13,7 @@ makedepends=('git' 'r' 'gcc-fortran' 'boost' 'jasp-rbundle' 'r-cran-rinside')
provides=('jasp' 'jasp-desktop')
conflicts=('jasp' 'jasp-desktop')
options=('!strip')
-source=("$_pkgname::git+https://github.com/jasp-stats/$_pkgname.git#tag=v0.8.3.1"
+source=("$_pkgname::git+https://github.com/jasp-stats/$_pkgname.git#tag=v0.8.5"
"include.patch")
pkgver() {
@@ -60,4 +60,4 @@ package() {
ln -s /usr/lib/JASP/jasp $pkgdir/usr/bin/JASP
}
md5sums=('SKIP'
- 'a703cd01dddd301d89425b47cb2a0c61')
+ '846d0f24ef877c895ae027aed7588bdc')
diff --git a/include.patch b/include.patch
index 3bcfdb03af23..b5d2808c189a 100644
--- a/include.patch
+++ b/include.patch
@@ -1,11 +1,11 @@
diff --git a/JASP-Engine/JASP-Engine.pro b/JASP-Engine/JASP-Engine.pro
-index 1eb77cdf..438b206d 100644
+index 82f3f985..197fd8f6 100644
--- a/JASP-Engine/JASP-Engine.pro
+++ b/JASP-Engine/JASP-Engine.pro
-@@ -73,6 +73,7 @@ INCLUDEPATH += \
-
+@@ -76,6 +76,7 @@ INCLUDEPATH += \
linux:INCLUDEPATH += \
/usr/share/R/include \
+ /usr/lib/R/library/include \
+ /usr/include/R \
$$_R_HOME/site-library/Rcpp/include
diff --git a/rlibrary.patch b/rlibrary.patch
index 3621dabb74b3..746f58814393 100644
--- a/rlibrary.patch
+++ b/rlibrary.patch
@@ -1,8 +1,8 @@
diff --git a/JASP-Desktop/enginesync.cpp b/JASP-Desktop/enginesync.cpp
-index 49e215b..a87db98 100644
+index a251a519..88725d45 100644
--- a/JASP-Desktop/enginesync.cpp
+++ b/JASP-Desktop/enginesync.cpp
-@@ -408,7 +408,7 @@ void EngineSync::startSlaveProcess(int no)
+@@ -429,7 +429,7 @@ void EngineSync::startSlaveProcess(int no)
env.insert("LD_LIBRARY_PATH", rHome.absoluteFilePath("lib") + ";" + rHome.absoluteFilePath("library/RInside/lib") + ";" + rHome.absoluteFilePath("library/Rcpp/lib") + ";" + rHome.absoluteFilePath("site-library/RInside/lib") + ";" + rHome.absoluteFilePath("site-library/Rcpp/lib"));
env.insert("R_HOME", rHome.absolutePath());