summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhvalera2023-03-04 01:35:38 +0200
committerkhvalera2023-03-04 01:35:38 +0200
commit19206753922a9cdbc7af15f328cd4b6580079999 (patch)
treee2da45c657424978a54f947a743a7647abc3cd83
parent0fc12db76364adbe4765135289876a57ab53a817 (diff)
downloadaur-19206753922a9cdbc7af15f328cd4b6580079999.tar.gz
22.0.2_2
-rw-r--r--.SRCINFO27
-rw-r--r--0005-httpd.patch22
-rw-r--r--0006-hostname.patch11
-rw-r--r--PKGBUILD44
4 files changed, 82 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1990623cfe9..eebc236e2fad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = bareos
pkgdesc = Bareos - Backup Archiving Recovery Open Sourced
pkgver = 22.0.2
- pkgrel = 1
+ pkgrel = 2
url = http://www.bareos.org
arch = i686
arch = x86_64
@@ -28,13 +28,15 @@ pkgbase = bareos
source = 0003-version.patch
source = 0004-sqlspam.patch
source = 0005-httpd.patch
+ source = 0006-hostname.patch
source = bootstrap-table-locale-all.min.js
md5sums = SKIP
md5sums = 419b0c64af750aa3e8ea668edf464d3e
md5sums = 39724df5903b712fb8d34209c7ac8f1e
md5sums = 5bf1233d94dfecc9060746bfb39b9d2b
md5sums = ca4c929a2462cafaead8d0b49e3cebed
- md5sums = 33d9c3a1d25b30ac2182aa8d874e28a5
+ md5sums = a6a260808e46c20b1c22aa2efebc3fe1
+ md5sums = 40fc1919d59133214466972b3f9aa6d2
md5sums = e78b88f897cfc3e60129eec360521e3d
pkgname = bareos-bconsole
@@ -260,14 +262,29 @@ pkgname = bareos-vmware-plugin
pkgname = bareos-webui
pkgdesc = Bareos - Backup Archiving Recovery Open Sourced - Webui (Bareos web administration)
- depends = php7
- depends = php7-fpm
+ arch = any
depends = jansson
backup = etc/bareos-webui/directors.ini
backup = etc/bareos-webui/configuration.ini
backup = etc/bareos/bareos-dir.d/console/admin.conf.example
backup = etc/bareos/bareos-dir.d/profile/webui-admin.conf
- backup = etc/httpd/conf.d/bareos-webui.conf
+
+pkgname = bareos-webui-apache
+ pkgdesc = Bareos - Backup Archiving Recovery Open Sourced - Webui Apache
+ arch = any
+ depends = apache
+ depends = php-apache
+ depends = php
+ depends = php-fpm
+ backup = etc/httpd/conf/extra/bareos-webui.conf
+
+pkgname = bareos-webui-nginx
+ pkgdesc = Bareos - Backup Archiving Recovery Open Sourced - Webui nginx
+ arch = any
+ depends = nginx
+ depends = php
+ depends = php-fpm
+ backup = etc/nginx/bareos-webui.conf
pkgname = bareos-devel
pkgdesc = Bareos - Backup Archiving Recovery Open Sourced - Devel headers
diff --git a/0005-httpd.patch b/0005-httpd.patch
index c8d8e8a56876..247ba934e6ba 100644
--- a/0005-httpd.patch
+++ b/0005-httpd.patch
@@ -1,11 +1,13 @@
---- webui/CMakeLists.txt 2022-05-10 23:29:44.000000000 +0300
-+++ webui/CMakeLists.txt 2022-05-11 00:05:05.698335917 +0300
-@@ -76,7 +76,7 @@
- elseif(EXISTS ${sysconfdir}/apache2/conf-available)
- set(HTTPD_CONF ${sysconfdir}/apache2/conf-available)
- else()
-- set(HTTPD_CONF ${sysconfdir}/httpd/conf.d)
-+ set(HTTPD_CONF ${sysconfdir}/httpd/conf/extra )
- endif()
+--- webui/CMakeLists.txt.orig 2023-03-03 21:55:18.000000000 +0200
++++ webui/CMakeLists.txt 2023-03-03 22:01:47.835425931 +0200
+@@ -66,7 +66,9 @@
+ message(" BAREOS_FULL_VERSION: ${BAREOS_FULL_VERSION} ")
+ message(" LocalBuildDefinitionsFile: ${BareosLocalBuildDefinitionsFile}")
- configure_file(
+-if(EXISTS ${sysconfdir}/httpd/conf.d)
++if(EXISTS ${sysconfdir}/httpd/conf/extra )
++ set(HTTPD_CONF ${sysconfdir}/httpd/conf/extra )
++elseif(EXISTS ${sysconfdir}/httpd/conf.d)
+ set(HTTPD_CONF ${sysconfdir}/httpd/conf.d)
+ elseif(EXISTS ${sysconfdir}/apache2/conf.d)
+ set(HTTPD_CONF ${sysconfdir}/apache2/conf.d)
diff --git a/0006-hostname.patch b/0006-hostname.patch
new file mode 100644
index 000000000000..ac9be85634d8
--- /dev/null
+++ b/0006-hostname.patch
@@ -0,0 +1,11 @@
+--- core/scripts/bareos-config-lib.sh.in.orig 2023-03-03 18:31:34.000000000 +0200
++++ core/scripts/bareos-config-lib.sh.in 2023-03-03 18:58:35.163665093 +0200
+@@ -998,7 +998,7 @@
+ {
+ # put actual short hostname in configuration files
+ # try to get short hostname
+- hname=$(hostname -s)
++ hname=$(hostnamectl hostname)
+ if [ -z "${hname}" ]; then
+ # try to get long hostname
+ hname=$(hostname|sed 's/\..*//g')
diff --git a/PKGBUILD b/PKGBUILD
index 06ab445507c8..e20154a18695 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -35,6 +35,8 @@ pkgname=("bareos-bconsole"
"bareos-traymonitor"
"bareos-vmware-plugin"
"bareos-webui"
+ "bareos-webui-apache"
+ "bareos-webui-nginx"
"bareos-devel"
"python-bareos"
)
@@ -48,7 +50,7 @@ pkgname=("bareos-bconsole"
pkgver=22.0.2
pkgmajor=${pkgver%%.*}
-pkgrel=1
+pkgrel=2
arch=(i686 x86_64 armv7h aarch64)
groups=('bareos')
pkgdesc="Bareos - Backup Archiving Recovery Open Sourced"
@@ -62,14 +64,18 @@ source=("git+https://github.com/bareos/bareos.git#tag=Release/${pkgver}"
"0003-version.patch"
"0004-sqlspam.patch"
"0005-httpd.patch"
+ "0006-hostname.patch"
"bootstrap-table-locale-all.min.js")
+
md5sums=('SKIP'
'419b0c64af750aa3e8ea668edf464d3e'
'39724df5903b712fb8d34209c7ac8f1e'
'5bf1233d94dfecc9060746bfb39b9d2b'
'ca4c929a2462cafaead8d0b49e3cebed'
- '33d9c3a1d25b30ac2182aa8d874e28a5'
+ 'a6a260808e46c20b1c22aa2efebc3fe1'
+ '40fc1919d59133214466972b3f9aa6d2'
'e78b88f897cfc3e60129eec360521e3d')
+
python3_ver="3.10"
#python2_ver="2.7"
@@ -819,21 +825,20 @@ package_bareos-vmware-plugin() {
#=========================================
package_bareos-webui() {
+ arch=(any)
pkgdesc="${pkgdesc} - Webui (Bareos web administration)"
- depends=('php7' 'php7-fpm' 'jansson')
- optdepend=('apache' 'nginx' 'php7-apache' )
+ depends=('jansson')
+ optdepend=( 'bareos-webui-apache' 'bareos-webui-nginx' )
backup=('etc/bareos-webui/directors.ini'
'etc/bareos-webui/configuration.ini'
'etc/bareos/bareos-dir.d/console/admin.conf.example'
- 'etc/bareos/bareos-dir.d/profile/webui-admin.conf'
- 'etc/httpd/conf.d/bareos-webui.conf')
+ 'etc/bareos/bareos-dir.d/profile/webui-admin.conf')
for f in \
etc/bareos/bareos-dir.d/console/admin.conf.example \
etc/bareos/bareos-dir.d/profile/webui-admin.conf \
etc/bareos/bareos-dir.d/profile/webui-limited.conf.example \
etc/bareos/bareos-dir.d/profile/webui-readonly.conf \
- etc/httpd/conf.d/bareos-webui.conf \
etc/bareos-webui/directors.ini \
etc/bareos-webui/configuration.ini \
usr/share/bareos-webui \
@@ -846,6 +851,31 @@ package_bareos-webui() {
}
#=========================================
+package_bareos-webui-apache() {
+ arch=(any)
+ pkgdesc="${pkgdesc} - Webui Apache"
+ depends=('apache' 'php-apache' 'php' 'php-fpm')
+ backup=('etc/httpd/conf/extra/bareos-webui.conf')
+
+ for f in \
+ etc/httpd/conf/extra/bareos-webui.conf \
+ ; do
+ cp_pkgdir "$f" "$srcdir/install"
+ done
+}
+
+#=========================================
+package_bareos-webui-nginx() {
+ arch=(any)
+ pkgdesc="${pkgdesc} - Webui nginx"
+ depends=('nginx' 'php' 'php-fpm')
+ backup=('etc/nginx/bareos-webui.conf')
+
+ mkdir -p "$pkgdir"/etc/nginx
+ cp ${srcdir}/bareos/webui/install/nginx/bareos-webui.conf ${pkgdir}/etc/nginx/bareos-webui.conf
+}
+
+#=========================================
package_python-bareos() {
pkgdesc="${pkgdesc} - python-bareos is a Python module to access a backup system."
depends=('python' 'python-sslpsk' 'jansson')