summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjose17112018-05-21 22:12:04 +0200
committerjose17112018-05-21 22:12:04 +0200
commit192075a74f54b88c35b87d73cde9c9df80d0cf5b (patch)
treef43a87f21a5875c27ca03758d897f493c35f545b
downloadaur-192075a74f54b88c35b87d73cde9c9df80d0cf5b.tar.gz
Adopted from aur3 (+ updated & fixed)
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD32
-rw-r--r--gadmin-bind-menu6
-rw-r--r--gadmin-bind.desktop6
4 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c68f18267ae7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+# Generated by mksrcinfo v8
+# Mon May 21 20:11:55 UTC 2018
+pkgbase = gadmin-bind
+ pkgdesc = A GTK+ Application to help administrate BIND
+ pkgver = 0.2.8
+ pkgrel = 1
+ url = http://dalalven.dtdns.net/linux/gadmintools-webpage/app_pages/gadmin-bind.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk3
+ depends = bind
+ optdepends = gksu: Graphical SU Support
+ source = http://dalalven.dtdns.net/linux/gadmin-bind/gadmin-bind-0.2.8.tar.gz
+ source = gadmin-bind-menu
+ source = gadmin-bind.desktop
+ md5sums = ae4686c0417ac542b54aaf6d7a76d893
+ md5sums = 8705c6ad45bdd08022cef2de4cd8bbc7
+ md5sums = 0fd7b067494e1edef07a9ec5a8a38643
+
+pkgname = gadmin-bind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1f4896cd93e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Contributor: Nathan Owe <ndowens.aur at gmail dot com>
+# Maintainer: Jose Riha <jose1711 gmail com>
+
+pkgname=gadmin-bind
+pkgver=0.2.8
+pkgrel=1
+pkgdesc="A GTK+ Application to help administrate BIND"
+arch=('i686' 'x86_64')
+url="http://dalalven.dtdns.net/linux/gadmintools-webpage/app_pages/gadmin-bind.html"
+license=('GPL')
+depends=('gtk3' 'bind')
+optdepends=('gksu: Graphical SU Support')
+source=("http://dalalven.dtdns.net/linux/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ "${pkgname}-menu"
+ "${pkgname}.desktop"
+ )
+md5sums=('ae4686c0417ac542b54aaf6d7a76d893'
+ '8705c6ad45bdd08022cef2de4cd8bbc7'
+ '0fd7b067494e1edef07a9ec5a8a38643')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install sbindir=/usr/bin
+ install -m644 -D $srcdir/gadmin-bind.desktop $pkgdir/usr/share/applications/gadmin-bind.desktop
+ install -m755 $srcdir/gadmin-bind-menu $pkgdir/usr/bin/gadmin-bind-menu
+}
diff --git a/gadmin-bind-menu b/gadmin-bind-menu
new file mode 100644
index 000000000000..31b6ffd0627e
--- /dev/null
+++ b/gadmin-bind-menu
@@ -0,0 +1,6 @@
+#!/bin/sh
+if [ -f /usr/bin/gksu ]; then
+ gksu /usr/bin/gadmin-bind
+else
+ /usr/bin/gadmin-bind
+fi
diff --git a/gadmin-bind.desktop b/gadmin-bind.desktop
new file mode 100644
index 000000000000..2f3c452934d3
--- /dev/null
+++ b/gadmin-bind.desktop
@@ -0,0 +1,6 @@
+[Desktop Entry]
+Type=Application
+Name=Gadmin Bind
+Icon=gadmin-bind
+Exec=gadmin-bind-menu
+Categories=Applications;System;