summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAutumn Boyhan2021-10-18 08:55:02 -0400
committerAutumn Boyhan2021-10-18 08:55:02 -0400
commit19352efb799bc17933d7ffc5ad8c7fad424fd007 (patch)
tree2abab79d5321f85319db0debcf5896b4c9ae82d7
downloadaur-19352efb799bc17933d7ffc5ad8c7fad424fd007.tar.gz
Initial commit for v2.0-post0.
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD22
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..cb28ad7969a1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-sge
+ pkgdesc = The Seclusion Game Engine, or SGE, is a general-purpose 2-D game engine.
+ pkgver = 2.0.post0
+ pkgrel = 1
+ url = https://python-sge.github.io/
+ arch = x86_64
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-pygame
+ provides = python-sge
+ conflicts = python-sge
+ source = https://github.com/python-sge/sge/archive/refs/tags/v2.0.post0.tar.gz
+ md5sums = bc6363ad02da7c015d46fabb5367b2a7
+
+pkgname = python-sge
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0a413b2a570e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Autumn Boyhan <autumn@crisismodel.com>
+
+pkgname=python-sge
+_pkgname=sge
+pkgver=2.0.post0
+pkgrel=1
+pkgdesc="The Seclusion Game Engine, or SGE, is a general-purpose 2-D game engine."
+arch=('x86_64')
+url="https://python-sge.github.io/"
+license=('GPL3')
+depends=('python' 'python-pygame')
+makedepends=('python-setuptools')
+provides=('python-sge')
+conflicts=('python-sge')
+_name=${pkgname#python-}
+source=("https://github.com/python-sge/sge/archive/refs/tags/v${pkgver}.tar.gz")
+md5sums=('bc6363ad02da7c015d46fabb5367b2a7')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}