summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVincent Grande2021-01-05 20:19:17 -0500
committerVincent Grande2021-01-05 20:19:17 -0500
commit19616e26052e6e82441319d05d8c21b0b402cb75 (patch)
tree35ce359752524813b05c750b2da2b8c680cfb554
downloadaur-19616e26052e6e82441319d05d8c21b0b402cb75.tar.gz
initial upload
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD76
2 files changed, 103 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..74f3855ea516
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = lib32-nss-hg
+ pkgdesc = Network Security Services (32-bit)
+ pkgver = 3.60
+ pkgrel = 1
+ url = https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS
+ arch = x86_64
+ license = MPL
+ license = GPL
+ makedepends = perl
+ makedepends = python
+ makedepends = gyp
+ depends = lib32-nspr
+ depends = lib32-sqlite
+ depends = lib32-zlib
+ depends = lib32-p11-kit>=0.23.19
+ provides = lib32-nss
+ conflicts = lib32-nss
+ source = hg+https://hg.mozilla.org/projects/nss
+ sha256sums = SKIP
+
+pkgname = lib32-nss-hg
+ depends = lib32-nspr
+ depends = lib32-sqlite
+ depends = lib32-zlib
+ depends = lib32-p11-kit>=0.23.19
+ depends = nss
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5b843a464d1b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,76 @@
+# Maintainer: Vincent Grande <shoober420@gmail.com>
+# Contributor: Franziskus Kiefer <arch@franziskuskiefer.de>
+# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
+# Contributor: Daniel Wallace <danielwallace at gtmanfred dot com>
+# Contributor: kfgz <kfgz at interia pl>
+# Contributor: Ionut Biru <ibiru at archlinux dot org>
+
+pkgname=lib32-nss-hg
+pkgver=3.60
+pkgrel=1
+pkgdesc="Network Security Services (32-bit)"
+url="https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS"
+arch=(x86_64)
+license=(MPL GPL)
+depends=(lib32-nspr lib32-sqlite lib32-zlib 'lib32-p11-kit>=0.23.19')
+makedepends=(perl python gyp)
+provides=(lib32-nss)
+conflicts=(lib32-nss)
+source=("hg+https://hg.mozilla.org/projects/nss")
+sha256sums=('SKIP')
+
+pkgver() {
+ local vmajor vminor vpatch
+ cd nss
+
+ { read vmajor; read vminor; read vpatch; } \
+ < <(awk '/#define.*NSS_V(MAJOR|MINOR|PATCH)/ {print $3}' lib/nss/nss.h)
+
+ printf "%s.%s.%sr%s.%s" "$vmajor" "$vminor" "$vpatch" "$(hg identify -n)" "$(hg identify -i)"
+}
+
+prepare() {
+ cd nss
+
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1382942
+# patch -Np1 -i "$srcdir/0001-Hack-mpi_x64.s-to-work-with-fno-plt.patch"
+}
+
+build() {
+ cd nss
+ ./build.sh \
+ --target ia32 \
+ --opt \
+ --system-sqlite \
+ --system-nspr \
+ --enable-libpkix \
+ --disable-tests
+}
+
+package() {
+ depends+=(nss)
+
+ cd nss
+
+ local libdir=/usr/lib32 nsprver="$(i686-pc-linux-gnu-pkg-config --modversion nspr)"
+ sed nss/pkg/pkg-config/nss.pc.in \
+ -e "s,%libdir%,$libdir,g" \
+ -e "s,%prefix%,/usr,g" \
+ -e "s,%exec_prefix%,/usr/bin,g" \
+ -e "s,%includedir%,/usr/include/nss,g" \
+ -e "s,%NSPR_VERSION%,$nsprver,g" \
+ -e "s,%NSS_VERSION%,$pkgver,g" |
+ install -Dm644 /dev/stdin "$pkgdir$libdir/pkgconfig/nss.pc"
+
+ ln -s nss.pc "$pkgdir$libdir/pkgconfig/mozilla-nss.pc"
+
+ install -Dt "$pkgdir$libdir" dist/Release/lib/*.so
+ install -Dt "$pkgdir$libdir" -m644 dist/Release/lib/*.chk
+
+
+ # Replace built-in trust with p11-kit connection
+ ln -s pkcs11/p11-kit-trust.so "$pkgdir$libdir/p11-kit-trust.so"
+ ln -sf p11-kit-trust.so "$pkgdir$libdir/libnssckbi.so"
+}
+
+# vim:set sw=2 et: