summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 16:07:14 +0200
committerM0Rf302015-06-17 16:07:14 +0200
commit196752e83696fcd3fcc9baec8adc9665f87427e7 (patch)
tree75043ad2fd848c7a44e74fe2431b8ce8722fc848
downloadaur-196752e83696fcd3fcc9baec8adc9665f87427e7.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD43
-rw-r--r--pump.io25
-rw-r--r--pump.io.install21
-rw-r--r--pump.io.json16
-rw-r--r--pump.io.service15
6 files changed, 148 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d12d592d4425
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = pump.io
+ pkgdesc = This is pump.io. It's a stream server that does most of what people really want from a social network
+ pkgver = 0.3.0
+ pkgrel = 2
+ url = http://pump.io
+ install = pump.io.install
+ arch = i686
+ arch = x86_64
+ license = Apache
+ depends = nodejs
+ depends = graphicsmagick
+ optdepends = mongodb
+ optdepends = redis
+ provides = pumpio
+ conflicts = pumpio-git
+ conflicts = pumpio
+ backup = etc/webapps/pump.io/pump.io.json
+ source = https://github.com/e14n/pump.io/archive/v0.3.0.tar.gz
+ source = pump.io.service
+ source = pump.io.json
+ source = pump.io
+ md5sums = fdc06c33645594049eaab481af133f75
+ md5sums = dcfd7c74792755996d0d9589bfaf6747
+ md5sums = d072eb2d992586e013c06c64786fc4ca
+ md5sums = 067b3c2fee9cef8a596bac9e9d89ae75
+
+pkgname = pump.io
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..990830daaa0b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: M0Rf30
+
+pkgname=pump.io
+pkgver=0.3.0
+pkgrel=2
+pkgdesc="This is pump.io. It's a stream server that does most of what people really want from a social network"
+url='http://pump.io'
+license=('Apache')
+arch=('i686' 'x86_64')
+depends=('nodejs' 'graphicsmagick')
+optdepends=('mongodb' 'redis')
+provides=('pumpio')
+conflicts=('pumpio-git' 'pumpio')
+install=${pkgname}.install
+backup=(etc/webapps/$pkgname/$pkgname.json)
+source=(https://github.com/e14n/pump.io/archive/v$pkgver.tar.gz
+ $pkgname.service
+ $pkgname.json
+ $pkgname)
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ export PYTHON=/usr/bin/python2
+ npm install
+ npm install databank-mongodb
+ npm install databank-redis
+}
+
+package() {
+ cd $srcdir
+ mkdir -p $pkgdir/usr/share/webapps/
+ mkdir -p $pkgdir/usr/lib/systemd/system/
+ mkdir -p $pkgdir/etc/webapps/$pkgname/
+ install -Dm755 pump.io $pkgdir/usr/bin/pump.io
+ cp -r $pkgname-$pkgver $pkgdir/usr/share/webapps/$pkgname
+ cp $pkgname.json $pkgdir/etc/webapps/$pkgname/$pkgname.json
+ cp $pkgname.service $pkgdir/usr/lib/systemd/system/
+}
+
+md5sums=('fdc06c33645594049eaab481af133f75'
+ 'dcfd7c74792755996d0d9589bfaf6747'
+ 'd072eb2d992586e013c06c64786fc4ca'
+ '067b3c2fee9cef8a596bac9e9d89ae75')
diff --git a/pump.io b/pump.io
new file mode 100644
index 000000000000..81fd9abaed8d
--- /dev/null
+++ b/pump.io
@@ -0,0 +1,25 @@
+#!/bin/bash
+
+WorkingDirectory=/usr/share/webapps/pump.io
+cd $WorkingDirectory
+# depending on parameter -- startup, shutdown, restart
+# of the instance and listener or usage display
+
+case "$1" in
+ start)
+ # Oracle listener and instance startup
+ node ./bin/pump -c /etc/webapps/pump.io/pump.io.json start &
+ ;;
+ stop)
+ # Oracle listener and instance shutdown
+ node ./bin/pump -c /etc/webapps/pump.io/pump.io.json stop
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "Usage: $0 start|stop|restart"
+ exit 1
+esac
+exit 0 \ No newline at end of file
diff --git a/pump.io.install b/pump.io.install
new file mode 100644
index 000000000000..f647bee3691a
--- /dev/null
+++ b/pump.io.install
@@ -0,0 +1,21 @@
+pumpuser=pump
+pumphome=/usr/share/webapps/pump.io
+
+_chown() {
+ chown -R $pumpuser:$pumpuser $pumphome
+}
+
+post_install() {
+ getent passwd $pumpuser &> /dev/null || useradd -r -d $pumphome -s /bin/bash $pumpuser
+ _chown
+ echo 'Edit the file /etc/webapps/pump.io/pump.io.json as needed. Please look over the documentation at http://pump.io/#configuration'
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ getent passwd $pumpuser &> /dev/null && userdel -f $pumpuser
+ return 0
+}
diff --git a/pump.io.json b/pump.io.json
new file mode 100644
index 000000000000..c58b2f7d5a1c
--- /dev/null
+++ b/pump.io.json
@@ -0,0 +1,16 @@
+{
+ "driver": "memory",
+ "secret": "my dog has fleas",
+ "noweb": false,
+ "site": "Awesome Sauce",
+ "owner": "Awesome Inc.",
+ "ownerURL": "http://example.com/",
+ "port": 8000,
+ "hostname": "localhost",
+ "address": "localhost",
+ "nologger": false,
+ "serverUser": "pump",
+ "uploaddir": "/tmp/pump.io/uploads",
+ "debugClient": false,
+ "firehose": "ofirehose.example"
+}
diff --git a/pump.io.service b/pump.io.service
new file mode 100644
index 000000000000..5a90e8d404a0
--- /dev/null
+++ b/pump.io.service
@@ -0,0 +1,15 @@
+[Unit]
+Description=Pump.io Social Server
+After=network.target
+
+[Service]
+Type=forking
+User=pump
+Group=pump
+ExecStart=/usr/bin/pump.io start
+ExecStop=/usr/bin/pump.io stop
+Restart=always
+SyslogIdentifier=pump.io
+
+[Install]
+WantedBy=multi-user.target