summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEduardo Escobar2017-12-24 11:37:50 -0300
committerEduardo Escobar2017-12-24 11:37:50 -0300
commit19725caf28fb1d7afe6802d53aa607828a096e77 (patch)
treef1f90945a03873557c91366b8361bbc95b527ca1
downloadaur-19725caf28fb1d7afe6802d53aa607828a096e77.tar.gz
Submitted 0.12.9-1
-rw-r--r--.SRCINFO33
-rw-r--r--PKGBUILD48
-rw-r--r--libpng14.patch21
-rw-r--r--stellarium.desktop9
-rw-r--r--stellarium.install14
-rw-r--r--stellarium.pngbin0 -> 18780 bytes
6 files changed, 125 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..029da3941fbf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,33 @@
+pkgbase = stellarium-lts
+ pkgdesc = A stellarium with great graphics and a nice database of sky-objects. LTS version for old/weak graphics cards
+ pkgver = 0.12.9
+ pkgrel = 1
+ url = http://stellarium.org/
+ install = stellarium.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = boost
+ makedepends = mesa
+ makedepends = mesa-libgl
+ depends = libpng
+ depends = glu
+ depends = libgl
+ depends = freetype2
+ depends = qt4
+ depends = openssl
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = phonon-qt4
+ provides = stellarium
+ conflicts = stellarium
+ source = http://downloads.sourceforge.net/stellarium/stellarium-0.12.9.tar.gz
+ source = stellarium.desktop
+ source = stellarium.png
+ md5sums = ed95879c38e7370ed895df47ef7b1aac
+ md5sums = b4f9ebd082c4e112c2bbfac9f2c8465d
+ md5sums = 134ab08e73f4f5d995a7931a7957b7a3
+
+pkgname = stellarium-lts
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd70552e335c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# $Id$
+# Mantainer: Eduardo escobar <eduardoeae@gmail.com>
+# Contributor: Ronald van Haren <ronald.archlinux.org>
+# Contributor: Damir Perisa <damir.perisa@bluewin.ch>
+
+pkgname=stellarium-lts
+_pkgname=stellarium
+pkgver=0.12.9
+pkgrel=1
+pkgdesc="A stellarium with great graphics and a nice database of sky-objects. LTS version for old/weak graphics cards"
+arch=("i686" "x86_64")
+url="http://stellarium.org/"
+license=('GPL2')
+depends=('libpng' 'glu' 'libgl' 'freetype2' 'qt4' 'openssl' 'desktop-file-utils'
+ 'xdg-utils' 'phonon-qt4')
+provides=("stellarium")
+conflicts=("stellarium")
+install=stellarium.install
+makedepends=('cmake' 'boost' 'mesa' 'mesa-libgl')
+source=(http://downloads.sourceforge.net/$_pkgname/$_pkgname-$pkgver.tar.gz
+ stellarium.desktop
+ stellarium.png)
+md5sums=('ed95879c38e7370ed895df47ef7b1aac'
+ 'b4f9ebd082c4e112c2bbfac9f2c8465d'
+ '134ab08e73f4f5d995a7931a7957b7a3')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ # Fix for build fail
+ CFLAGS="$CFLAGS -fpermissive"
+ CXXFLAGS="$CXXFLAGS -fpermissive"
+
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=RELEASE
+ make
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+
+ make DESTDIR=${pkgdir} install
+
+ # install desktop file & pixmap
+ install -Dm644 ${srcdir}/stellarium.desktop \
+ ${pkgdir}/usr/share/applications/stellarium.desktop
+ install -Dm644 ${srcdir}/stellarium.png \
+ ${pkgdir}/usr/share/pixmaps/stellarium.png
+}
diff --git a/libpng14.patch b/libpng14.patch
new file mode 100644
index 000000000000..7ed1da689050
--- /dev/null
+++ b/libpng14.patch
@@ -0,0 +1,21 @@
+diff -Naur stellarium-0.10.2-orig/src/core/StelTextureMgr.cpp stellarium-0.10.2/src/core/StelTextureMgr.cpp
+--- stellarium-0.10.2-orig/src/core/StelTextureMgr.cpp 2010-01-21 17:04:57.000000000 -0500
++++ stellarium-0.10.2/src/core/StelTextureMgr.cpp 2010-01-21 17:06:55.000000000 -0500
+@@ -513,7 +513,7 @@
+ fread (magic, 1, sizeof (magic), fp);
+
+ /* check for valid magic number */
+- if (!png_check_sig (magic, sizeof (magic)))
++ if (png_sig_cmp (magic, 0, sizeof (magic)))
+ {
+ qWarning() << "error: \"" << filename << "\" is not a valid PNG image!";
+ fclose (fp);
+@@ -576,7 +576,7 @@
+ /* convert 1-2-4 bits grayscale images to 8 bits
+ grayscale. */
+ if (color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8)
+- png_set_gray_1_2_4_to_8 (png_ptr);
++ png_set_expand_gray_1_2_4_to_8 (png_ptr);
+
+ if (png_get_valid (png_ptr, info_ptr, PNG_INFO_tRNS))
+ png_set_tRNS_to_alpha (png_ptr);
diff --git a/stellarium.desktop b/stellarium.desktop
new file mode 100644
index 000000000000..1b82b18bd75d
--- /dev/null
+++ b/stellarium.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Stellarium nightsky renderer
+GenericName=Nightsky renderer
+Comment=A real-time nightsky renderer
+Categories=Education;Science;Astronomy;
+Icon=stellarium
+Exec=stellarium
+Terminal=false
+Type=Application
diff --git a/stellarium.install b/stellarium.install
new file mode 100644
index 000000000000..46544f062733
--- /dev/null
+++ b/stellarium.install
@@ -0,0 +1,14 @@
+pkgname=stellarium
+
+post_install() {
+ update-desktop-database -q
+ xdg-icon-resource forceupdate
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
diff --git a/stellarium.png b/stellarium.png
new file mode 100644
index 000000000000..08bce127cbfa
--- /dev/null
+++ b/stellarium.png
Binary files differ