summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDevin Christensen2015-06-08 11:15:38 -0600
committerDevin Christensen2015-06-08 11:15:38 -0600
commit1979739a384347c2dd4b3bd8984c86692b61922c (patch)
tree1cae50d303cf941ef07847dfeb88908e831998b3
downloadaur-1979739a384347c2dd4b3bd8984c86692b61922c.tar.gz
Create package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
-rw-r--r--otf-meslo-powerline-git.install15
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab1aaa6da31a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = otf-meslo-powerline-git
+ pkgdesc = Meslo for Powerline
+ pkgver = r71.39c99c0
+ pkgrel = 1
+ url = https://github.com/powerline/fonts
+ install = otf-meslo-powerline-git.install
+ arch = any
+ license = custom:Apache License, Version 2.0
+ makedepends = git
+ depends = fontconfig
+ depends = xorg-font-utils
+ conflicts = powerline-fonts
+ conflicts = powerline-fonts-git
+ source = git://github.com/powerline/fonts.git
+ md5sums = SKIP
+
+pkgname = otf-meslo-powerline-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c1ca6fcbf42a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Devin Christensen <quixoten at gmail dot com>
+pkgname=otf-meslo-powerline-git
+pkgver=r71.39c99c0
+pkgrel=1
+pkgdesc="Meslo for Powerline"
+arch=('any')
+url=('https://github.com/powerline/fonts')
+license=('custom:Apache License, Version 2.0')
+depends=(fontconfig xorg-font-utils )
+makedepends=('git')
+conflicts=(powerline-fonts powerline-fonts-git)
+install=$pkgname.install
+source=('git://github.com/powerline/fonts.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fonts
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd $srcdir/fonts/Meslo
+ find . -iname '*.otf' -execdir install -Dm644 {} $pkgdir/usr/share/fonts/OTF/{} \;
+ install -Dm644 LICENSE.txt $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/otf-meslo-powerline-git.install b/otf-meslo-powerline-git.install
new file mode 100644
index 000000000000..f8ecdd439d8a
--- /dev/null
+++ b/otf-meslo-powerline-git.install
@@ -0,0 +1,15 @@
+post_install() {
+ echo -n "Updating font cache... "
+ mkfontscale /usr/share/fonts/OTF > /dev/null 2>&1
+ mkfontdir /usr/share/fonts/OTF > /dev/null 2>&1
+ fc-cache -s >/dev/null
+ echo "done"
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}