summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtakar Jašek2021-02-11 14:05:31 +0100
committerOtakar Jašek2021-02-11 14:05:31 +0100
commit19a77ec2ecc6bed9f7758a858c0d5ebb01925cd0 (patch)
tree1f9ab88c3d5b86263a1316c893b857e9d47d835c
parent198a8d7cecdf336824a950cc42fa54dd2c1abeab (diff)
downloadaur-19a77ec2ecc6bed9f7758a858c0d5ebb01925cd0.tar.gz
pkgver bump + python tests
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD22
2 files changed, 13 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1dcc71aa9ce4..2c1b7b371723 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = faiss-cuda-git
- pkgver = 1.6.1.r142.gfa85ddf
+ pkgver = v1.7.0.r13.g43ce2c93
pkgrel = 1
url = https://github.com/facebookresearch/faiss
arch = i686
@@ -14,11 +14,10 @@ pkgbase = faiss-cuda-git
depends = lapack
depends = cuda
depends = openmp
- optdepends = intel-mkl
+ optdepends = intel-mkl: To use MKL blas implemenetation
+ optdepends = python-numpy-mkl: To use MKL blas implementation.
source = faiss::git+https://github.com/facebookresearch/faiss.git
- source = compiler.patch
sha256sums = SKIP
- sha256sums = 3739947d39ebffb2775607f135743cd30489aa12f41c14e3aec42fbe79822fd3
pkgname = faiss-cuda-git
pkgdesc = A library for efficient similarity search and clustering of dense vectors, CUDA version.
diff --git a/PKGBUILD b/PKGBUILD
index 5a69b7b307be..01338d1efe43 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,33 +5,30 @@
# If you want the python package to work with MKL, you need to have python-numpy-mkl installed!
# See https://github.com/facebookresearch/faiss/issues/1393
-#_GPU_TARGET="75"
+_GPU_TARGET="75"
_pkgname=faiss
pkgbase=faiss-cuda-git
pkgname=('faiss-cuda-git' 'python-faiss-cuda-git')
arch=('i686' 'x86_64')
url="https://github.com/facebookresearch/faiss"
license=('MIT')
-pkgver=1.6.1.r142.gfa85ddf
+pkgver=v1.7.0.r13.g43ce2c93
pkgrel=1
-source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git
- 'compiler.patch')
-sha256sums=('SKIP'
- '3739947d39ebffb2775607f135743cd30489aa12f41c14e3aec42fbe79822fd3')
+source=(${_pkgname}::git+https://github.com/facebookresearch/faiss.git)
+sha256sums=('SKIP')
depends=('blas' 'lapack' 'cuda' 'openmp')
makedepends=('git' 'python' 'python-numpy' 'swig' 'python-setuptools')
-optdepends=('intel-mkl')
+optdepends=('intel-mkl: To use MKL blas implemenetation' 'python-numpy-mkl: To use MKL blas implementation.')
pkgver() {
cd "${_pkgname}"
- git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
prepare() {
cd "${srcdir}/${_pkgname}"
- patch -p1 < ../compiler.patch # see https://github.com/facebookresearch/faiss/issues/1392
mkdir -p build
cd build
_CMAKE_FLAGS="\
@@ -47,15 +44,16 @@ prepare() {
else
_CMAKE_FLAGS=$_CMAKE_FLAGS"-DCMAKE_CUDA_ARCHITECTURES=\"\"52 60 61 70 75\"\""
fi
- echo $_CMAKE_FLAGS
+# echo $_CMAKE_FLAGS
cmake $_CMAKE_FLAGS ..
}
check() {
cd "${srcdir}/${_pkgname}/build"
make test
- cd "${srcdir}/${_pkgname}"
- PYTHONPATH=build/faiss/python:$PYTHONPATH pytest
+ PYTHONPATH="${srcdir}/${_pkgname}/build/${_pkgname}/python" python -c "import faiss; import faiss.contrib"
+ cd "${srcdir}/${_pkgname}/tests"
+ PYTHONPATH="${srcdir}/${_pkgname}/build/${_pkgname}/python" pytest
}