summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-07-29 17:59:16 -0500
committerLuis Martinez2021-07-29 17:59:41 -0500
commit19e4131f3f0110d1a47cd0c49a7e445e45dd1347 (patch)
tree79334391e24827acb340c2ca2e4a2e6e4f99eda3
parentacd9c586f93ea03405f63630558780e5ef32d7ac (diff)
downloadaur-19e4131f3f0110d1a47cd0c49a7e445e45dd1347.tar.gz
add validpgpkeys and armor file
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD19
2 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f6ad4ceafa83..29cb29637545 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = python-hupper
pkgdesc = Integrated process monitor for developing servers
pkgver = 1.10.3
- pkgrel = 2
- url = https://github.com/Pylons/hupper
+ pkgrel = 3
+ url = https://github.com/pylons/hupper
changelog = CHANGES.rst
arch = any
license = MIT
- checkdepends = python-watchdog
checkdepends = python-pytest-cov
checkdepends = python-pytest-runner
+ checkdepends = python-watchdog
makedepends = python-setuptools
- depends = python
+ depends = python>=3.5
source = python-hupper-1.10.3.tar.gz::https://files.pythonhosted.org/packages/source/h/hupper/hupper-1.10.3.tar.gz
+ source = python-hupper-1.10.3.tar.gz.asc::https://files.pythonhosted.org/packages/source/h/hupper/hupper-1.10.3.tar.gz.asc
+ validpgpkeys = CC1A48C957AC6ABEF05B2C596BC977B056B829E5
sha256sums = cd6f51b72c7587bc9bce8a65ecd025a1e95f1b03284519bfe91284d010316cd9
+ sha256sums = SKIP
pkgname = python-hupper
diff --git a/PKGBUILD b/PKGBUILD
index 76e6d97ef3c2..4ef4eebc2d67 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,26 @@
-# Maintainer: Luis Martinez <luis dot martinez at tuta dot io>
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
# Contributor: Andrew Sun <adsun701 at gmail dot com>
# Contributor: Aleksandar Trifunović <akstrfn at gmail dot com>
# Contributor: Sergey Mastykov <smastykov[at]gmail[dot]com>
pkgname=python-hupper
pkgver=1.10.3
-pkgrel=2
+pkgrel=3
pkgdesc="Integrated process monitor for developing servers"
arch=('any')
-url="https://github.com/Pylons/hupper"
+url="https://github.com/pylons/hupper"
license=('MIT')
-depends=('python')
+depends=('python>=3.5')
makedepends=('python-setuptools')
-checkdepends=('python-watchdog' 'python-pytest-cov' 'python-pytest-runner')
+checkdepends=('python-pytest-cov'
+ 'python-pytest-runner'
+ 'python-watchdog')
changelog=CHANGES.rst
-source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/h/hupper/hupper-$pkgver.tar.gz")
-sha256sums=('cd6f51b72c7587bc9bce8a65ecd025a1e95f1b03284519bfe91284d010316cd9')
+source=("$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/h/hupper/hupper-$pkgver.tar.gz"
+ "$pkgname-$pkgver.tar.gz.asc::https://files.pythonhosted.org/packages/source/h/hupper/hupper-$pkgver.tar.gz.asc")
+sha256sums=('cd6f51b72c7587bc9bce8a65ecd025a1e95f1b03284519bfe91284d010316cd9'
+ 'SKIP')
+validpgpkeys=('CC1A48C957AC6ABEF05B2C596BC977B056B829E5')
build() {
cd "hupper-$pkgver"