summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbanana-bred2023-12-30 18:23:31 -0500
committerbanana-bred2023-12-30 18:23:31 -0500
commit19f3ff307f0ef7aab9801bc780e6f8867cf7518a (patch)
tree5ce311eda6f2934e85417ce3ffc08f92d56d47ea
parent8c4ff766647ad7cf04362d8db446b6f40244bcf6 (diff)
downloadaur-19f3ff307f0ef7aab9801bc780e6f8867cf7518a.tar.gz
update to 7.3, remove redundant makedepends
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e1bda0d781e6..c73b302d08d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = molden
pkgdesc = A program for molecular and electronic structure visualization
- pkgver = 6.9
+ pkgver = 7.3
pkgrel = 1
url = http://www.cmbi.ru.nl/molden/
arch = i686
@@ -10,14 +10,13 @@ pkgbase = molden
makedepends = gcc-fortran
makedepends = xorgproto
makedepends = libx11
- makedepends = mesa
- makedepends = glu
+ makedepends = makedepend
depends = mesa
depends = glu
optdepends = openbabel: to create 2D images of the molecules in a .sdf file
optdepends = wget: to fetch PDB from rcsb.org
provides = molden
- source = https://ftp.science.ru.nl/Molden/molden6.9.tar.gz
- md5sums = 3551167d2853e5a6b3379edf74e81f1f
+ source = https://ftp.science.ru.nl/Molden/molden7.3.tar.gz
+ sha256sums = 870f4fa6635229791bb09bbbd07f51456b2c90101d73564dc47ed7769b8c07a1
pkgname = molden
diff --git a/PKGBUILD b/PKGBUILD
index a340e3d43415..bcac9687d4bf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Dan Maftei <dan.maftei@gmail.com>
pkgname="molden"
-pkgver=6.9
+pkgver=7.3
pkgrel=1
pkgdesc="A program for molecular and electronic structure visualization"
arch=('i686' 'x86_64')
@@ -13,8 +13,7 @@ makedepends=(
'gcc-fortran'
'xorgproto'
'libx11'
- 'mesa'
- 'glu'
+ 'makedepend'
)
optdepends=(
'openbabel: to create 2D images of the molecules in a .sdf file'
@@ -31,19 +30,16 @@ source=(
"https://ftp.science.ru.nl/Molden/${pkgname}${pkgver}.tar.gz"
)
noextract=()
-md5sums=('3551167d2853e5a6b3379edf74e81f1f')
+sha256sums=('870f4fa6635229791bb09bbbd07f51456b2c90101d73564dc47ed7769b8c07a1')
build() {
cd "molden${pkgver}"
- # Patch Makefile for surf utility to reflect
- # the replacement of missing makedepend
- sed -i 's/@.*makedepend.*$/@ \$(CC) \$(INCLUDE) -M \$(SRCS) \> makedep/' src/surf/Makefile
- # Patch to compile with gfortran 10
- # Contributed by Panadestein on 5/31/2020
- sed -i 's/FFLAGS = -g ${AFLAG}/& -fallow-argument-mismatch/g' makefile
- sed -i 's/FFLAGS = -c -g -ffast-math -funroll-loops -O3/& -fallow-argument-mismatch/g' src/ambfor/makefile
- make
+ # Patch to compile with gfortran 10+
+ # Original contribution by Panadestein on 5/31/2020
+ sed -i 's/FFLAGS += -g ${AFLAG}/& -fallow-argument-mismatch/g' makefile
+ sed -i 's/FFLAGS = -g ${AFLAG}/& -fallow-argument-mismatch/g' docker/makefile
+ make -k
}
package() {