summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoranthraxx2015-07-09 21:51:53 +0200
committeranthraxx2015-07-09 21:51:53 +0200
commit1a0503380c5a232a86caed090b0296463b4ce324 (patch)
tree083fae194f0d461a1b072d6244b670bd42cf52aa
downloadaur-1a0503380c5a232a86caed090b0296463b4ce324.tar.gz
addpkg: xprobe2 0.3-2
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD27
-rwxr-xr-xip.patch10
-rwxr-xr-xmisc.patch9
-rwxr-xr-xtcp.patch10
5 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc8420f76d8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xprobe2
+ pkgdesc = xprobe2 is an active OS fingerprinting tool
+ pkgver = 0.3
+ pkgrel = 2
+ url = http://sourceforge.net/apps/mediawiki/xprobe/index.php?title=Main_Page
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ depends = gcc
+ depends = libpcap
+ source = http://downloads.sourceforge.net/project/xprobe/xprobe2/Xprobe2%200.3/xprobe2-0.3.tar.gz
+ md5sums = 3ebb89ed9380038d368327816e34ec54
+
+pkgname = xprobe2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..2b47b82a7858
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: sandman <r.coded@gmail.com>
+# Contributor: Christoph Siegenthaler <csi@gmx.ch>
+
+pkgname=xprobe2
+pkgver=0.3
+pkgrel=2
+pkgdesc="xprobe2 is an active OS fingerprinting tool"
+url="http://sourceforge.net/apps/mediawiki/xprobe/index.php?title=Main_Page"
+depends=('gcc' 'libpcap')
+source=('http://downloads.sourceforge.net/project/xprobe/xprobe2/Xprobe2%200.3/'$pkgname'-'$pkgver'.tar.gz')
+md5sums=('3ebb89ed9380038d368327816e34ec54')
+arch=('i686' 'x86_64')
+license=('GPL2')
+build(){
+ cd $startdir
+ patch -p1 < ip.patch
+ patch -p1 < misc.patch
+ patch -p1 < tcp.patch
+ cd $startdir/src/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc
+ make || return 1
+}
+
+package(){
+ cd $startdir/src/$pkgname-$pkgver
+ make DESTDIR=$startdir/pkg install
+} \ No newline at end of file
diff --git a/ip.patch b/ip.patch
new file mode 100755
index 000000000000..faa37b04e831
--- /dev/null
+++ b/ip.patch
@@ -0,0 +1,10 @@
+--- old/src/xprobe2-0.3/libs-external/USI++/src/ip.cc 2005-07-27 14:08:15.000000000 +0530
++++ new/src/xprobe2-0.3/libs-external/USI++/src/ip.cc 2011-02-13 09:44:58.997511172 +0530
+@@ -13,6 +13,7 @@
+ #include "usi++/ip.h"
+
+ #include "config.h"
++#include <cstdlib>
+ #include <iostream>
+ #include <string.h>
+ #include <errno.h>
diff --git a/misc.patch b/misc.patch
new file mode 100755
index 000000000000..e89fc4378608
--- /dev/null
+++ b/misc.patch
@@ -0,0 +1,9 @@
+--- old/src/xprobe2-0.3/libs-external/USI++/src/misc.cc 2005-07-27 14:08:15.000000000 +0530
++++ new/src/xprobe2-0.3/libs-external/USI++/src/misc.cc 2011-02-13 09:50:31.033661585 +0530
+@@ -1,5 +1,6 @@
+ #include "usi++/usi++"
+ #include "usi++/usi-structs.h"
++#include <cstdlib>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/ioctl.h>
diff --git a/tcp.patch b/tcp.patch
new file mode 100755
index 000000000000..268c25baf042
--- /dev/null
+++ b/tcp.patch
@@ -0,0 +1,10 @@
+--- old/src/xprobe2-0.3/libs-external/USI++/usi++/tcp.h 2005-07-27 14:08:14.000000000 +0530
++++ new/src/xprobe2-0.3/libs-external/USI++/usi++/tcp.h 2011-02-13 09:51:12.697355342 +0530
+@@ -15,6 +15,7 @@
+ #include "usi-structs.h"
+ #include "datalink.h"
+ #include "ip.h"
++#include <cstring>
+
+ namespace usipp {
+