summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-06-15 14:40:02 +1200
committercaltlgin2020-06-15 14:40:02 +1200
commit1a0af02e38eea3970025066b52002f4a9fade6fe (patch)
tree71ad59a405b78b29efd391cd6aba4dd403d027e9
parent7a91a783fac2c98c39f4ccfb9f5296a66b02acd0 (diff)
downloadaur-1a0af02e38eea3970025066b52002f4a9fade6fe.tar.gz
Clean PKGBUILD in lines with packaging guidelines
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7ba08659721a..480afd291809 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = xubuntu-community-artwork
pkgdesc = Xubuntu community wallpapers
pkgver = 20.04.0
- pkgrel = 1
+ pkgrel = 2
url = https://launchpad.net/xubuntu-community-artwork
arch = any
license = custom
- provides = xubuntu-community-artwork
- conflicts = xubuntu-community-artwork
- conflicts = xubuntu-community-artwork-git
+ optdepends = xfce4: xfce desktop
source = http://archive.ubuntu.com/ubuntu/pool/universe/x/xubuntu-community-artwork/xubuntu-community-artwork_20.04.0.tar.xz
sha256sums = 2a40074fae8754babc4e7c7e141ad2163f1f40cdf0e5ac6b267f432658d09dd1
diff --git a/PKGBUILD b/PKGBUILD
index cf1cdc66d85e..03b49fa8aa8a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,22 +3,20 @@
pkgname=xubuntu-community-artwork
pkgver=20.04.0
-pkgrel=1
-pkgdesc="Xubuntu community wallpapers"
+pkgrel=2
+pkgdesc='Xubuntu community wallpapers'
arch=(any)
-url="https://launchpad.net/${pkgname}"
+url='https://launchpad.net/xubuntu-community-artwork'
license=('custom')
+optdepends=('xfce4: xfce desktop')
source=("http://archive.ubuntu.com/ubuntu/pool/universe/x/${pkgname}/${pkgname}_${pkgver}.tar.xz")
-provides=("${pkgname}")
-conflicts=("${pkgname}" "${pkgname}-git")
sha256sums=('2a40074fae8754babc4e7c7e141ad2163f1f40cdf0e5ac6b267f432658d09dd1')
package() {
- cd "${pkgname}"
- install -d "$pkgdir/usr/share/backgrounds/${pkgname}"
- install -m644 'usr/share/xfce4/backdrops/'*.jpg "$pkgdir/usr/share/backgrounds/${pkgname}/"
- install -m644 'usr/share/xfce4/backdrops/'*.png "$pkgdir/usr/share/backgrounds/${pkgname}/"
- install -Dm644 'README' "${pkgdir}/usr/share/doc/${pkgname}/README"
- install -Dm644 'debian/changelog' "${pkgdir}/usr/share/doc/${pkgname}/CHANGELOG"
- install -Dm644 'debian/copyright' "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-} \ No newline at end of file
+ install -d "${pkgdir}/usr/share/backgrounds/xfce"
+ install -m644 "${pkgname}/usr/share/xfce4/backdrops/"*.{jpg,png} "${pkgdir}/usr/share/backgrounds/xfce/"
+ install -Dm644 "${pkgname}/README" "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -Dm644 "${pkgname}/debian/copyright" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim: ts=2 sw=2 et: \ No newline at end of file