summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2017-05-19 18:11:15 -0400
committergraysky2017-05-19 18:11:15 -0400
commit1a12347e607a7842f468fe5a04634f8875341d74 (patch)
tree951301932a6f7f2ae2ef38dad73b30f8c88de328
parente7af74c74bb53843bd540e084ac8711cecd57e7c (diff)
downloadaur-1a12347e607a7842f468fe5a04634f8875341d74.tar.gz
Update to 6.30.223.271-42
-rw-r--r--.SRCINFO32
-rw-r--r--001-null-pointer-fix.patch27
-rw-r--r--002-rdtscl.patch22
-rw-r--r--003-linux47.patch (renamed from linux47.patch)0
-rw-r--r--004-linux48.patch64
-rw-r--r--005-debian-fix-kernel-warnings.patch161
-rw-r--r--006-linux411.patch27
-rw-r--r--PKGBUILD45
-rw-r--r--license.patch10
-rw-r--r--linux48.patch52
-rw-r--r--readme.install2
-rw-r--r--wl_linux.c.patch14
12 files changed, 347 insertions, 109 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 552b1af683ac..4bc4697d2dbb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,32 @@
# Generated by mksrcinfo v8
-# Fri Apr 21 22:15:51 UTC 2017
+# Fri May 19 22:11:15 UTC 2017
pkgbase = broadcom-wl-ck
pkgdesc = Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.
pkgver = 6.30.223.271
- pkgrel = 41
+ pkgrel = 42
url = https://www.broadcom.com/support/802.11
install = readme.install
arch = i686
arch = x86_64
license = custom
- makedepends = linux-ck-headers>=4.10
- makedepends = linux-ck-headers<4.11
- depends = linux-ck>=4.10
- depends = linux-ck<4.11
+ makedepends = linux-ck-headers>=4.11
+ makedepends = linux-ck-headers<4.12
+ depends = linux-ck>=4.11
+ depends = linux-ck<4.12
+ source = 001-null-pointer-fix.patch
+ source = 002-rdtscl.patch
+ source = 003-linux47.patch
+ source = 004-linux48.patch
+ source = 005-debian-fix-kernel-warnings.patch
+ source = 006-linux411.patch
source = modprobe.d
- source = license.patch
- source = wl_linux.c.patch
- source = linux47.patch
- source = linux48.patch
- sha256sums = b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32
- sha256sums = 2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac
- sha256sums = 583335a6edb2ed1094977c401643d3e60471c6bc5c3ea81f45910a9cccb06032
+ sha256sums = 32e505a651fdb9fd5e4870a9d6de21dd703dead768c2b3340a2ca46671a5852f
+ sha256sums = 4ea03f102248beb8963ad00bd3e36e67519a90fa39244db065e74038c98360dd
sha256sums = 30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e
- sha256sums = 833af3b209d6a101d9094db16480bda2ad9a85797059b0ae0b13235ad3818e9c
+ sha256sums = 09d709df0c764118ca43117f5c096163d9669a28170da8476d4b8211bd225d2e
+ sha256sums = 2306a59f9e7413f35a0669346dcd05ef86fa37c23b566dceb0c6dbee67e4d299
+ sha256sums = 5bc12cb57712e6a944dff1c90de50135c2508085d8497ab99284ccccdb35c32b
+ sha256sums = b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32
source_i686 = https://docs.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35-nodebug-pcoem-6_30_223_271.tar.gz
sha256sums_i686 = 4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd
source_x86_64 = http://www.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-6_30_223_271.tar.gz
diff --git a/001-null-pointer-fix.patch b/001-null-pointer-fix.patch
new file mode 100644
index 000000000000..adef19f30af1
--- /dev/null
+++ b/001-null-pointer-fix.patch
@@ -0,0 +1,27 @@
+Description: Fixing null pointer crash
+
+Origin: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=773713
+Bug-Ubuntu: https://launchpad.net/bugs/1415880
+Last-Update: 2015-08-18
+
+---
+ src/wl/sys/wl_linux.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/wl/sys/wl_linux.c b/src/wl/sys/wl_linux.c
+index 860b935..295156f 100644
+--- a/src/wl/sys/wl_linux.c
++++ b/src/wl/sys/wl_linux.c
+@@ -2157,8 +2157,8 @@ wl_start(struct sk_buff *skb, struct net_device *dev)
+ wlif = WL_DEV_IF(dev);
+ wl = WL_INFO(dev);
+
++ skb->prev = NULL;
+ if (WL_ALL_PASSIVE_ENAB(wl) || (WL_RTR() && WL_CONFIG_SMP())) {
+- skb->prev = NULL;
+
+ TXQ_LOCK(wl);
+
+--
+1.9.1
+
diff --git a/002-rdtscl.patch b/002-rdtscl.patch
new file mode 100644
index 000000000000..1b9862cc3d8d
--- /dev/null
+++ b/002-rdtscl.patch
@@ -0,0 +1,22 @@
+Since Linux 4.3, rdtscl() is no longer available and native_read_tsc()
+is renamed to rdtsc(). Move the macro contents in-line and call the
+new function. References:
+
+https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit?id=fe47ae6e1a5005b2e82f7eab57b5c3820453293a
+https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit?id=4ea1636b04dbd66536fa387bae2eea463efc705b
+
+diff -ru a/src/shared/linux_osl.c b/src/shared/linux_osl.c
+--- a/src/shared/linux_osl.c 2015-09-19 01:47:15.000000000 +0300
++++ b/src/shared/linux_osl.c 2015-11-21 15:20:30.585902518 +0200
+@@ -932,7 +932,11 @@
+ uint cycles;
+
+ #if defined(__i386__)
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 3, 0)
++ cycles = (u32)rdtsc();
++#else
+ rdtscl(cycles);
++#endif
+ #else
+ cycles = 0;
+ #endif
diff --git a/linux47.patch b/003-linux47.patch
index 566680a09140..566680a09140 100644
--- a/linux47.patch
+++ b/003-linux47.patch
diff --git a/004-linux48.patch b/004-linux48.patch
new file mode 100644
index 000000000000..20e8a9ae49d2
--- /dev/null
+++ b/004-linux48.patch
@@ -0,0 +1,64 @@
+From d3f93542326a06d920c6eb89b703384290d37b8b Mon Sep 17 00:00:00 2001
+From: Alberto Milone <alberto.milone@canonical.com>
+Date: Fri, 2 Sep 2016 17:35:34 +0200
+Subject: [PATCH 1/1] Add support for Linux 4.8
+
+Orginal author: Krzysztof Kolasa
+---
+ src/wl/sys/wl_cfg80211_hybrid.c | 22 ++++++++++++++++++++++
+ 1 file changed, 22 insertions(+)
+
+diff --git a/src/wl/sys/wl_cfg80211_hybrid.c b/src/wl/sys/wl_cfg80211_hybrid.c
+index 2fc71fe..ec5e472 100644
+--- a/src/wl/sys/wl_cfg80211_hybrid.c
++++ b/src/wl/sys/wl_cfg80211_hybrid.c
+@@ -2388,8 +2388,16 @@ wl_bss_connect_done(struct wl_cfg80211_priv *wl, struct net_device *ndev,
+ s32 err = 0;
+
+ if (wl->scan_request) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = true,
++ };
++ WL_DBG(("%s: Aborting scan\n", __FUNCTION__));
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
+ WL_DBG(("%s: Aborting scan\n", __FUNCTION__));
+ cfg80211_scan_done(wl->scan_request, true);
++#endif
+ wl->scan_request = NULL;
+ }
+
+@@ -2490,7 +2498,14 @@ wl_notify_scan_status(struct wl_cfg80211_priv *wl, struct net_device *ndev,
+
+ scan_done_out:
+ if (wl->scan_request) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = false,
++ };
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
+ cfg80211_scan_done(wl->scan_request, false);
++#endif
+ wl->scan_request = NULL;
+ }
+ rtnl_unlock();
+@@ -2909,7 +2924,14 @@ s32 wl_cfg80211_down(struct net_device *ndev)
+ s32 err = 0;
+
+ if (wl->scan_request) {
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
++ struct cfg80211_scan_info info = {
++ .aborted = true,
++ };
++ cfg80211_scan_done(wl->scan_request, &info);
++#else
+ cfg80211_scan_done(wl->scan_request, true);
++#endif
+ wl->scan_request = NULL;
+ }
+
+--
+2.7.4
+
diff --git a/005-debian-fix-kernel-warnings.patch b/005-debian-fix-kernel-warnings.patch
new file mode 100644
index 000000000000..e9bf66a959b8
--- /dev/null
+++ b/005-debian-fix-kernel-warnings.patch
@@ -0,0 +1,161 @@
+--- a/src/wl/sys/wl_cfg80211_hybrid.c
++++ b/src/wl/sys/wl_cfg80211_hybrid.c
+@@ -1968,7 +1968,7 @@
+
+ if (dtoh32(bi->length) > WL_BSS_INFO_MAX) {
+ WL_DBG(("Beacon is larger than buffer. Discarding\n"));
+- return err;
++ return -E2BIG;
+ }
+ notif_bss_info = kzalloc(sizeof(*notif_bss_info) + sizeof(*mgmt) - sizeof(u8) +
+ WL_BSS_INFO_MAX, GFP_KERNEL);
+@@ -1992,9 +1992,15 @@
+ beacon_proberesp->capab_info = cpu_to_le16(bi->capability);
+ wl_rst_ie(wl);
+
+- wl_mrg_ie(wl, ((u8 *) bi) + bi->ie_offset, bi->ie_length);
+- wl_cp_ie(wl, beacon_proberesp->variable, WL_BSS_INFO_MAX -
++ err = wl_mrg_ie(wl, ((u8 *) bi) + bi->ie_offset, bi->ie_length);
++ if (err)
++ goto inform_single_bss_out;
++
++ err = wl_cp_ie(wl, beacon_proberesp->variable, WL_BSS_INFO_MAX -
+ offsetof(struct wl_cfg80211_bss_info, frame_buf));
++ if (err)
++ goto inform_single_bss_out;
++
+ notif_bss_info->frame_len = offsetof(struct ieee80211_mgmt, u.beacon.variable) +
+ wl_get_ielen(wl);
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 39)
+@@ -2006,14 +2012,14 @@
+ #endif
+ if (freq == 0) {
+ WL_ERR(("Invalid channel, fail to chcnage channel to freq\n"));
+- kfree(notif_bss_info);
+- return -EINVAL;
++ err = -EINVAL;
++ goto inform_single_bss_out;
+ }
+ channel = ieee80211_get_channel(wiphy, freq);
+ if (unlikely(!channel)) {
+ WL_ERR(("ieee80211_get_channel error\n"));
+- kfree(notif_bss_info);
+- return -EINVAL;
++ err = -EINVAL;
++ goto inform_single_bss_out;
+ }
+
+ WL_DBG(("SSID : \"%s\", rssi %d, channel %d, capability : 0x04%x, bssid %pM\n",
+@@ -2021,28 +2027,37 @@
+ mgmt->u.beacon.capab_info, &bi->BSSID));
+
+ signal = notif_bss_info->rssi * 100;
+- cbss = cfg80211_inform_bss_frame(wiphy, channel, mgmt,
+- le16_to_cpu(notif_bss_info->frame_len), signal, GFP_KERNEL);
+- if (unlikely(!cbss)) {
+- WL_ERR(("cfg80211_inform_bss_frame error\n"));
+- kfree(notif_bss_info);
+- return -EINVAL;
+- }
+
+- notify_ie = (u8 *)bi + le16_to_cpu(bi->ie_offset);
+- notify_ielen = le32_to_cpu(bi->ie_length);
++ if (!wl->scan_request) {
++ cbss = cfg80211_inform_bss_frame(wiphy, channel, mgmt,
++ le16_to_cpu(notif_bss_info->frame_len), signal, GFP_KERNEL);
++ if (unlikely(!cbss)) {
++ WL_ERR(("cfg80211_inform_bss_frame error\n"));
++ err = -ENOMEM;
++ goto inform_single_bss_out;
++ }
++ } else {
++ notify_ie = (u8 *)bi + le16_to_cpu(bi->ie_offset);
++ notify_ielen = le32_to_cpu(bi->ie_length);
+ #if LINUX_VERSION_CODE < KERNEL_VERSION(3, 18, 0)
+- cbss = cfg80211_inform_bss(wiphy, channel, (const u8 *)(bi->BSSID.octet),
+- 0, beacon_proberesp->capab_info, beacon_proberesp->beacon_int,
+- (const u8 *)notify_ie, notify_ielen, signal, GFP_KERNEL);
++ cbss = cfg80211_inform_bss(wiphy, channel, (const u8 *)(bi->BSSID.octet),
++ 0, beacon_proberesp->capab_info, beacon_proberesp->beacon_int,
++ (const u8 *)notify_ie, notify_ielen, signal, GFP_KERNEL);
+ #else
+- cbss = cfg80211_inform_bss(wiphy, channel, CFG80211_BSS_FTYPE_UNKNOWN, (const u8 *)(bi->BSSID.octet),
+- 0, beacon_proberesp->capab_info, beacon_proberesp->beacon_int,
+- (const u8 *)notify_ie, notify_ielen, signal, GFP_KERNEL);
++ cbss = cfg80211_inform_bss(wiphy, channel,
++ wl->active_scan ?
++ CFG80211_BSS_FTYPE_PRESP : CFG80211_BSS_FTYPE_BEACON,
++ (const u8 *)(bi->BSSID.octet), 0,
++ beacon_proberesp->capab_info,
++ beacon_proberesp->beacon_int,
++ (const u8 *)notify_ie, notify_ielen, signal, GFP_KERNEL);
+ #endif
+-
+- if (unlikely(!cbss))
+- return -ENOMEM;
++ if (unlikely(!cbss)) {
++ WL_ERR(("cfg80211_inform_bss error\n"));
++ err = -ENOMEM;
++ goto inform_single_bss_out;
++ }
++ }
+
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 9, 0)
+ cfg80211_put_bss(wiphy, cbss);
+@@ -2050,6 +2065,7 @@
+ cfg80211_put_bss(cbss);
+ #endif
+
++inform_single_bss_out:
+ kfree(notif_bss_info);
+
+ return err;
+@@ -2316,6 +2332,9 @@
+ if (err)
+ goto update_bss_info_out;
+
++ bss = cfg80211_get_bss(wl_to_wiphy(wl), NULL, (s8 *)&wl->bssid,
++ ssid->SSID, ssid->SSID_len, WLAN_CAPABILITY_ESS, WLAN_CAPABILITY_ESS);
++
+ ie = ((u8 *)bi) + bi->ie_offset;
+ ie_len = bi->ie_length;
+ } else {
+@@ -2328,11 +2347,18 @@
+ ie_len = bss->len_information_elements;
+ #endif
+ wl->conf->channel = *bss->channel;
++ }
++
++ if (bss) {
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3, 9, 0)
+ cfg80211_put_bss(wiphy, bss);
+ #else
+ cfg80211_put_bss(bss);
+ #endif
++ } else {
++ WL_DBG(("Could not update BSS\n"));
++ err = -EINVAL;
++ goto update_bss_info_out;
+ }
+
+ tim = bcm_parse_tlvs(ie, ie_len, WLAN_EID_TIM);
+@@ -2360,10 +2386,17 @@
+ struct wl_cfg80211_connect_info *conn_info = wl_to_conn(wl);
+ s32 err = 0;
+
+- wl_get_assoc_ies(wl);
++ err = wl_get_assoc_ies(wl);
++ if (err)
++ return err;
++
+ memcpy(wl->profile->bssid, &e->addr, ETHER_ADDR_LEN);
+ memcpy(&wl->bssid, &e->addr, ETHER_ADDR_LEN);
+- wl_update_bss_info(wl);
++
++ err = wl_update_bss_info(wl);
++ if (err)
++ return err;
++
+ cfg80211_roamed(ndev,
+ #if LINUX_VERSION_CODE > KERNEL_VERSION(2, 6, 39)
+ &wl->conf->channel,
diff --git a/006-linux411.patch b/006-linux411.patch
new file mode 100644
index 000000000000..7a2e8c0c6cb0
--- /dev/null
+++ b/006-linux411.patch
@@ -0,0 +1,27 @@
+diff -u sys0/wl_cfg80211_hybrid.c sys/wl_cfg80211_hybrid.c
+--- a/src/wl/sys/wl_cfg80211_hybrid.c
++++ b/src/wl/sys/wl_cfg80211_hybrid.c
+@@ -39,6 +39,10 @@
+ #include <proto/802.11.h>
+ #include <wl_cfg80211_hybrid.h>
+
++#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 11, 0)
++#include <linux/sched/signal.h>
++#endif
++
+ #define EVENT_TYPE(e) dtoh32((e)->event_type)
+ #define EVENT_FLAGS(e) dtoh16((e)->flags)
+ #define EVENT_STATUS(e) dtoh32((e)->status)
+diff -u sys0/wl_linux.c sys/wl_linux.c
+--- a/src/wl/sys/wl_linux.c
++++ b/src/wl/sys/wl_linux.c
+@@ -2915,7 +2915,9 @@
+ if (skb == NULL) return;
+
+ skb->dev = wl->monitor_dev;
++#if LINUX_VERSION_CODE < KERNEL_VERSION(4, 11, 0)
+ skb->dev->last_rx = jiffies;
++#endif
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(2, 6, 22)
+ skb_reset_mac_header(skb);
+ #else
diff --git a/PKGBUILD b/PKGBUILD
index b07416cbbf19..a85c86fbe8dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,45 +6,54 @@
pkgname=broadcom-wl-ck
pkgver=6.30.223.271
-pkgrel=41
+pkgrel=42
_pkgdesc='Broadcom 802.11abgn hybrid Linux networking device driver for linux-ck.'
-_extramodules="extramodules-4.10-ck"
+_extramodules="extramodules-4.11-ck"
_kernver="$(cat /usr/lib/modules/${_extramodules}/version)"
pkgdesc="${_pkgdesc}"
arch=('i686' 'x86_64')
url='https://www.broadcom.com/support/802.11'
license=('custom')
-depends=('linux-ck>=4.10' 'linux-ck<4.11')
-makedepends=('linux-ck-headers>=4.10' 'linux-ck-headers<4.11')
+depends=('linux-ck>=4.11' 'linux-ck<4.12')
+makedepends=('linux-ck-headers>=4.11' 'linux-ck-headers<4.12')
#replaces=()
#groups=('ck-generic')
-source=('modprobe.d'
-'license.patch'
-'wl_linux.c.patch'
-'linux47.patch'
-'linux48.patch')
+source=(
+ '001-null-pointer-fix.patch'
+ '002-rdtscl.patch'
+ '003-linux47.patch'
+ '004-linux48.patch'
+ '005-debian-fix-kernel-warnings.patch'
+ '006-linux411.patch'
+ 'modprobe.d'
+ )
source_i686=("https://docs.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35-nodebug-pcoem-${pkgver//./_}.tar.gz")
source_x86_64=("http://www.broadcom.com/docs-and-downloads/docs/linux_sta/hybrid-v35_64-nodebug-pcoem-${pkgver//./_}.tar.gz")
-sha256sums=('b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32'
- '2f70be509aac743bec2cc3a19377be311a60a1c0e4a70ddd63ea89fae5df08ac'
- '583335a6edb2ed1094977c401643d3e60471c6bc5c3ea81f45910a9cccb06032'
+sha256sums=('32e505a651fdb9fd5e4870a9d6de21dd703dead768c2b3340a2ca46671a5852f'
+ '4ea03f102248beb8963ad00bd3e36e67519a90fa39244db065e74038c98360dd'
'30ce1d5e8bf78aee487d0f3ac76756e1060777f70ed1a9cf95215c3a52cfbe2e'
- '833af3b209d6a101d9094db16480bda2ad9a85797059b0ae0b13235ad3818e9c')
+ '09d709df0c764118ca43117f5c096163d9669a28170da8476d4b8211bd225d2e'
+ '2306a59f9e7413f35a0669346dcd05ef86fa37c23b566dceb0c6dbee67e4d299'
+ '5bc12cb57712e6a944dff1c90de50135c2508085d8497ab99284ccccdb35c32b'
+ 'b4aca51ac5ed20cb79057437be7baf3650563b7a9d5efc515f0b9b34fbb9dc32')
sha256sums_i686=('4f8b70b293ac8cc5c70e571ad5d1878d0f29d133a46fe7869868d9c19b5058cd')
sha256sums_x86_64=('5f79774d5beec8f7636b59c0fb07a03108eef1e3fd3245638b20858c714144be')
install=readme.install
prepare() {
- patch -p1 -i license.patch
- patch -p1 -i wl_linux.c.patch
- patch -p1 -i linux47.patch
- patch -p1 -i linux48.patch
- sed -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" -i src/wl/sys/wl_linux.c
+ patch -Np1 -i $srcdir/001-null-pointer-fix.patch
+ patch -Np1 -i $srcdir/002-rdtscl.patch
+ patch -Np1 -i $srcdir/003-linux47.patch
+ patch -Np1 -i $srcdir/004-linux48.patch
+ patch -Np1 -i $srcdir/005-debian-fix-kernel-warnings.patch
+ patch -Np1 -i $srcdir/006-linux411.patch
}
build() {
+ sed -i -e "/BRCM_WLAN_IFNAME/s:eth:wlan:" -i src/wl/sys/wl_linux.c
+ #sed -i -e "/EXTRA_LDFLAGS/s|\$(src)/lib|/usr/lib/${pkgname}|" Makefile
make -C /usr/lib/modules/"${_kernver}"/build M=`pwd`
}
diff --git a/license.patch b/license.patch
deleted file mode 100644
index 1719a99cab6c..000000000000
--- a/license.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/src/wl/sys/wl_linux.c 2014-06-26 10:42:08.000000000 +0000
-+++ b/src/wl/sys/wl_linux.c 2014-07-17 22:44:26.254759666 +0000
-@@ -205,6 +205,7 @@
-
- static int nompc = 0;
- module_param(nompc, int, 0);
-+MODULE_LICENSE("Mixed/Proprietary");
-
- #ifdef quote_str
- #undef quote_str
diff --git a/linux48.patch b/linux48.patch
deleted file mode 100644
index 0f3e81906226..000000000000
--- a/linux48.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-Reference: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=839629
-
---- a/src/wl/sys/wl_cfg80211_hybrid.c 2016-10-03 10:53:55.588036464 +0200
-+++ b/src/wl/sys/wl_cfg80211_hybrid.c 2016-10-03 10:54:11.911695944 +0200
-@@ -2386,8 +2386,15 @@
- s32 err = 0;
-
- if (wl->scan_request) {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
-+ struct cfg80211_scan_info info = {
-+ .aborted = true
-+ };
- WL_DBG(("%s: Aborting scan\n", __FUNCTION__));
-- cfg80211_scan_done(wl->scan_request, true);
-+ cfg80211_scan_done(wl->scan_request, &info);
-+#else
-+ cfg80211_scan_done(wl->scan_request, true);
-+#endif
- wl->scan_request = NULL;
- }
-
-@@ -2488,7 +2495,14 @@
-
- scan_done_out:
- if (wl->scan_request) {
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
-+ struct cfg80211_scan_info info = {
-+ .aborted = false
-+ };
-+ cfg80211_scan_done(wl->scan_request, &info);
-+#else
- cfg80211_scan_done(wl->scan_request, false);
-+#endif
- wl->scan_request = NULL;
- }
- rtnl_unlock();
-@@ -2913,7 +2927,14 @@
- s32 err = 0;
-
- if (wl->scan_request) {
-- cfg80211_scan_done(wl->scan_request, true);
-+#if LINUX_VERSION_CODE >= KERNEL_VERSION(4, 8, 0)
-+ struct cfg80211_scan_info info = {
-+ .aborted = true
-+ };
-+ cfg80211_scan_done(wl->scan_request, &info);
-+#else
-+ cfg80211_scan_done(wl->scan_request, true);
-+#endif
- wl->scan_request = NULL;
- }
-
diff --git a/readme.install b/readme.install
index 9ce7bf2307b5..25736d880f33 100644
--- a/readme.install
+++ b/readme.install
@@ -1,5 +1,5 @@
post_upgrade() {
- EXTRAMODULES='extramodules-4.10-ck'
+ EXTRAMODULES='extramodules-4.11-ck'
depmod $(cat /usr/lib/modules/$EXTRAMODULES/version)
}
diff --git a/wl_linux.c.patch b/wl_linux.c.patch
deleted file mode 100644
index cf7d4b44ead3..000000000000
--- a/wl_linux.c.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-diff --git a/src/wl/sys/wl_linux.c.orig b/src/wl/sys/wl_linux.c
-index eb00717..489c9f5 100644
---- a/src/wl/sys/wl_linux.c.orig
-+++ b/src/wl/sys/wl_linux.c
-@@ -2166,8 +2166,8 @@ wl_start(struct sk_buff *skb, struct net_device *dev)
- wlif = WL_DEV_IF(dev);
- wl = WL_INFO(dev);
-
-+ skb->prev = NULL;
- if (WL_ALL_PASSIVE_ENAB(wl) || (WL_RTR() && WL_CONFIG_SMP())) {
-- skb->prev = NULL;
-
- TXQ_LOCK(wl);
-