summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcbpark2021-10-07 14:10:17 +0900
committercbpark2021-10-07 14:10:17 +0900
commit1a1504fb27d09dbbd4876ad8ad34f5f24b88d0e4 (patch)
tree103bf2d1fdba8fa27fca6ac340a2ab62fb1d420a
parentcd0745be33c0f0e3871fc70806b3201dd0a74953 (diff)
downloadaur-1a1504fb27d09dbbd4876ad8ad34f5f24b88d0e4.tar.gz
upgpkg: softsusy 4.1.12-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD13
-rw-r--r--remove_duplicate_header.patch4
-rw-r--r--remove_install_data_local.patch23
4 files changed, 36 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e380a897f73e..0b257bb7486f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,13 @@
pkgbase = softsusy
pkgdesc = This program provides a SUSY spectrum in the NMSSM, or the MSSM including flavour violation and with or without R-parity consistent with input Standard Model fermion mass/mixings and electroweak/strong coupling data.
- pkgver = 4.1.7
+ pkgver = 4.1.12
pkgrel = 1
url = http://softsusy.hepforge.org
arch = x86_64
license = GPL
- makedepends = autoconf
depends = gcc-libs
depends = gcc-fortran
- source = http://www.hepforge.org/archive/softsusy/softsusy-4.1.7.tar.gz
- source = remove_duplicate_header.patch
- sha256sums = 5ff7890e5be9f0affa89016bf6bcaed032700c09e6ea278a6e7fd5d6d4ccb12c
- sha256sums = 75923858486bc404f2147b11cb7691410b83be624ca9b2c6607e9dfee98f1353
+ source = http://www.hepforge.org/archive/softsusy/softsusy-4.1.12.tar.gz
+ sha256sums = 2a5980e80f4346fa511c62050fb2321322090a5e2852766e250af563676f7185
pkgname = softsusy
-
diff --git a/PKGBUILD b/PKGBUILD
index 5e33f09798e6..cda7e4dfa1e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chan Beom Park <cbpark@gmail.com>
pkgname=softsusy
-pkgver=4.1.7
+pkgver=4.1.12
pkgrel=1
pkgdesc="This program provides a SUSY spectrum in the NMSSM, or the MSSM including flavour violation and with or without R-parity consistent with input Standard Model fermion mass/mixings and electroweak/strong coupling data."
arch=("x86_64")
@@ -10,14 +10,17 @@ license=('GPL')
makedepends=("autoconf")
depends=("gcc-libs" "gcc-fortran")
source=("http://www.hepforge.org/archive/softsusy/${pkgname}-${pkgver}.tar.gz"
- "remove_duplicate_header.patch")
-sha256sums=('5ff7890e5be9f0affa89016bf6bcaed032700c09e6ea278a6e7fd5d6d4ccb12c'
- '75923858486bc404f2147b11cb7691410b83be624ca9b2c6607e9dfee98f1353')
+ "remove_duplicate_header.patch"
+ "remove_install_data_local.patch")
+sha256sums=('2a5980e80f4346fa511c62050fb2321322090a5e2852766e250af563676f7185'
+ '363e0537caf14b340d1d1308f768e314f0b14a90455c4ba4eaa2fd41884c369b'
+ '5a58edaa0a73a594d7f9758135f0ce10e7cb01c2d6f2a1b08b37237fc5b12263')
prepare() {
cd "${pkgname}-${pkgver}"
patch -p1 -i "${srcdir}/remove_duplicate_header.patch"
+ patch -p1 -i "${srcdir}/remove_install_data_local.patch"
autoreconf -i
}
@@ -27,7 +30,7 @@ build() {
./configure --prefix=/usr \
--enable-shared=yes \
--enable-static=no
- MAKEFLAGS=-j1 make
+ make
}
package() {
diff --git a/remove_duplicate_header.patch b/remove_duplicate_header.patch
index 2c14a6762813..e3c7ccb24610 100644
--- a/remove_duplicate_header.patch
+++ b/remove_duplicate_header.patch
@@ -1,6 +1,6 @@
diff -rupN a/src/supermodel/supermodel.amk b/src/supermodel/supermodel.amk
---- a/src/supermodel/supermodel.amk 2018-07-05 01:13:34.000000000 +0900
-+++ b/src/supermodel/supermodel.amk 2019-01-04 16:41:13.311359955 +0900
+--- a/src/supermodel/supermodel.amk 2019-04-02 03:31:36.000000000 +0900
++++ b/src/supermodel/supermodel.amk 2021-10-07 13:52:02.243669379 +0900
@@ -36,5 +36,4 @@ src/supermodel/supermodel/sumo_params.h
src/supermodel/supermodel/sumo_smdata.h \
src/supermodel/supermodel/sumo_squarks.h \
diff --git a/remove_install_data_local.patch b/remove_install_data_local.patch
new file mode 100644
index 000000000000..e55062e67e65
--- /dev/null
+++ b/remove_install_data_local.patch
@@ -0,0 +1,23 @@
+diff -rupN a/Makefile.am b/Makefile.am
+--- a/Makefile.am 2021-07-13 00:54:03.000000000 +0900
++++ b/Makefile.am 2021-10-07 14:07:58.321394685 +0900
+@@ -15,7 +15,7 @@ include src/softsusy.amk
+ DOCFILES = doc/rpcManual.pdf doc/rpvManual.pdf doc/neutManual.pdf \
+ doc/nmssmManual.pdf doc/threeLoop.pdf doc/ho.pdf doc/decays.pdf
+ #include doc/doc.amk
+-include inOutFiles/inOut.amk
++#include inOutFiles/inOut.amk
+
+ dist_pkgdata_DATA += CHANGES GUIDELINES COPYING $(DOCFILES)
+
+@@ -37,8 +37,8 @@ updateWeb: dist
+ scp -P 222 -r CHANGES allanach@login.hepforge.org:~/softsusy/public_html/CHANGES.${VERSION}.shtml; \
+ rm -fr html *.tar.gz
+
+-install-data-local:
+- rm -f softsusy.x softsusy-nmssm.x softpoint.x rpvsoftsusy.x rpvneut.x *.la
++#install-data-local:
++# rm -f softsusy.x softsusy-nmssm.x softpoint.x rpvsoftsusy.x rpvneut.x *.la
+
+ # For distributions: don't re-make the docs
+ dist-hook: