summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2021-12-19 13:01:52 +0100
committerPhilipp A2021-12-19 13:01:52 +0100
commit1a4702a29ef0ff27c955f01af17512f68c5a5504 (patch)
tree465c04fcba8ed54a8515e4c985108cdc81b630cc
parent0531929c0171432dada36cb1ce0cfacb06b4d657 (diff)
downloadaur-1a4702a29ef0ff27c955f01af17512f68c5a5504.tar.gz
v0.11.3
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD14
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b0025d0d372e..d23364fdceef 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,15 @@
pkgbase = python-tiledb
pkgdesc = Pythonic interface to the TileDB array storage manager
- pkgver = 0.6.5
+ pkgver = 0.11.3
pkgrel = 1
url = https://github.com/TileDB-Inc/TileDB-Py
arch = x86_64
license = MIT
- makedepends = unzip
- depends = python
- depends = python-setuptools
- depends = python-numpy>=1.16
- noextract = tiledb-0.6.5-cp38-cp38-manylinux1_x86_64.whl
- source = https://files.pythonhosted.org/packages/cp38/t/tiledb/tiledb-0.6.5-cp38-cp38-manylinux1_x86_64.whl
- sha256sums = d8fea3df7543e8704954921c1cd5da1a8f495e38b2e5f28c58550931857a17d6
+ depends = python>=3.10
+ depends = python<3.11
+ depends = python-numpy>=1.21
+ noextract = tiledb-0.11.3-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl
+ source = https://files.pythonhosted.org/packages/cp310/t/tiledb/tiledb-0.11.3-cp310-cp310-manylinux_2_17_x86_64.manylinux2014_x86_64.whl
+ sha256sums = c032c22ecf7eba87fd6e829fe4821e414042550d2456b61ee96f74b78cf3753e
pkgname = python-tiledb
-
diff --git a/PKGBUILD b/PKGBUILD
index 5b4afda9dc35..fdb04387cfb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,21 @@
_name=tiledb
pkgname=python-$_name
-pkgver=0.6.5
+pkgver=0.11.3
pkgrel=1
pkgdesc='Pythonic interface to the TileDB array storage manager'
arch=(x86_64)
url="https://github.com/TileDB-Inc/TileDB-Py"
license=(MIT)
-depends=(python python-setuptools 'python-numpy>=1.16')
-makedepends=(unzip)
-_wheel="${_name/-/_}-$pkgver-cp38-cp38-manylinux1_$CARCH.whl"
-source=("https://files.pythonhosted.org/packages/cp38/${_name::1}/$_name/$_wheel")
-sha256sums=('d8fea3df7543e8704954921c1cd5da1a8f495e38b2e5f28c58550931857a17d6')
+_pyminor=10
+depends=("python>=3.$_pyminor" "python<3.$((_pyminor + 1))" 'python-numpy>=1.21')
+_wheel="${_name/-/_}-$pkgver-cp3$_pyminor-cp3$_pyminor-manylinux_2_17_$CARCH.manylinux2014_$CARCH.whl"
+source=("https://files.pythonhosted.org/packages/cp3$_pyminor/${_name::1}/$_name/$_wheel")
+sha256sums=('c032c22ecf7eba87fd6e829fe4821e414042550d2456b61ee96f74b78cf3753e')
noextract=("$_wheel")
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ local site="$pkgdir/usr/lib/python3.$_pyminor/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
}