summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene Lebedev2020-04-01 13:14:14 +0300
committerEugene Lebedev2020-04-01 13:14:14 +0300
commit1a6cefde2732589eb04c05647ba07cbe0ff1b241 (patch)
tree7e1c99ca68138782ec76bbb36224cc8e8c3b5c2e
downloadaur-1a6cefde2732589eb04c05647ba07cbe0ff1b241.tar.gz
Add fastc-git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD36
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..839ae41e7e1f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fastc-git
+ pkgdesc = A fast texture compressor for various formats
+ pkgver = 679.0f8cef6
+ pkgrel = 1
+ url = https://github.com/GammaUNC/FasTC
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = cmake
+ makedepends = git
+ depends = libpng
+ depends = zlib
+ provides = fastc
+ conflicts = fastc
+ source = fastc::git+https://github.com/GammaUNC/FasTC.git
+ md5sums = SKIP
+
+pkgname = fastc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad45552c832d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Eugene Lebedev <satanych13+dev@gmail.com>
+
+_pkgname=FasTC
+pkgname="fastc-git"
+pkgver=679.0f8cef6
+pkgrel=1
+pkgdesc="A fast texture compressor for various formats"
+arch=('i686' 'x86_64')
+url="https://github.com/GammaUNC/FasTC"
+license=('Apache')
+depends=('libpng' 'zlib')
+conflicts=("fastc")
+provides=("fastc")
+makedepends=('cmake' 'git')
+source=(fastc::git+https://github.com/GammaUNC/${_pkgname}.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd fastc
+ echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+}
+
+build() {
+ mkdir -p fastc/build
+ cd fastc/build
+ cmake ../ -DCMAKE_BUILD_TYPE=Release
+ make
+}
+
+package() {
+ cd fastc
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 ./build/CLTool/tc "$pkgdir/usr/bin/fastc"
+ install -Dm755 ./build/CLTool/compare "$pkgdir/usr/bin/fastc-compare"
+ install -Dm755 ./build/CLTool/decomp "$pkgdir/usr/bin/fastc-decomp"
+}