summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2016-10-21 21:16:41 +0100
committerGrey Christoforo2016-10-21 21:16:41 +0100
commit1a73d4ce1566a5184f2506de6591506a174cff47 (patch)
treef916d8ac71b4881c3926db492752ebb82e1ce84a
parent483526381ec65c33f64304ac22ede63db378fad9 (diff)
downloadaur-1a73d4ce1566a5184f2506de6591506a174cff47.tar.gz
fix python install dir name
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 96e5798cbddd..a195434d2ea4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Oct 21 19:57:04 UTC 2016
+# Fri Oct 21 20:16:37 UTC 2016
pkgbase = uranium
pkgdesc = A Python framework for building Desktop applications.
pkgver = 2.3.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Ultimaker/Uranium
arch = any
license = GPLv3
diff --git a/PKGBUILD b/PKGBUILD
index 57304b173f6f..88ceec1cc1e6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=uranium
pkgver=2.3.0
-pkgrel=1
+pkgrel=2
pkgdesc="A Python framework for building Desktop applications."
url="https://github.com/Ultimaker/Uranium"
arch=('any')
@@ -12,6 +12,12 @@ makedepends=('cmake')
source=("https://github.com/Ultimaker/${pkgname}/archive/${pkgver}.tar.gz")
md5sums=('4e12b8b4c856e8a89b3bba046837b401')
+prepare() {
+ cd Uranium-${pkgver}
+ sed -i 's,DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages,DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages,g' CMakeLists.txt
+ sed -i 's,DESTINATION lib/python${PYTHON_VERSION_MAJOR}/dist-packages/cura),DESTINATION lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages/cura),g' CMakeLists.txt
+}
+
build() {
cd Uranium-${pkgver}
mkdir -p build